MozillaZine

How to put tabs on bottom in FF 29.0?

User Help for Mozilla Firefox
Clueless in Seattle

User avatar
 
Posts: 430
Joined: March 27th, 2006, 11:58 am
Location: duh!

Post Posted April 29th, 2014, 1:09 pm

Apparently I've got Firefox set to automatically update, because suddenly my tabs have been switched to the top of the window (and are now displayed in a difficult to read white type on a dark blue background).

I was able to find a topic with the Subject: How do I put the tab-bar back on bottom in Firefox 29? https://support.mozilla.org/en-US/questions/991043

But I can't seem to find in that thread where is tells how to put the tabs back on the bottom.

And the thread was closed moments ago with this message:

"Guys/gals, this is a solved thread! Please don't comment on solved threads."

"Each of you can create your own question if you have any problems or issues with Firefox 29 by visiting /questions/new"

"I'll be closing this thread to prevent future users commenting on a solved thread."

"Thanks for your understanding!"

But I have to confess that I don't understand.

Can someone explain to me how to put the tabs back on the bottom, where I had them before the update to 29.0?

And while you are at it, could you also tell me how to change the tab display to black letters on light grey background?
Will in Seattle
a.k.a. "Clueless"

Caspid

User avatar
 
Posts: 581
Joined: December 18th, 2005, 4:01 pm

Post Posted April 29th, 2014, 1:12 pm

See viewtopic.php?f=38&t=2824649, at the bottom.
"Know what I pray for? The strength to change what I can, the inability to accept what I can't, and the incapacity to tell the difference." -Calvin

Caspid

User avatar
 
Posts: 581
Joined: December 18th, 2005, 4:01 pm

Post Posted April 29th, 2014, 1:16 pm

Put this in userChrome.css or a Stylish script:
Code: Select all
    .tabbrowser-tab:not([selected=true]) .tab-background {
        background-color: lightgray !important;
        color: black !important;
    }

Is this what you mean?
"Know what I pray for? The strength to change what I can, the inability to accept what I can't, and the incapacity to tell the difference." -Calvin

mightyglydd

User avatar
 
Posts: 9908
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted April 29th, 2014, 5:38 pm

If you like dark elegant Themes try Frank's Tiger SP.. https://addons.mozilla.org/en-US/firefo ... -tiger-sp/ ..Tabs Under and a bunch of additional 'back to sanity' features (Please read them!)
In conjunction with.. https://addons.mozilla.org/en-US/firefo ... erestorer/ ...you'll be a happy camper in no time.
#KeepFightingMichael and Alex.

Clueless in Seattle

User avatar
 
Posts: 430
Joined: March 27th, 2006, 11:58 am
Location: duh!

Post Posted April 29th, 2014, 5:55 pm

I found a work-around solution here:

https://support.mozilla.org/en-US/questions/986465

Chosen Solution

You can look at this extension:

Classic Theme Restorer: https://addons.mozilla.org/firefox/addo ... erestorer/


It solved both problems by restoring the tabs to the bottom position that I had configured in my previous version of FF, and also restored the grey background my bookmarks folders.

It's a shame that we have to resort to an add-on to restore a setting that's been in Firefox ever since the advent of the tabbed format. But I guess I have to be thankful for whatever works.

By the way, it would be nice if the "Check for updates" button would give users the option to say either "yes" or "no" to a proposed update. This morning I clicked that button thinking that the word "check" meant that it would just check to see if there was an update and report back to me. But instead it just went ahead and updated that computer to version 29.0

And then shortly thereafter another computer that I mistakenly had set to automatically update suddenly turned up running 29.0

I've since gone into options and turned off that automatic updates setting. And I'm making my Firefox mantra from now on to be: "Never 'check' for updates!"

Having the GUI change like that without warning is like waking up one morning to find that the landlady has let herself into my apartment while I slept and taken the dishes and silverware from the kitchen and hidden them in the attic. And taken my address book from my desk and buried it in a flower pot out in the garden.

It would be nice if they could offer us a picture of how a new version will look before updating and giving us the option to say "No, thanks." I realize that there are security reasons for updating Firefox, but wouldn't it be more considerate of users' needs to separate the GUI updates from the security updates? I'm severely disabled by chronic illness and have great difficulty sitting up at my computer for more than a few minutes at a time. My computer is my main lifeline to the outside world so I have to keep it working. And I struggle to just get through the most basic tasks of living each day, and have precious little time or energy to spend trying to figure out how to undo needless and confusing changes in my user interface.

But I suppose that this forum is not the appropriate place to offer my opinions about software design
Will in Seattle
a.k.a. "Clueless"

Derek Shaw
 
Posts: 182
Joined: May 9th, 2006, 9:24 am

Post Posted April 30th, 2014, 10:02 am

I found an Add-on

Tabs on Bottom 0.3

which is working for me but I agree this should be an Option within Firefox without having to resort to an Add-on

Derek Shaw

jeffweaver25
 
Posts: 1
Joined: May 4th, 2014, 4:53 am

Post Posted May 4th, 2014, 4:57 am

Disappointed user here. Someone from MicroSoft must have been involved because now FF better knows what I want than I do. Sound familiar?

This worked for me. I cobbled it together from various posts.

(1) Select Help->Troubleshooting Information
(2) For Profile Folder: push the [Show Folder] button
(3) Navigate into the chrome folder. If it is not already there, create a subdirectory called chrome and navigate into it.
(4) Edit or create the userChrome.css. Make sure these lines are in the file and save it.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#TabsToolbar{-moz-box-ordinal-group:10000!important}

(5) Close all Firefox windows and dialogs and restart Firefox.

Phantoms

User avatar
 
Posts: 136
Joined: October 24th, 2006, 7:15 pm

Post Posted May 4th, 2014, 8:54 am

jeffweaver25 wrote:Disappointed user here. Someone from MicroSoft must have been involved because now FF better knows what I want than I do. Sound familiar?

This worked for me. I cobbled it together from various posts.

(1) Select Help->Troubleshooting Information
(2) For Profile Folder: push the [Show Folder] button
(3) Navigate into the chrome folder. If it is not already there, create a subdirectory called chrome and navigate into it.
(4) Edit or create the userChrome.css. Make sure these lines are in the file and save it.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#TabsToolbar{-moz-box-ordinal-group:10000!important}

(5) Close all Firefox windows and dialogs and restart Firefox.



Thank you Jeff.

What a DUMBA$$ move by the FF developers. I'm about to the point of dropping FF altogether.

Anonymosity
 
Posts: 8621
Joined: May 7th, 2007, 12:07 pm

Post Posted May 4th, 2014, 1:56 pm

Try SeaMonkey. It is much better. It is not being gutted.

kukla
 
Posts: 855
Joined: December 30th, 2008, 3:59 pm

Post Posted May 4th, 2014, 4:18 pm

Clueless in Seattle wrote:By the way, it would be nice if the "Check for updates" button would give users the option to say either "yes" or "no" to a proposed update. This morning I clicked that button thinking that the word "check" meant that it would just check to see if there was an update and report back to me. But instead it just went ahead and updated that computer to version 29.0

And then shortly thereafter another computer that I mistakenly had set to automatically update suddenly turned up running 29.0

I've since gone into options and turned off that automatic updates setting. And I'm making my Firefox mantra from now on to be: "Never 'check' for updates!"

Having the GUI change like that without warning is like waking up one morning to find that the landlady has let herself into my apartment while I slept and taken the dishes and silverware from the kitchen and hidden them in the attic. And taken my address book from my desk and buried it in a flower pot out in the garden.


You can avoid this in the future by getting the Add-on Check for Updates in Help Menu. Let's you just check without updating. Firefox used to have this feature.

https://addons.mozilla.org/en-us/firefo ... nu-update/

makaiguy

User avatar
 
Posts: 16867
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted May 4th, 2014, 8:50 pm

jeffweaver25 wrote:#TabsToolbar{-moz-box-ordinal-group:10000!important}


That magic line put my tabs back directly at the top of the display area, i.e. below all the tool bars, where I want them. Thank you kind sir. =D>
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 80.0.1 (64bit), TB 68.12.0 (32-bit) ║ Android 10/7.1.1: FF Mobile 80.1.3, No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

nisakiman
 
Posts: 3
Joined: May 8th, 2014, 8:51 am

Post Posted May 8th, 2014, 9:16 am

I didn't like at all the 'tabs on top' layout, always having had the tabs on bottom, so I checked to see what I could do. So I downloaded 'Tabs on bottom 0.5' and installed it, and sure enough, it shifted the tabs to the bottom. But there has appeared a blank bar above the tabs, and the top of the web page almost completely obscures the tabs - I can see barely a sliver of the tab above the page. So I disabled that and looked again, and found 'Classic theme restorer'. So I downloaded that and hit the 'tabs on bottom' option, and bugger me exactly the same thing has happened - a blank bar has appeared above the tabs bar, and the tabs are hidden behind the top of the window. Does anyone know what I'm doing wrong? I'm using the Lava-Fox blue skin, but that's never been a problem in the past. Where has this blank bar appeared from, and why? I should add that I'm not a wizz with computer related stuff - I just use it, so suggestions like jeffweaver25's

"(1) Select Help->Troubleshooting Information
(2) For Profile Folder: push the [Show Folder] button
(3) Navigate into the chrome folder. If it is not already there, create a subdirectory called chrome and navigate into it.
(4) Edit or create the userChrome.css. Make sure these lines are in the file and save it.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#TabsToolbar{-moz-box-ordinal-group:10000!important}"


go right over my head. It is probably the best solution, but I'm afraid I haven't got a clue what he means.

Any help would be much appreciated. Meanwhile, I'll have to go back to 'tabs on top', which I really don't like.

Gingerbread Man

User avatar
 
Posts: 7744
Joined: January 30th, 2007, 10:55 am

Post Posted May 8th, 2014, 10:08 am

nisakiman wrote:But there has appeared a blank bar above the tabs, and the top of the web page almost completely obscures the tabs - I can see barely a sliver of the tab above the page.

First, try resetting the toolbar setup: right-click an empty area of the tab bar and choose Customize, then click the Restore Defaults button.

If that doesn't solve the problem, it may be a theme issue. Open the Add-ons Manager, Appearance category. Next to the default theme, click the Enable button and restart Firefox.

If there's no improvement, here are directions for the user style you're interested in:
  1. Launch a text editor like Notepad and paste the following in it:
    Code: Select all
    @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

    #TabsToolbar { -moz-box-ordinal-group: 10000 !important }
  2. Save the file as "userChrome.css" to the desktop. Be sure to include the quotation marks, and note that the filename is case-sensitive: that's a lowercase u at the beginning and a capital C.
  3. In Firefox, type about:support into the address bar and press Enter. On the page that opens, click the Show Folder button.
  4. In the Windows Explorer window that opened, right-click an empty area and choose New, then Folder. Name the folder chrome — note it's all lowercase.
  5. Open the chrome folder and move the userChrome.css file into it.
  6. Restart Firefox for the changes to take effect.

nisakiman
 
Posts: 3
Joined: May 8th, 2014, 8:51 am

Post Posted May 8th, 2014, 1:18 pm

Many thanks for your very helpful reply. With your clear explanation, I was able to negotiate what at first glance looked to be a complex issue! However, I ended up with the exact same hidden tab situation, so reluctantly concluded that it must be the theme I was using that was causing the problems. And sure enough, when I went back to the default theme, all was well, and with the tabs bar at the bottom too! It's a shame - I've been using the Lava-blue theme for years, and was very comfortable with it. Oh well, looks like it's time for change. I'm sure I'll find another theme that I like. :)

Once again, thanks for taking the time to talk me through the modification. I really do appreciate it.

Gingerbread Man

User avatar
 
Posts: 7744
Joined: January 30th, 2007, 10:55 am

Post Posted May 8th, 2014, 1:34 pm

nisakiman wrote:Many thanks for your very helpful reply.

You're quite welcome.
nisakiman wrote:It's a shame - I've been using the Lava-blue theme for years, and was very comfortable with it.

What version are you using? Version 2.2.1 was apparently made available as an update yesterday. If that doesn't solve the problem, you can try version 2.2.2 which hasn't been reviewed yet.
:arrow: https://addons.mozilla.org/firefox/addon/lavafox-v1-blue/versions/

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 8 guests