MozillaZine

Firefox using 100% CPU...????

User Help for Mozilla Firefox
Killah Mike
Guest
 

Post Posted June 23rd, 2005, 12:20 am

Whenever I start up Firefox my CPU useage fires straight up to around 99-100% and stays there. It lags my system terribly. I can't figure out what the problem is. I'm running Windows XP SP2 and plenty of power for a browser. IE averages like 2% CPU useage. Does anyone know how I can fix this problem?

--Mike

greenknight

User avatar
 
Posts: 6158
Joined: December 13th, 2004, 2:28 am
Location: In the shadow of Mount St. Helens

Post Posted June 23rd, 2005, 12:58 am

Try opening the browser in Firefox Safe Mode (Start -> All Programs -> Mozilla Firefox -> Mozilla Firefox Safe Mode). If the problem doesn't occur in Safe Mode, it's almost certainly a theme or extension problem.

Try the default theme, and try uninstalling extensions one at a time, testing after each one, to locate the problem.

If that doesn't help, try creating a new profile (don't delete the old one yet): http://www.mozilla.org/support/firefox/profile#new

If the problem is gone when running a clean profile, then do this: http://the-edmeister.home.comcast.net/t ... _data.html

Guest
Guest
 

Post Posted June 23rd, 2005, 1:09 am

I tried everything you suggested and none of it worked. I've also tried reinstalling it multiple times. Oddly enough, Netscape 8.0, it also does this same exact thing. It makes me wonder if it just has something to do with the Firefox engine itself. I have absolutely no idea how to fix this thing which leaves me stuck on I.E.

Thanks for the attempted help. I appreciate the effort.

--Mike

greenknight

User avatar
 
Posts: 6158
Joined: December 13th, 2004, 2:28 am
Location: In the shadow of Mount St. Helens

Post Posted June 23rd, 2005, 5:08 am

The only thing I can think of is that it could be a problem with a plug-in, since Netscape and Firefox share some of them.

I was going to suggest uninstalling Firefox and deleting the Mozilla Firefox installation folder in C:/Program Files, >edit< so you re-install in a new directory. I guess you could do that with Netscape at the same time.

Some plug-ins would be deleted by doing this, Flash and Shockwave, for instance.

It wouldn't hurt to clean your hard drive and registry while you're at it, I recommend CCleaner: http://www.ccleaner.com/

Then re-install and maybe you'll see some improvement, at least I hope so.
Last edited by greenknight on June 24th, 2005, 1:37 am, edited 2 times in total.

AnotherGuest.
 
Posts: 2158
Joined: December 22nd, 2004, 11:47 am

Post Posted June 23rd, 2005, 6:21 am

Check to see if your computer has hyperthreading. There is a bug in some recent Intel processors. Fortunately, it's easy to fix.

Also double-check. Make sure you created a new profile and ran Fx in it.

If both of those fail, uninstall Fx and reinstall it <i>in a new directory.</i>

Killah Mike
Guest
 

Post Posted July 2nd, 2005, 10:44 pm

Thank you all for the help. I went through all the suggestions and nothing worked. I made sure to try each thing twice just to make sure I wasn't making any errors. I really just can't figure this thing out at all. It's ashame too, I loved using Firefox. Thanks again to everyone that replied. I appreciate the attempts.

--Mike

pikaunforgiven
 
Posts: 1004
Joined: May 9th, 2005, 9:58 am
Location: um that place, the one with the stuff

Post Posted July 3rd, 2005, 1:13 am

do you happen to have a java, javascript, or flash heavy website as your homepage? if so this could be the cause of it. other than that im kinda clueless myself.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 12 guests