MozillaZine

Firefox 33 using High amount of CPU

User Help for Mozilla Firefox
Firefoxuser81
 
Posts: 3
Joined: October 18th, 2014, 12:28 pm

Post Posted October 18th, 2014, 12:48 pm

Hi I have been using Firefox on windows 7 fine up until now, however I now have a problem after updating to the latest version.

In task manager firefox is using constant 50%+ CPU (at 50 degrees) for no reason I can see (it is basically roasting the cpu) It doesnt seem to be on specific pages.

On previous versions it has spiked a bit then gone down to a few percent of cpu usage.

Ive tried so far -

-Disabling flashplayer addon (I dont think it is a flashplayer issue? But havent tried installing a previous version of flashplayer, might this help?)
-Disabling addons
-Deleting my profile and then deleting firefox and going back to previous versions 33 then back to 32. It was okay for a while and the same issue.

I have now installed 28 (and going to see if it solves it) im not happy obviously as this is a security risk (i am running it in sandboxie though). How much of a risk is this in terms of security? I will see if it solves it...

What is weird is that all the versions up until the latest firefox didnt have this issue, but if I go back to them now it still has this problem. As I say I am running 28 at the moment and will see if it reoccurs...

As you can imagine this is a very annoying problem to have as I use the internet alot (and I dont want my CPU being roasted 24/7 for no reason and am not sure what to do to solve it. (the only thing that I am carrying over in a reinstall is a file containing all my bookmarks and some of these folders I open all in tabs at once and have alot of tabs open at once (this hasnt been an issue before as I only have a small number loaded up at any one time). Could my Bookmarks file be corrupted and causing this in anyway?

Is it a problem with my computer or is it an issue with the latest version of firefox or flashplayer and do you think it will get solved in the next release/update?

Ive tried everything I can think of and am not sure what to do (whether the problem is firefox or my computer or malware (Ive checked and I dont think ive got any malware).

Many thanks for your help.

JayhawksRock

User avatar
 
Posts: 10433
Joined: October 24th, 2010, 8:51 am

Post Posted October 18th, 2014, 1:09 pm

Try going into Addons > Plugins and disable everything there except Shockwave Flash and into Extensions and disable any/all extensions related to your Antivirus Software and/or security. Restart Firefox and see what you get... All bets are off if you have a gazillion tabs open.
"The trouble with quotes on the internet is you never know if they are genuine" ...Abraham Lincoln

Firefoxuser81
 
Posts: 3
Joined: October 18th, 2014, 12:28 pm

Post Posted October 18th, 2014, 1:17 pm

Hi I think I did disable just about every addon and extension and it didnt seem to solve it.

I have quite an impressive amount of tabs stored over quite a few tab groups when using my computer in normal use (and havent had a problem with it so far) are you saying I should cut down the amount of tabs I have open? what would be an acceptable amount of tabs to have open (max).

I will try and close as many tabs as possible and keep the rest bookmarked then and see if it improves thanks for your help.

(im running firefox 28 now with a load of tabs open (only a few active though) and have about 4 websites open (e.g. ebay, this site, and running a flash video and the cpu usage is a few percent now (after spiking now and then).

When running 33 and 32 it was using about 50%+ cpu just with one tab active and with bing/ebay and a flashplayer video it was using 50+ CPU nonstop.

at the moment using 28 it is even running the flash video and it is max about 5% cpu usage.

Neko-

User avatar
 
Posts: 11
Joined: November 27th, 2004, 3:48 am
Location: The Netherlands

Post Posted October 19th, 2014, 2:25 am

Running into the same thing here. As of version 33 Firefox has shown a tendency to slow down displaying of pages all of a sudden, at which point pages show mostly black, until you wait for some 30 to 60 seconds before they show up again (slowly). Switching between tabs slows down to a crawl.

Does this on pages that have flash, and on pages that have no flash. Taskmanager shows excessive CPU usage for the Firefox*32.exe process. Killing the process and restarting Firefox seems to briefly solve it. Atleast I had to repeat that action some 5 times in the last 5 minutes to finally get Firefox to behave again. Never had the problems with version 32 or prior.

Frank Lion

User avatar
 
Posts: 20816
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted October 19th, 2014, 4:05 am

Neko- wrote:Running into the same thing here. As of version 33 Firefox has shown a tendency to slow down displaying of pages all of a sudden, at which point pages show mostly black, until you wait for some 30 to 60 seconds before they show up again (slowly). Switching between tabs slows down to a crawl.

Does this on pages that have flash, and on pages that have no flash. Taskmanager shows excessive CPU usage for the Firefox*32.exe process. Killing the process and restarting Firefox seems to briefly solve it. Atleast I had to repeat that action some 5 times in the last 5 minutes to finally get Firefox to behave again. Never had the problems with version 32 or prior.


1) Select : Menu > Help > Restart with Add-ons Disabled.
2) OK the 'Start in Safe Mode' box.
3) Menu > Tools > Options > Advanced > General Tab.
4) Uncheck the "Use hardware acceleration when available" checkbox.
5) Restart Firefox
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Neko-

User avatar
 
Posts: 11
Joined: November 27th, 2004, 3:48 am
Location: The Netherlands

Post Posted October 19th, 2014, 6:00 am

And then? The Add-Ons are part of my FireFox expirience. Not that I have many (9 total), but killing them off seems somewhat excessive. Especially since more often than not when using FF with add-ons enabled doesn't run into any problems

Hardware acceleration has been on since forever, and whule I can see that as a possible cause (it's disabled now, lets see what happens), disabling the add-ons isn't really something feasable for the long-run.
I reject your reality, and substitute my own - Adam Savage

Frank Lion

User avatar
 
Posts: 20816
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted October 19th, 2014, 6:46 am

Neko- wrote:And then? The Add-Ons are part of my FireFox expirience. Not that I have many (9 total), but killing them off seems somewhat excessive. Especially since more often than not when using FF with add-ons enabled doesn't run into any problems.

WTF? You butt into someone else's thread and then bang on about Jay suggesting a temporary troubleshooting method.

What would you suggest the OP does, just stare at the extensions?

Hardware acceleration has been on since forever, and whule I can see that as a possible cause

Yeah, especially as there is a Sticky at the head of this forum about it - viewtopic.php?f=38&t=2879933

Bet you're from North Holland.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Neko-

User avatar
 
Posts: 11
Joined: November 27th, 2004, 3:48 am
Location: The Netherlands

Post Posted October 19th, 2014, 6:59 am

Frank Lion wrote:WTF? You butt into someone else's thread and then bang on about Jay suggesting a temporary troubleshooting method.

What would you suggest the OP does, just stare at the extensions?

No. I can disable the extensions, but if that solves the matter of FF eating excessive CPU cycles it's a temp solution. Tho it might help in finding out anything regarding a possible extension that causes the problem if any. Then again, the extensions have been the same for quite a number of versions for me, so they're not a primary culprit for me. Especially since the problem cropped up with the last release.

Frank Lion wrote:Yeah, especially as there is a Sticky at the head of this forum about it - viewtopic.php?f=38&t=2879933

Bet you're from North Holland.

And that thread is news to me... I only thought to jump in to underline someone having the same problem, instead of starting a new thread and making everything convoluted. If your response could've pointed out that thread in your first reaction, that probably would've made it clearer than the response given to disable all add-ons and kill HW acceleration. Especially since it seems that just that last one is mentions as solution 1 and thus should be sufficient.

On a personal note: I am NOT from the province of North Holland, and I fail to see what that has to do with the whole issue.
I reject your reality, and substitute my own - Adam Savage

Frank Lion

User avatar
 
Posts: 20816
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted October 19th, 2014, 7:08 am

Neko- wrote: I only thought to jump in to underline someone having the same problem, instead of starting a new thread and making everything convoluted.

Yeah, because one person's problem on one thread is more convoluted than people with different problems on the same thread.

You see the OP saying any of this? -

Running into the same thing here. As of version 33 Firefox has shown a tendency to slow down displaying of pages all of a sudden, at which point pages show mostly black, until you wait for some 30 to 60 seconds before they show up again (slowly). Switching between tabs slows down to a crawl.


No. You have a different problem.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Firefoxuser81
 
Posts: 3
Joined: October 18th, 2014, 12:28 pm

Post Posted October 19th, 2014, 7:20 am

Hi again. Thanks for your help so far.

I have been using firefox 28 all day and the cpu usage has been <5% with my usual number of (loads of tabs and windows open) and a few websites being active (including flash). and plugins activated. (hopefully it will continue behaving like this, so far so good).

Im running firefox 28 in sandboxie. Would it be safe from a security standpoint if I just used this without updating firefox for a few months (or six months) and then tried deleting 28 and upgrading to the new version of firefox around at that time (and hoping it runs okay again?)

I dont understand why 32 didnt have this issue and then upgrading to 33 has the cpu issue, yet when I move back to 32 now it exibits the same issue. (28 seems fine so far as I say).

Could it be that something else (e.g. third party wise e.g. flashplayer or websites, or something else HAS been updated recently and isnt working well alongside 33 (and now 32 which was working fine?) rather than firefox being the issue? (in how each thing interacts) Sorry just surmising really....

dfoulkes

User avatar
 
Posts: 22575
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted October 19th, 2014, 10:10 am

I dont understand why 32 didnt have this issue and then upgrading to 33 has the cpu issue, yet when I move back to 32 now it exibits the same issue. (28 seems fine so far as I say).

There have been many, many posts around here where AV software did not update its database properly with respect to Firefox updating... and that also happens at times with Firewalls.
http://kb.mozillazine.org/Firewalls
http://kb.mozillazine.org/Firefox_CPU_usage
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

therube

User avatar
 
Posts: 20551
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted October 31st, 2014, 12:42 am

> province of North Holland

LOL, good clip, though I was expecting the last line to have been ...and a partridge in a pear tree :-).
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

RobertsV
New Member
 
Posts: 1
Joined: November 14th, 2014, 2:21 pm

Post Posted November 14th, 2014, 2:27 pm

One of my computers had this problem. I found that going to Options->Advanced->Updates and turning updates from 'Automatically install updates' to 'Check for Updates' completely fixed this issue. Obviously there is some bug in the update code that is causing this.

the traveller

User avatar
 
Posts: 20
Joined: November 7th, 2014, 2:50 pm

Post Posted November 14th, 2014, 7:26 pm

I'm sure this will be moved somewhere or just omitted. Does the NSA rule?
It's difficult for anyone to solve every-ones problems since setups and extensions and plugs and....Chrome, IE, Fx,...etc. has problems with this one and that one. Windows has been a F(wats)up since I started using v3.0. Some people have so much xxx running in the back ground that even the best systems fall to their knees. Check your resources...what is using what...stop the process (if your comfortable with it)....do a back-up and experiment. Tons of good info on line...tons crap too. Some people here are just trying to help you(us). Shut your keyboard and open your mind. Self explanatory for some, if not...shut your mouth and open your ears (eyes)...same deal. Hey? got a problem with your system? send it to me with return postage and I will fix it...if not...LEARN. this is a smart
(donkey) comment:) Please don't sent me negative vibes because it just feeds me.
Last edited by Daifne on November 15th, 2014, 7:37 am, edited 1 time in total.
Reason: Unallowed word removed
REMEMBER; amateurs built the ark. Professionals built the Titanic

mightyglydd

User avatar
 
Posts: 9908
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted November 14th, 2014, 8:19 pm

the traveller wrote:Please don't sent me negative vibes..


http://www.youtube.com/watch?v=KuStsFW4EmQ
#KeepFightingMichael and Alex.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 9 guests