MozillaZine

Many add ons disappeared (Solved)

User Help for Mozilla Firefox
pschroeter
 
Posts: 126
Joined: September 3rd, 2004, 1:19 pm

Post Posted November 14th, 2014, 12:11 pm

Today I started up Firefox 33.1 only to find many of my add ons have disappeared and are not listed in the Add-ons Manager anymore. I still have some add ons both enabled and disabled listed. I would have blamed the recent 33.1 upgrade except I would have expected to see the missing add-ons disabled, but they are gone. I've run two malware scans and have Avast installed.

Update: November 15
I find it suspicious that this problem happened the day after the Firefox 3.1 upgrade came out. Also, I could not last one whole day with Austalis. I have just manually reinstalled all the missing extensions that I can remember because I have to have Classic Theme Restorer or I'll go nuts. I also upgraded Avast in case it was part of the problem.

I don't necessarily consider the problem solved because I still don't know what happened in the first place and worry it can happen again at any time. I welcome any ideas that might explain it.

People on the Avast forum are noticing this too. The phrase "HTTPS Scanning" keeps coming up.

Update: November 15 #2
Spoke too soon. The computer started up twice okay with the reinstalled add ons. The third time something turned only Classic Theme Restorer off and left the other re-installed add-ons alone (so far). The third time Austalis was back and Classic Theme Restorer still showed in the Add-ons Manager, but when I clicked on it, it made the browser crash, and was no longer listed when I restarted Firefox.

Update: November 17
I found this post (Latest Avast reportedly deleting Firefox add-ons) on http://www.ghacks.net/2014/11/16/latest ... nt-2944764

Ficho November 17, 2014 at 5:58 pm #

lukor (Avast team):
Hi guys,
thanks to all for the information posted. We have been able to identify the problem now. Browser Cleanup is responsible for this issue. A bug in the component calculating hashes of the extension packages cause (only in some rare cases) deletion of the wrong file - the original instead the packed one.

Sorry for that and thanks again for your help obtaining the repro steps for us.

The Browser Cleanup team is now working on a fix, which will be delivered via a VPS update shortly (tomorrow).

Lukas


Update December December 8
I forgot to mention the Avast VPS update seemed to have fixed my problem. I wanted to try it for awhile first. Of course, the recent Firefox 34.0 update broke a couple of my search extensions which I had to fix, but that is another story.
Last edited by pschroeter on December 8th, 2014, 2:56 pm, edited 5 times in total.

DanRaisch
Moderator

User avatar
 
Posts: 121588
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 14th, 2014, 12:25 pm

Are you using Firefox Sync?

JBradND
 
Posts: 4
Joined: November 14th, 2014, 1:10 pm

Post Posted November 14th, 2014, 1:14 pm

The same thing happened to me today. Adblock plus, tab mix plus, classic theme, and other add ons have disappeared from firefox. The only extension that I can see is avast online security which I have disabled. It looks like all of my plugins are still there. I am not using Firefox Sync.

Erroneus

User avatar
 
Posts: 63
Joined: November 12th, 2004, 1:42 am
Location: Denmark

Post Posted November 14th, 2014, 2:13 pm

I have the exact same problem. I've turned off firefox sync of addons on my other machines, but still just vitnessed that some of my addons dissapeared.

Using Firefox 33.1. Something is messed up.

Turned off addon sync on this machine also, because this is very annoying.

Erroneus

User avatar
 
Posts: 63
Joined: November 12th, 2004, 1:42 am
Location: Denmark

Post Posted November 14th, 2014, 2:35 pm

Hmm, I'm also using avast online security.

Do you use Avast pschroeter?

I've just turned of HTTPS scanning in Avast, as it has caused crashes in Firefox. This could very well be the culprit.

pschroeter
 
Posts: 126
Joined: September 3rd, 2004, 1:19 pm

Post Posted November 14th, 2014, 4:27 pm

JBradND wrote:The same thing happened to me today. Adblock plus, tab mix plus, classic theme, and other add ons have disappeared from firefox.


This is spooky because I had all three of the same add ons you mention disappear, as well a several others, like Scrapbook. Since something got rid of Classic Theme Restore I am completely lost in an interface I don't like or understand.

pschroeter
 
Posts: 126
Joined: September 3rd, 2004, 1:19 pm

Post Posted November 14th, 2014, 4:32 pm

Erroneus wrote:Hmm, I'm also using avast online security.

Do you use Avast pschroeter?

I've just turned of HTTPS scanning in Avast, as it has caused crashes in Firefox. This could very well be the culprit.


Yes I use Avast as my antivirus. I don't understand what "HTTPS scanning" is and is it safe to shut off. I see a common thread of Avast in the people who have responded to my post. I wonder if they updated their heuristics in a way that suddenly didn't like these add ons. I know a couple weeks ago Avast suddenly didn't like a utility I have been using for ten years between two different computers that it had been okay with me running for the past year.

malliz
Folder@Home

User avatar
 
Posts: 43708
Joined: December 7th, 2002, 4:34 am
Location: Australia

Post Posted November 14th, 2014, 4:42 pm

The HTTPs scanner is a recent addition to avast since the new version came out. From all reports it does not play nicely with Firefox.
Edit: I will ad the caveat that I don't know how it could be removing Firefox Extensions as far as I know it's more a blocking/warning thing

http://www.ghacks.net/2014/10/31/avasts ... -programs/
What sort of man would put a known criminal in charge of a major branch of government? Apart from, say, the average voter.
"Terry Pratchett"

Gopher John

User avatar
 
Posts: 1764
Joined: May 8th, 2008, 3:42 pm
Location: Northwest Ohio

Post Posted November 14th, 2014, 7:30 pm

Avast fixed a problem with Firefox crashing after close with one of it's VPS releases. Avast stopped the https scanning of Firefox checking for extension updates. Firefox also made their closing housework more robust.

I haven't had a crash since. I've also had a few extensions update (including AdBlock Plus) with no problems.
The significant problems we face cannot be solved at the same level of thinking we were at when we created them. - Albert Einstein

Erroneus

User avatar
 
Posts: 63
Joined: November 12th, 2004, 1:42 am
Location: Denmark

Post Posted November 15th, 2014, 5:04 am

Which was a week ago, this is a new issue.

Gopher John

User avatar
 
Posts: 1764
Joined: May 8th, 2008, 3:42 pm
Location: Northwest Ohio

Post Posted November 15th, 2014, 7:19 am

Erroneus wrote:Which was a week ago, this is a new issue.


I have 8 Firefox profiles scattered across 3 laptops on Win 7 Pro SP1 with the one with the most extensions having 26 extensions and am having no problems with HTTPS scanning. I am not losing any extensions. All extensions are current with https://addons.mozilla.org/en-US/firefox/extensions/ and have not been modified in any way.

I'm using Avast Internet Security 2015 10.0.2208. The one thing that I'm not using is Firefox Sync.
The significant problems we face cannot be solved at the same level of thinking we were at when we created them. - Albert Einstein

Alice0775

User avatar
 
Posts: 2710
Joined: October 26th, 2007, 11:25 pm
Location: OSAKA JPN

Post Posted November 15th, 2014, 7:33 am

I have no problem with avast 10.
But I suspect Avast Browser Cleanup Tool.

Gopher John

User avatar
 
Posts: 1764
Joined: May 8th, 2008, 3:42 pm
Location: Northwest Ohio

Post Posted November 15th, 2014, 8:01 am

Avast Browser Cleanup Tool does require the user to click on the requester and approve the removal, so one has the option not to allow such action beforehand.
The significant problems we face cannot be solved at the same level of thinking we were at when we created them. - Albert Einstein

Erroneus

User avatar
 
Posts: 63
Joined: November 12th, 2004, 1:42 am
Location: Denmark

Post Posted November 15th, 2014, 8:32 am

Interesting. I've activated add-ons sync in Firefox sync settings again, to see what's going to happen.

HTTPS scanning is still being kept off in Avast.

But I'm still being hit with Firefox sync errors.

1416065291734 Sync.Service INFO Loading Weave 1.35.0
1416065291735 Sync.Engine.Clients DEBUG Engine initialized
1416065291736 Sync.Engine.Clients DEBUG Resetting clients last sync time
1416065291739 Sync.Engine.Bookmarks DEBUG Engine initialized
1416065291741 Sync.Engine.Forms DEBUG Engine initialized
1416065291743 Sync.Engine.History DEBUG Engine initialized
1416065291745 Sync.Engine.Passwords DEBUG Engine initialized
1416065291747 Sync.Engine.Prefs DEBUG Engine initialized
1416065291748 Sync.Engine.Tabs DEBUG Engine initialized
1416065291749 Sync.Engine.Tabs DEBUG Resetting tabs last sync time
1416065291752 Sync.Engine.Addons DEBUG Engine initialized
1416065291752 Sync.Service INFO Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
1416065291754 Sync.SyncScheduler DEBUG Clearing sync triggers and the global score.
1416065291755 Sync.Status DEBUG Status.service: success.status_ok => success.status_ok
1416065291755 Sync.Service DEBUG Caching URLs under storage user base: https://sync-129-us-west-2.sync.service ... 5/9714023/
1416065291755 Sync.Status DEBUG Status.service: success.status_ok => success.status_ok
1416065291755 Sync.AddonsReconciler INFO Registering as Add-on Manager listener.
1416065291755 Sync.AddonsReconciler DEBUG Adding change listener.
1416065291755 Sync.Tracker.History INFO Adding Places observer.
1416065291758 Sync.Status DEBUG Status.service: success.status_ok => success.status_ok
1416065291758 Sync.Engine.Greasemonkey DEBUG Engine initialized
1416065291760 Sync.Engine.AdblockPlus DEBUG Engine initialized
1416065291761 Sync.Status DEBUG Status.service: success.status_ok => success.status_ok
1416065291764 FirefoxAccounts DEBUG got keyPair
1416065291764 FirefoxAccounts DEBUG getCertificateSigned: true true
1416065292596 FirefoxAccounts DEBUG getCertificate got a new one: true
1416065292596 FirefoxAccounts DEBUG getAssertionFromCert
1416065292597 FirefoxAccounts DEBUG getAssertionFromCert returning signed: true
1416065292597 Sync.BrowserIDManager DEBUG Getting a token
1416065293427 Sync.BrowserIDManager DEBUG Successfully got a sync token
1416065293428 Sync.BulkKeyBundle INFO BulkKeyBundle being created for undefined
1416065293428 Sync.BrowserIDManager INFO Background fetch for key bundle done
1416065293428 Sync.Status DEBUG Status.login: success.login => success.login
1416065293428 Sync.Status DEBUG Status.service: success.status_ok => success.status_ok
1416065295762 Sync.Status DEBUG Status.service: success.status_ok => success.status_ok
1416065295762 Sync.Service DEBUG User-Agent: Firefox/33.1 FxSync/1.35.0.20141106120505.
1416065295762 Sync.Service INFO Starting sync at 2014-11-15 16:28:15
1416065295762 Sync.Service DEBUG In sync: should login.
1416065295762 Sync.Status DEBUG Status.service: success.status_ok => success.status_ok
1416065295762 Sync.Status DEBUG Status.service: success.status_ok => success.status_ok
1416065295763 Sync.Service INFO Logging in the user.
1416065295763 Sync.Service DEBUG Caching URLs under storage user base: https://sync-129-us-west-2.sync.service ... 5/9714023/
1416065295763 Sync.BrowserIDManager DEBUG _ensureValidToken already has one
1416065296398 Sync.Resource DEBUG mesg: GET success 200 https://sync-129-us-west-2.sync.service ... ollections
1416065296398 Sync.Resource DEBUG GET success 200 https://sync-129-us-west-2.sync.service ... ollections
1416065296398 Sync.Service DEBUG Fetching global metadata record
1416065296399 Sync.BrowserIDManager DEBUG _ensureValidToken already has one
1416065296604 Sync.Resource DEBUG mesg: GET fail 503 https://sync-129-us-west-2.sync.service ... eta/global
1416065296604 Sync.Resource DEBUG GET fail 503 https://sync-129-us-west-2.sync.service ... eta/global
1416065296605 Sync.Service DEBUG Clearing cached meta record. metaModified is undefined, setting to 1416000335.16
1416065296605 Sync.BrowserIDManager DEBUG _ensureValidToken already has one
1416065296808 Sync.Resource DEBUG mesg: GET fail 503 https://sync-129-us-west-2.sync.service ... eta/global
1416065296808 Sync.Resource DEBUG GET fail 503 https://sync-129-us-west-2.sync.service ... eta/global
1416065296808 Sync.Service DEBUG No meta/global record on the server. Creating one.
1416065296808 Sync.BrowserIDManager DEBUG _ensureValidToken already has one
1416065296809 Sync.Resource DEBUG PUT Length: 127
1416065297015 Sync.Resource DEBUG mesg: PUT fail 503 https://sync-129-us-west-2.sync.service ... eta/global
1416065297015 Sync.Resource DEBUG PUT fail 503 https://sync-129-us-west-2.sync.service ... eta/global
1416065297015 Sync.Service WARN Unable to upload new meta/global. Failing remote setup.
1416065297015 Sync.Service WARN Remote setup failed.
1416065297015 Sync.SyncScheduler DEBUG Clearing sync triggers and the global score.
1416065297015 Sync.SyncScheduler DEBUG Next sync in 3600000 ms.

SachinF
 
Posts: 2
Joined: November 14th, 2014, 7:05 pm

Post Posted November 15th, 2014, 9:19 am

Anyone managed to fix this? My addons have disappeared too. I use avast as my anti virus. Can I get my addons back with my preference?
Thanks

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 10 guests