MozillaZine

Firefox 37 and Sync Weave error

User Help for Mozilla Firefox
NickJH
 
Posts: 428
Joined: November 4th, 2003, 7:28 am
Location: Hampshire, England

Post Posted April 2nd, 2015, 12:44 pm

Hi,
For a few years now I have been running my Weave sync server with the 1.1 version of sync. Upgrading to a 1.5 sync server is not an option as my server distro only runs Python 2.6 and not 2.7.

Anyway, since my first PC updated itself to 37.0, I've been getting the following in my logs:
Code: Select all
172.17.2.100 - {my_services.sync.username} [02/Apr/2015:20:03:51 +0100] "GET /weave/1.1/{my_services.sync.username}/info/collections HTTP/1.1" 200 171
172.17.2.100 - {my_services.sync.username} [02/Apr/2015:20:03:51 +0100] "GET /weave/1.1/{my_services.sync.username}/storage/meta/fxa_credentials HTTP/1.1" 404 18
172.17.2.100 - {my_services.sync.username} [02/Apr/2015:20:08:28 +0100] "GET /weave/1.1/{my_services.sync.username}/info/collections HTTP/1.1" 200 171
172.17.2.100 - {my_services.sync.username} [02/Apr/2015:20:08:28 +0100] "GET /weave/1.1/{my_services.sync.username}/storage/meta/fxa_credentials HTTP/1.1" 404 18
172.17.2.100 - {my_services.sync.username} [02/Apr/2015:20:18:28 +0100] "GET /weave/1.1/{my_services.sync.username}/info/collections HTTP/1.1" 200 171
172.17.2.100 - {my_services.sync.username} [02/Apr/2015:20:18:28 +0100] "GET /weave/1.1/{my_services.sync.username}/storage/meta/fxa_credentials HTTP/1.1" 404 18
172.17.2.100 - {my_services.sync.username} [02/Apr/2015:20:28:28 +0100] "GET /weave/1.1/{my_services.sync.username}/info/collections HTTP/1.1" 200 171
172.17.2.100 - {my_services.sync.username} [02/Apr/2015:20:28:28 +0100] "GET /weave/1.1/{my_services.sync.username}/storage/meta/fxa_credentials HTTP/1.1" 404 18
etc
The messages repeat every 5 - 10 mins. There is one good message and one getting a 404:
Code: Select all
172.17.2.100 - {my_services.sync.username} [02/Apr/2015:20:28:28 +0100] "GET /weave/1.1/{my_services.sync.username}/storage/meta/fxa_credentials HTTP/1.1" 404 18
The 404 error only started since the update. Presumably prior to v37.0 this url was never requested.

Does anyone know how I can stop it as it is spamming my logs (sync still works)?

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 11 guests