MozillaZine

Firefox 43.0.4 Saving All ImageTypes As Jfif

User Help for Mozilla Firefox
mike2701
 
Posts: 2
Joined: January 19th, 2016, 3:57 pm

Post Posted January 19th, 2016, 4:01 pm

Hi,

Recently whenever I save an image in firefox to my desktop or a desired folder, the image is saved as a jfif file. This makes it complicated to upload images to my website and I now need to convert all the files before I can use them. It doesn't matter if I "save as" or drag and drop, the result is the same. How can I stop this from happening? I don't want to switch browsers as I've always used firefox but this issue poses a major inconvenience for me when I'm working.

therube

User avatar
 
Posts: 20571
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 19th, 2016, 6:21 pm

Any change if you restart in Safe Mode?
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

mike2701
 
Posts: 2
Joined: January 19th, 2016, 3:57 pm

Post Posted January 20th, 2016, 10:25 am

therube wrote:Any change if you restart in Safe Mode?

No change, i've done a refresh and even reinstalled firefox after deleting the old date folder. I don't think its a Windows issue either because Chrome saves the images as normal. I ran Malwarebytes as well and found nothing. I'm really stumped by this.

dfoulkes

User avatar
 
Posts: 22575
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted January 20th, 2016, 1:02 pm

Try doing all that with a new profile... using it as-is for now and see what happens then.

Creating a new Firefox profile on Windows - MozillaZine Knowledge Base
And,.... DON'T TOUCH THAT "Choose Folder..." BUTTON! ... unless you fully know all about it.

In the end you may have to start using that new one... but let us know the results and we will post some other links to help you move stuff over from your old profile.
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

therube

User avatar
 
Posts: 20571
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 20th, 2016, 6:00 pm

> Recently whenever I save an image in firefox

So is this all (jpeg) images or only some?
If the latter, URLs where it occurs?
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

dickvl

User avatar
 
Posts: 53221
Joined: July 18th, 2005, 3:25 am

Post Posted January 20th, 2016, 9:08 pm

Do you mean that JPG files are saved with a .jfif file extension?

Did you try to rename the files or made sure to save the files with a .jpg file extension to see if that works?

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.
Help > Troubleshooting Information > Profile Directory: Show Folder
*http://kb.mozillazine.org/Profile_folder_-_Firefox

http://kb.mozillazine.org/mimeTypes.rdf
http://kb.mozillazine.org/File_types_an ... ad_actions

You can inspect the MIME database key with the registry editor (regedit.exe) and do a search for that MIME type (file extension) via Ctrl+F.
Be cautious with editing the registry as there is NO UNDO possible: all changes are applied immediately.
You can export key(s) in the registry editor before making changes.
You can check specific file extension keys (e.g.: .jpg) in the registry with the registry editor.
HKEY_CLASSES_ROOT\.xxx
You can check the linked MIME type in the MIME Database registry key.
HKEY_CLASSES_ROOT\MIME\Database\Content Type\

Athari
New Member
 
Posts: 1
Joined: February 27th, 2016, 12:16 am
Location: Kazan, Russia

Post Posted February 27th, 2016, 12:30 am

dickvl wrote:You can check the linked MIME type in the MIME Database registry key.
HKEY_CLASSES_ROOT\MIME\Database\Content Type\

Thanks you, this is what helped me. HKCR\MIME\Database\Content Type\image/jpeg key had Extension value set to ".jfif". I changed it to ".jpg", and the default extension in the save dialog was fixed. Firefox still displays the list of extensions weirdly ("JPEG Image (*.jpg;*.jpg;*.jfif)", before that was "JPEG Image (*.jfif;*.jpg;*.jfif)"), but at least it saves files properly now. I have no idea why ".jfif" was the default in the Registry, since when and why.

Grumpus

User avatar
 
Posts: 12605
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted February 27th, 2016, 5:18 am

The following could be the reason: (Might be MS system and not Firefox)
Copied from the Jpeg wiki
wiki wrote:The JPEG File Interchange Format (JFIF) is an image file format standard. It is a format for exchanging JPEG encoded files compliant with the JPEG Interchange Format (JIF) standard. It solves some of JIF's limitations in regard to simple JPEG encoded file interchange. As with all JIF compliant files, image data in JFIF files is compressed using the techniques in the JPEG standard, hence JFIF is sometimes referred to as "JPEG/JFIF".
Purpose: JFIF defines a number of details that are left unspecified by the JPEG Part 1 standard (ISO/IEC IS 10918-1, ITU-T Recommendation T.81
Doesn't matter what you say, it's wrong for a toaster to walk around the house and talk to you

therube

User avatar
 
Posts: 20571
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 27th, 2016, 7:45 am

(*.jfif;*.jpg;*.jfif)

On Win7, default is (only) ".jpg" (& also no *'s).

(Unless Win10 is different) I'd suspect some other (image [editing] related) program made that change (for whatever reason).
(FF did not.)
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

MarkRH

User avatar
 
Posts: 1291
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted February 28th, 2016, 1:08 pm

On my Win 7 systems it's *.jpg;*.jpeg;*.jpg

therube

User avatar
 
Posts: 20571
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted February 29th, 2016, 8:31 am

On Win7, default is (only) ".jpg" (& also no *'s).

Ditto on XP.
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

zebdaddy
 
Posts: 1
Joined: November 8th, 2016, 6:10 am

Post Posted November 8th, 2016, 6:21 am

I know this is an old thread but I joined the forum to thank dickvl for the registry location HKEY_CLASSES_ROOT\MIME\Database\Content Type\JPEG
I was pulling my hair out.
When I was browsing to upload some images the "supported file types" were (jfif, png, gif, bmp) I had to select "all files" to see the jpegs.
It was a small inconvenience, but it wasn't right. It was deep digging to find this and it worked

Thanks again.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 12 guests