MozillaZine

Disable connecting with messages

User Help for Mozilla Firefox
Pietertje-building
 
Posts: 6
Joined: February 13th, 2016, 8:11 am

Post Posted February 13th, 2016, 8:21 am

I am building a private website which should be like a second desktop with lots of features. It also uses some PHP pages which reload every second to get current data. Since the site would have to look like some sort of desktop, the browser needs to be in full screen. (F11) All standard browser things should not be show, which is a succes @ full screen. However...

Those PHP pages which get reloaded, make the browser show the "connecting with..." messages in the bottom left corner. There doesn't seem to be any html/javascript/PHP/css solution to suppres those messages. Is there a way to block these messages in firefox? Is there a setting in about:config?

(btw, if you hover over a link, you get the same kind of pop-up in the bottom left of your browser, I don't want those)

LIMPET235
Moderator

User avatar
 
Posts: 37475
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted February 13th, 2016, 8:24 am

Moving to Web Dev...
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-50.0-56.0.1/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. Conficker Test. (Always choose the "Custom" Install.)

Pietertje-building
 
Posts: 6
Joined: February 13th, 2016, 8:11 am

Post Posted February 13th, 2016, 8:29 am

Not sure why this has been moved, since I already said that it could not be fixed with code on my website... Just want to turn off that anoying bar in the bottom left, which is part of the firefox browser... So firefox support should be the correct category.

LIMPET235
Moderator

User avatar
 
Posts: 37475
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted February 13th, 2016, 8:39 am

Oh, I missed that.
Sorry.
Back to Support...
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-50.0-56.0.1/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
RadioYachting. Conficker Test. (Always choose the "Custom" Install.)

kreemoweet
 
Posts: 708
Joined: December 30th, 2009, 11:25 pm

Post Posted February 13th, 2016, 10:00 am

Here's first result I got from searching "hide Firefox status bar": https://support.mozilla.org/en-US/questions/1009109
There's many, many more results to consult if necessary.

Pietertje-building
 
Posts: 6
Joined: February 13th, 2016, 8:11 am

Post Posted February 13th, 2016, 12:30 pm

Thank you Kreemoweet! Tryed the solution with that "userChrome.css" file, but could not get it to work. (had to create the dir and file, and according to all the help pages, it should work, but it didn't) Finaly got the plugin that was mentioned with your search query, and that did what I wanted to do. Yet another plugin... But hey, I shouldn't complain to much.

*didn't know the name of that bar, so I didn't get any usefull search results before*

Pietertje-building
 
Posts: 6
Joined: February 13th, 2016, 8:11 am

Post Posted February 13th, 2016, 12:39 pm

Problem not solved... Could turn off the status bar when not in full-screen. When in full-screen, the problem remains. Can someone explain to me how I can use those userChrome.css files, and where they should be located? And what should be in them?

File location:
C:\Users\*username*\AppData\Roaming\Mozilla\chrome

File content:
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.statuspanel-label {background:#FF9!important;color:black!important;font-family:"DejaVu Sans Mono"}

statuspanel {display:none!important}
statuspanel {max-width:90%!important}

statuspanel[type="overLink"] .statuspanel-label
statuspanel[type="status"] .statuspanel-label[value^="Looking"]
statuspanel[type="status"] .statuspanel-label[value^="Connect"]
statuspanel[type="status"] .statuspanel-label[value^="Waiting"]
statuspanel[type="status"] .statuspanel-label[value^="Transfer"]

Pietertje-building
 
Posts: 6
Joined: February 13th, 2016, 8:11 am

Post Posted February 13th, 2016, 1:11 pm

I used this source for finding the correct directory:
http://kb.mozillazine.org/Profile_folder

It's not correct at all!!! The correct way of finding the directory can be found here:
https://support.mozilla.org/nl/questions/959024

Quote from that topic:
your profile folder is a subfolder of C:\Documents and Settings\XXXXXXX\Application Data\Mozilla\Firefox\Profiles\ and should be labelled something like <randomstring>.default - the chrome folder with the userChrome.css file has to go within that <randomstring>.default folder.

Using this newly found location/directory, it was easy to create a "chrome" map, and create the file "userChrome.css" with all the text from above in it. Now it finaly works. (removed the plugin)

DanRaisch
Moderator

User avatar
 
Posts: 117346
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted February 13th, 2016, 5:59 pm

It appears you may have missed the text in that first link which noted that the location of the profile folder in older Windows operating system versions differs from the location in newer versions. For Windows Vista and above the profile is found in C:\Users\<Windows login/user name>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile folder>. The directory path you reported above is/was valid for Windows XP and earlier.

Return to Firefox Support


Who is online

Users browsing this forum: rocco.xyz and 10 guests