MozillaZine

Bing

User Help for Mozilla Firefox
journeyman4
 
Posts: 12
Joined: June 9th, 2015, 1:33 am

Post Posted January 10th, 2017, 4:19 am

Hi,
Can anyone help me please? Firstly im in the old gits league, so might be a bit slower on the uptake, so need clear instructions. I Obviously use FF, with Google as my home page.
When I type what ever I want to look up in google somtimes results appear, thats fine, but if nothing comes up and I have to hit the return key, then everything is returned in blasted Bing and I hate it.
Ive gone into control panel, there is nothing there that I can see that is associated with it, Ive also read "Conduit" has something to do with bing, I did somehow get conduit once but removed it ages ago so thats not the culprit.
Ive opened my browser as I say home page google Clicked on the magnifying glass in search box, clicked on google, I have FF as my default browser, Google shows as being my default search engine, Ive done every thing i can find on-line all this seemed to come about over the last weekend, I thought that i might have just clicked on something accidently, but if so I do not know what.
All I want is when I hit the return key things to come up in google, can you help me please!!

LIMPET235
Moderator

User avatar
 
Posts: 36580
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted January 10th, 2017, 4:36 am

Hello,
Have you tried removing "Bing" from the Search Box?
Tools > Options > Search.
Just left click to highlight each one that is not needed & hit the Remove button.

Try restarting Firefox & check that "they're" gone.

Please ref; > http://kb.mozillazine.org/Search_Bar
Ancient Amateur Astronomer
Win-7-HP/Intel® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-50.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.8.0.
RadioYachting. Conficker Test. (Always choose the "Custom" Install.)

Grumpus

User avatar
 
Posts: 10725
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted January 10th, 2017, 6:35 am

It may be the basic GUI might not address the problem. (Make sure you keep notes of your changes)
You could open About:config and search for "Bing" and change each instance to Google.
How to: prepare by following Limpet235's instruction as a starter.
1. Set your browser to work off line /File/check work offline or go offline to make the changes.
2. Type "about:config" in the nav text entry.
3. Agree to be careful and open about:config
4. In the search text entry type "Bing"
5. Right click on the item and select modify fro the panel and edit from "Bing" to "Google" (this works for all the instances of search in about config)
6. You could also use the word "search" and it should show all search engine items.
7. Close and re-open Firefox. Do NOT do a Restart.

Note: The following items are the ones where change occurs.
browser.search.defaultenginename
browser.search.order.1
browser.search.order.2
browser.search.order.3
browser.search.order.4
browser.search.selectedEngine

There are also some other items which are country specific and have the name of the search engine at the end of the string, change also.
If you feel you made a mistake on an item, right click on the item and hit reset.

the-edmeister

User avatar
 
Posts: 31680
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted January 10th, 2017, 7:03 am

Try setting your default search engine.

https://support.mozilla.org/en-US/kb/ch ... gs-firefox



.
A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

journeyman4
 
Posts: 12
Joined: June 9th, 2015, 1:33 am

Post Posted January 10th, 2017, 8:35 am

Replies from Limpet235 & the-edmeister, both bring up the same pages, I have removed bing, I have reset manually google as default S/E Ive also clicked on the button reset defaults whereby bing came back so I highlighted it and clicked remove, did a restart and yes it had gone, so typed luggage into google hit return key and search result still appeared as Bing.

I am now trying Grumpus reply but am a bit stuck, I clicked on off line, typed in "about:config" hit return and get a page open up AS BING, with in the search box what I typed aboutconfig, but interesting enogh in the address bar it has bing.com in black letters followed by /search? and loads of other letters and numbers but all grayed out. So as Grumpus said where it shows aboutconfig in the search box i typed as he said "Bing" then he says right click on item what item? where Ive typed bing is that what I right click? if so all that says is something inspect element so im totall lost

mightyglydd

User avatar
 
Posts: 8411
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted January 10th, 2017, 10:39 am

journeyman4 wrote:I am now trying Grumpus reply but am a bit stuck
Don't bother, messing about in about:config is a tinfoil recipe for disaster; if you don't know what you're doing.

You might want to run this Extension
https://addons.mozilla.org/en-US/firefo ... archreset/
It uninstalls itself after running.
#KeepFightingMichael

journeyman4
 
Posts: 12
Joined: June 9th, 2015, 1:33 am

Post Posted January 10th, 2017, 11:42 am

Hi mightyglydd, done what youve said, the add on did make FF my home page, I changed it back to google, made sure google was set as default Search Engine, just typed any old thing into google search results still come up in bing!!
what the hell is going on, ive done all that Ive been told on here, all waht ive read on line, still everything appears in bing. Thanks for your reply to help me.

mightyglydd

User avatar
 
Posts: 8411
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted January 10th, 2017, 12:01 pm

#KeepFightingMichael

journeyman4
 
Posts: 12
Joined: June 9th, 2015, 1:33 am

Post Posted January 10th, 2017, 12:19 pm

Hi again yep done that and its still there. Saw online it said about cortania in windows 10, as that is microsoft, as is bing, so have disabled that and cleared all that is stored in the cloud, yet still it returns!!

One thing though, lets say I type Luggage in to google, the results come up in bing, but when i click the "Back" button as i did in google and go back to home page, this does not happen now with bing. I click back button and what Ive searched for stays there, I have to go to the little house to get back to home page!!!

mightyglydd

User avatar
 
Posts: 8411
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted January 10th, 2017, 12:44 pm

#KeepFightingMichael

Grumpus

User avatar
 
Posts: 10725
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted January 10th, 2017, 2:04 pm

@journeyman 4 - You probably made a syntax and location error.
First you type "about:config" without the quotes but with the : You place this where the url would go in the navigation bar not in the search entry.
It should not be showing aboutconfig in the search box. The search function should not be interfering with typing in about:config.
If you do not get the about:config entry page there's something wrong.
Here is an about:config image showing warning page ac image warning Note the location of about:config in the image.
The following shows what you would see past the warning page AC item list It also shows (red arrow) where to put the items in about:config you wish to search for.
If this changes things follow my previous instructions and make notes.

journeyman4
 
Posts: 12
Joined: June 9th, 2015, 1:33 am

Post Posted January 10th, 2017, 2:44 pm

ok my friend thanks for that, I am just about to turn in for the night been up early so will try tomorrow, and will let you know, thank you so much for your patience and help greatly appreciated, thank you.

the-edmeister

User avatar
 
Posts: 31680
Joined: February 25th, 2003, 12:51 am
Location: Chicago, IL, USA

Post Posted January 10th, 2017, 2:49 pm

journeyman4 wrote:... I have removed bing, I have reset manually google as default S/E Ive also clicked on the button reset defaults whereby bing came back so I highlighted it and clicked remove, did a restart and yes it had gone, so typed luggage into google hit return key and search result still appeared as Bing.


First, the en-US versions of Firefox come with Bing and as one of the provided search engines. It is "protected" against permanent removal. So of course if you "Restore Default Search Engines" it will be there after you removed it. Also, while it should stay deleted with out using the "Restore Default Search Engines" feature, but with the next Firefox update it will return automatically with the updated omni.ja in the Firefox program files - the provided search engines can't be permanently deleted.

As far as the default search engine in the en-US version of Firefox goes, if anything it should be getting reset to Yahoo and not to Bing - that's how it is set up to act. My guess is that some type of Malware is changing the default back to Bing when Windows is restarted or on a cold boot and that is happening thru Windows thence to Firefox. Please check exactly when it gets reset to Bing, when Firefox is launched or upon a Windows cold start or restart.

.
A mind is a terrible thing to waste. Mine has wandered off and I'm out looking for it.

journeyman4
 
Posts: 12
Joined: June 9th, 2015, 1:33 am

Post Posted January 11th, 2017, 4:02 am

Grumpus wrote:@journeyman 4 - You probably made a syntax and location error.
First you type "about:config" without the quotes but with the : You place this where the url would go in the navigation bar not in the search entry.
It should not be showing aboutconfig in the search box. The search function should not be interfering with typing in about:config.
If you do not get the about:config entry page there's something wrong.
Here is an about:config image showing warning page ac image warning Note the location of about:config in the image.
The following shows what you would see past the warning page AC item list It also shows (red arrow) where to put the items in about:config you wish to search for.
If this changes things follow my previous instructions and make notes.


Hi Back again, Right Ive done what you have said, this time when I got the aboutconfig page I accepted the warning, and hit the button, then in the search bar I typed Bing this brought up 3 different lines of things that had bing mentioned, one was something default, so anyway on all 3 lines individually I right clicked, then clicked MODIFY, deleted the word Bing and put in google, I then just closed the whole thing (via cross in top right), I then went back on line to my home page google, typed in a couple of words one being Luggage, and the results still came up as bing, so I started again, went off line, typed in aboutconfig, accepted the warning typed in bing in search bar, only this time it was just a blank page, the 3 lines that were there before where i deleted bing and put in google have gone!! think Im getting way out of my depth here.

journeyman4
 
Posts: 12
Joined: June 9th, 2015, 1:33 am

Post Posted January 11th, 2017, 4:08 am

the-edmeister wrote:
journeyman4 wrote:... I have removed bing, I have reset manually google as default S/E Ive also clicked on the button reset defaults whereby bing came back so I highlighted it and clicked remove, did a restart and yes it had gone, so typed luggage into google hit return key and search result still appeared as Bing.


First, the en-US versions of Firefox come with Bing and as one of the provided search engines. It is "protected" against permanent removal. So of course if you "Restore Default Search Engines" it will be there after you removed it. Also, while it should stay deleted with out using the "Restore Default Search Engines" feature, but with the next Firefox update it will return automatically with the updated omni.ja in the Firefox program files - the provided search engines can't be permanently deleted.

As far as the default search engine in the en-US version of Firefox goes, if anything it should be getting reset to Yahoo and not to Bing - that's how it is set up to act. My guess is that some type of Malware is changing the default back to Bing when Windows is restarted or on a cold boot and that is happening thru Windows thence to Firefox. Please check exactly when it gets reset to Bing, when Firefox is launched or upon a Windows cold start or restart.

All I can tell you my friend it that when I click on the magnifying glass in search box, on my google home page, then click on "Change search settings" that then brings up the list that FF uses, I have deleted Bing, and it still does not show, so it has been deleted, and google is shown with the word DEFAULT besides it, so when or how the search results keep coming in bing i am no idea. As i say I basically can use a pc but all the tech no stuff is way beyond me, i just do not know how it has changed, I never ever touch or dabble with settings or anything.

.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 2 guests