Firefox does not remember me. [Linux.]

User Help for Mozilla Firefox
Posts: 2
Joined: January 16th, 2017, 8:05 pm

Post Posted January 16th, 2017, 8:16 pm

I have the setting on to save history. I use FireFox in Linux, various versions. This was happening a lot in Simplicity and I narrowed it down to a FireFox issue. Now I am using FireFox in Linux Mint. Seemed ok for a while but now 2 days in a row I log in and everything thinks I have a new browser. Meaning, I use a lot of 2 factor authentication, I have to go through all of that again. Also, I use Last Pass, I have to put the master password back in , all the other pages (tabs) I was logged into all forget me , it is a super pain in the butt. Having to put all these codes back in (2 factor), etc. I keep looking at the settings and do not see any setting that would be causing this forgetfulness of the browser all the time. Any ideas. When I sit down to work I don't want to have to go through all this every night. Huge time waster.
Last edited by LIMPET235 on January 17th, 2017, 2:33 am, edited 1 time in total.
Reason: Added [Linux] to the title.


User avatar
Posts: 38393
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted January 17th, 2017, 2:36 am

Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0-61.0-62.0/T-bird-
RadioYachting. (Always choose the "Custom" Install.)

Posts: 252
Joined: September 26th, 2008, 2:13 am
Location: South Carolina, USA

Post Posted January 17th, 2017, 9:04 pm

in FF's "privacy" settings, if you have it set to "clear history when firefox closes", you have to adjust the settings, there, for "clear history", so that cookies are not removed by "clear history", if you want cookies to be saved..

if you use any custom-settings for cookies, you also need to disable the clearing of "site preferences", in the settings for "clear history," so that the custom-settings for cookies are not removed by "clear history"..

in the "privacy" settings, there is a setting for cookies, "keep until i close firefox".. if you use that setting, but you want some cookies to be saved, you need to use the "exceptions" settings, for cookies, for the cookies that you want to save, setting them to "allow".. in that case, the cookies that are set to "allow" will not be removed when the browser is closed..

when adding an exception for a cookie, you have to specify "HTTP" or "HTTPS".. for example, ""

p.s. in firefox's "privacy" settings, you may need to enable "use custom settings for history," if you haven't already done that, in order to be able to access the advanced settings, there..
find answers at "Mozilla Support":

Posts: 2
Joined: January 16th, 2017, 8:05 pm

Post Posted January 21st, 2017, 11:56 pm

I have no custom settings and I do not have it set to clear history. If anyone is familiar with 2 factor authentication there is a checkbox to click that says remember this browser I use it frequently. I have all the default settings in FireFox , This is extremely Frustrating as I deal with a multitude of websites every night and I am wasting huge amounts of time with a problem that should not be happening. I cannot believe I am the only one experiencing this issue. I actually log in to FireFox and have an account. This happens in multiple operating systems.

Return to Firefox Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests