MozillaZine

FF 51 and the "invisible" bug

User Help for Mozilla Firefox
KasperskyITA
 
Posts: 18
Joined: January 27th, 2016, 3:23 pm

Post Posted January 27th, 2017, 6:20 am

Hi. With FF 51 I started having problems with some add-ons. The phrases are invisible http://i.imgur.com/iG6r3dZ.png unless I do not highlight with my mouse http://i.imgur.com/FbBg9IF.png .

Is a problem/bug with WebGL or Webextension? Help, thanks.

P.S. The add-on that I used as the test is called "Add-on Compatibility Reporter".

DanRaisch
Moderator

User avatar
 
Posts: 116118
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 27th, 2017, 7:43 am

That image doesn't tell us where that is occurring. Where are you seeing that dialogue?

Also, do you have hardware acceleration enabled on that system? (Tools->Options->Advanced->General)

KasperskyITA
 
Posts: 18
Joined: January 27th, 2016, 3:23 pm

Post Posted January 27th, 2017, 8:13 am

DanRaisch wrote:That image doesn't tell us where that is occurring. Where are you seeing that dialogue?

Also, do you have hardware acceleration enabled on that system? (Tools->Options->Advanced->General)


The dialogue you can see in the second image http://i.imgur.com/FbBg9IF.png only if it is selected.

I can now affirm that if I disable hardware acceleration, the problem disappear. Therefore it is a bug in FF and not of addons. What can I do about it?

DanRaisch
Moderator

User avatar
 
Posts: 116118
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 27th, 2017, 8:21 am

It's not necessarily a bug in Firefox, it's possible that there is a problem with the video drivers on your system. Have you confirmed that you are running with the latest version of those drivers?

BTW, many folks don't actually see much difference between performance with hardware acceleration on or off, so it may not really be much of an issue at all.

KasperskyITA
 
Posts: 18
Joined: January 27th, 2016, 3:23 pm

Post Posted January 27th, 2017, 8:36 am

DanRaisch wrote:It's not necessarily a bug in Firefox, it's possible that there is a problem with the video drivers on your system. Have you confirmed that you are running with the latest version of those drivers?

BTW, many folks don't actually see much difference between performance with hardware acceleration on or off, so it may not really be much of an issue at all.


I'm using the latest Nvidia drivers (378.49) and if I disable hardware acceleration, the YouTube videos become jerky and therefore unwatchable. So apart the "many folks", for me it is a problem.
P.s. I'm using the same driver video as when I had the version of FF 50 and the problem with the add-ons would not show.

Reflective

User avatar
 
Posts: 1863
Joined: February 15th, 2007, 11:13 am

Post Posted January 27th, 2017, 9:13 am

KasperskyITA wrote:
DanRaisch wrote:It's not necessarily a bug in Firefox, it's possible that there is a problem with the video drivers on your system. Have you confirmed that you are running with the latest version of those drivers?

BTW, many folks don't actually see much difference between performance with hardware acceleration on or off, so it may not really be much of an issue at all.


I'm using the latest Nvidia drivers (378.49) and if I disable hardware acceleration, the YouTube videos become jerky and therefore unwatchable. So apart the "many folks", for me it is a problem.
P.s. I'm using the same driver video as when I had the version of FF 50 and the problem with the add-ons would not show.


Disable h/w acceleration and then install this extension: https://addons.mozilla.org/en-US/firefo ... fy/?src=ss

You should find that YT videos play without hiccuping afterwards.

KasperskyITA
 
Posts: 18
Joined: January 27th, 2016, 3:23 pm

Post Posted January 27th, 2017, 9:26 am

Reflective wrote:
KasperskyITA wrote:
DanRaisch wrote:It's not necessarily a bug in Firefox, it's possible that there is a problem with the video drivers on your system. Have you confirmed that you are running with the latest version of those drivers?

BTW, many folks don't actually see much difference between performance with hardware acceleration on or off, so it may not really be much of an issue at all.


I'm using the latest Nvidia drivers (378.49) and if I disable hardware acceleration, the YouTube videos become jerky and therefore unwatchable. So apart the "many folks", for me it is a problem.
P.s. I'm using the same driver video as when I had the version of FF 50 and the problem with the add-ons would not show.


Disable h/w acceleration and then install this extension: https://addons.mozilla.org/en-US/firefo ... fy/?src=ss

You should find that YT videos play without hiccuping afterwards.


Thank you but this is a temporary solution. What I want to know is if it also happens to others.

Reflective

User avatar
 
Posts: 1863
Joined: February 15th, 2007, 11:13 am

Post Posted January 27th, 2017, 9:38 am

Reflective wrote:Disable h/w acceleration and then install this extension: https://addons.mozilla.org/en-US/firefo ... fy/?src=ss

You should find that YT videos play without hiccuping afterwards.


KasperskyITA wrote:Thank you but this is a temporary solution. What I want to know is if it also happens to others.


I can't answer that without the link to the original image. Can you post that?

KasperskyITA
 
Posts: 18
Joined: January 27th, 2016, 3:23 pm

Post Posted January 27th, 2017, 9:42 am

Exactly what image you're asking me?

mightyglydd

User avatar
 
Posts: 8692
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted January 27th, 2017, 9:50 am

:-k ..One of the two in your first post?
#KeepFightingMichael

KasperskyITA
 
Posts: 18
Joined: January 27th, 2016, 3:23 pm

Post Posted January 27th, 2017, 10:15 am

I hope goes well: http://imgur.com/a/n4WjZ

MarkRH

User avatar
 
Posts: 1082
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted January 27th, 2017, 4:51 pm

For those don't know, that dialog comes from the Add-on Compatibility Reporter :: Add-ons for Firefox

Anyway, I installed it and the told CTR not to use alternative background color for panel popups so it's the normal white, and I can see the dialog fine:

Image

Windows 7 Pro 64bit with NVidia 550ti with 347.88 version drivers using a Windows Classic theme.

Do you have any other extensions or Stylish CSS rules that might be interfering with the appearance?

KasperskyITA
 
Posts: 18
Joined: January 27th, 2016, 3:23 pm

Post Posted January 28th, 2017, 6:13 am

I have Stylish and other add-ons that might be interfering but disabling them all, nothing changes.
Summary: This happens since I updated to version FF 51. If i turn OFF the hardware acceleration, the problem disappears, the dialogue appear as it should.

MarkRH

User avatar
 
Posts: 1082
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted January 28th, 2017, 12:11 pm

I have Hardware Acceleration turned on here. If toggling that setting changes the appearance then I guess it's related to the video drivers in some fashion. I wonder what graphics handling was changed in FF51?

dickvl

User avatar
 
Posts: 52044
Joined: July 18th, 2005, 3:25 am

Post Posted January 28th, 2017, 12:52 pm

It looks that you have a white or transparent text color set.

Did you check the default color settings in "Options/Preferences -> Content -> Colors"?

Return to Firefox Support


Who is online

Users browsing this forum: Manheim2 and 9 guests