MozillaZine

Firefox 52 history manager uses 12-hour clock now?

User Help for Mozilla Firefox
ForCryingOutLoud
 
Posts: 5
Joined: March 11th, 2017, 12:07 am

Post Posted March 11th, 2017, 12:20 am

I wasn't sure if this is a bug or something else, but beginning in Firefox 52 the history manager uses 12-hour clock instead of 24-hour clock the earlier versions used. How can I change it back to 24-hour clock? I tried searching, but the forum's search is... not up to the task, so I apologize if this has been asked already.

Yes, I use the English (en-us) version of Firefox, but I cannot understand why force 12/24-hour clock based on the language. Why doesn't it just use the system default like in the past? I've used English versions for 15 years and Firefox has dutifully used 24-hour clocks everywhere until now, because 24-hour clock is what Windows displays for me when I set my locale correctly.

(I had to create a new account here, because my 10-year old account no longer worked due to some incompatibilities. It took me 15 minutes to create an account that the forum software finally accepted. The email address in the old account still works, but it's "in use", but the account isn't, so I had to "waste" another email address for this new account. I admit I should have logged in more often to avoid this mess.)

Reflective

User avatar
 
Posts: 2254
Joined: February 15th, 2007, 11:13 am

Post Posted March 11th, 2017, 3:40 am

I've never seen a clock in the history menu. Are you talking about an extension?

ForCryingOutLoud
 
Posts: 5
Joined: March 11th, 2017, 12:07 am

Post Posted March 11th, 2017, 5:30 am

They're not in the history menu, they're in the History (Library) window you can open in History/Show All History and Bookmarks/Show All bookmarks. All built-in features of Firefox.

If you right-click the column headers, you can select which columns there are. The ones I'm talking about are "Most Recent Visit", "Added" and "Last Modified". The first one only shows data for visited websites, the last two two are only for bookmarks. They're ALL now using what seems to be hardcoded DD/MM/YYYY date order with 12-hour clocks. In previous Firefox versions they were displayed in locale-dependent way.

Lnwdz
 
Posts: 152
Joined: June 12th, 2012, 7:59 am

Post Posted March 11th, 2017, 7:34 am

They're doing lots of tinkering for arcane reasons. I can't tell whether there's a solution here:
Firefox ignores user chosen regional settings in date/time display

ForCryingOutLoud
 
Posts: 5
Joined: March 11th, 2017, 12:07 am

Post Posted March 11th, 2017, 10:07 am

I guess this being a known problem counts as good news.

The bad news is that there is no fix available at the time :-( I fiddled with general.useragent.locale and intl.locale.matchOS in about:config, but they did nothing.

If I'm reading everything correctly, the fix will be in Firefox 54. So I either have to downgrade or wait a few months. Neither is a good option. (Or update to Developer Edition/Nightly...)

ForCryingOutLoud
 
Posts: 5
Joined: March 11th, 2017, 12:07 am

Post Posted March 11th, 2017, 11:51 pm

I "solved" this problem by installing a language pack. It's only a temporary fix; as soon as the bug is fixed I'll switch back to English. It's a better solution than downgrading (security-wise). The interactions between all the about:config settings relating to this and the UI language are horrendously broken. To me it seems no one tested if they even work.

I also realized the newest ESR version suffers from this and while the normal Firefox eventually (hopefully) gets fixed, the ESR 52 will remain eternally broken... :-(

Reflective

User avatar
 
Posts: 2254
Joined: February 15th, 2007, 11:13 am

Post Posted March 12th, 2017, 8:52 am

Yes, I see what you mean. It displays in 12 hour format on my system as well.

According to this Mozillazine article Firefox doesn't have a clock of its own and derives whatever time is displayed from the OS. However, I have a 24 hour clock configured so I guess it's a bug. A quick google search shows that this isn't the first time it's happened either and it seems to be a regular event.

JayhawksRock

User avatar
 
Posts: 10430
Joined: October 24th, 2010, 8:51 am

Post Posted March 12th, 2017, 11:24 am

I had to change the OS date and time setting accessed in the windows tray at the lower right (double click the time/date) as I have always done. Works perfect 2 times per Year. If needed there is 3 different time severs available in the Windows settings dialog
"The trouble with quotes on the internet is you never know if they are genuine" ...Abraham Lincoln

The Tinsmith
 
Posts: 707
Joined: December 24th, 2011, 10:29 am

Post Posted March 12th, 2017, 12:07 pm

had to change the OS date and time setting accessed in the windows tray



Windows XP defaulted to setting the system/date time to/from daylight saving time automatically. At least it did in the US version.

I do not recall, it has been over 10 years ago, having to do anything. If yours does not, I'm not doubting you, there might be something minor wrong. A setting.

Have a good day.

ForCryingOutLoud
 
Posts: 5
Joined: March 11th, 2017, 12:07 am

Post Posted June 17th, 2017, 10:56 pm

Well, 54 is out and... the bug still persists. I can see it marked "fixed", but no matter how I fiddle with about:config, the History manager throws AM/PM times at me. I've modified general.useragent.locale and intl.locale.matchOS but they seem to have no effect. The only way to fix this is to change the UI language of the whole program, which, because the language pack is not complete, means the UI is a mishmash of two languages.

](*,)

latimer
 
Posts: 4
Joined: March 12th, 2012, 1:41 am

Post Posted November 18th, 2017, 12:19 pm

Same problem with here.
I have w7 x64 US english but regional setting set to German and 24h clock of course.
Alas the history windows shows a crappy AM/PM clock.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 20 guests