MozillaZine

Can't play Shockwave games on 52

User Help for Mozilla Firefox
cartoonic945
 
Posts: 6
Joined: March 14th, 2017, 8:40 am

Post Posted March 14th, 2017, 8:44 am

So I was going to replay some old games from VeggieTales, but the ones use Shockwave won't work.

https://web.archive.org/web/20030625211 ... uills.html

Does anyone know how to get this around?

DanRaisch
Moderator

User avatar
 
Posts: 117793
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 14th, 2017, 9:08 am

Moving to Firefox Support.

If you are referring to Shockwave Flash, see this link.,

cartoonic945
 
Posts: 6
Joined: March 14th, 2017, 8:40 am

Post Posted March 14th, 2017, 9:25 am

I was talking about Shockwave director.

DanRaisch
Moderator

User avatar
 
Posts: 117793
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted March 14th, 2017, 9:32 am

Version 52 removed support for Netscape Plugin API (NPAPI) plugins other than Flash. That means that Silverlight, Java, Acrobat and the like are no longer supported.

If you want to revert to an older version, you can get 51.0.1 from this link -- https://ftp.mozilla.org/pub/firefox/rel ... 0.1/win32/

ReggieNJ
 
Posts: 25
Joined: March 21st, 2016, 5:45 am

Post Posted March 14th, 2017, 11:05 am

You can go to about:config and add a new preference called plugin.load_flash_only as a boolean variable and set it to false. It's only a workaround for now though, don't know how long it will last.

frg
 
Posts: 432
Joined: December 15th, 2015, 1:20 pm

Post Posted March 14th, 2017, 12:01 pm

>> It's only a workaround for now though, don't know how long it will last.

With 53 actual plugin code was removed so 52 is the last safe version where you can use it for all plugins.

James
Moderator

User avatar
 
Posts: 27091
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted March 14th, 2017, 1:39 pm

DanRaisch wrote:Version 52 removed support for Netscape Plugin API (NPAPI) plugins other than Flash. That means that Silverlight, Java, Acrobat and the like are no longer supported.

If you want to revert to an older version, you can get 51.0.1 from this link -- https://ftp.mozilla.org/pub/firefox/rel ... 0.1/win32/

Or to be more safer with having security updates use the Firefox 52.0 ESR instead. The Firefox 52.0 ESR allows you to run Plugins like before.

https://www.mozilla.org/firefox/organizations/all/
https://support.mozilla.org/t5/Problems-with-add-ons-plugins-or/Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no/ta-p/31069

cartoonic945
 
Posts: 6
Joined: March 14th, 2017, 8:40 am

Post Posted March 17th, 2017, 7:22 pm

James wrote:
DanRaisch wrote:Version 52 removed support for Netscape Plugin API (NPAPI) plugins other than Flash. That means that Silverlight, Java, Acrobat and the like are no longer supported.

If you want to revert to an older version, you can get 51.0.1 from this link -- https://ftp.mozilla.org/pub/firefox/rel ... 0.1/win32/

Or to be more safer with having security updates use the Firefox 52.0 ESR instead. The Firefox 52.0 ESR allows you to run Plugins like before.

https://www.mozilla.org/firefox/organizations/all/
https://support.mozilla.org/t5/Problems-with-add-ons-plugins-or/Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no/ta-p/31069


Thanks, that version work! I decided to disable updating it for the moment.

therube

User avatar
 
Posts: 17822
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted March 17th, 2017, 10:53 pm

If you're using the ESR version, you will still get (security) updates on that, & for the length of time that 52 ESR persists, you do want to have it update, so turn updates back on (& see if you don't get a 52.0.1 ESR - today, or tomorrow, or so ;-)).

(A 52 ESR will not update to a FF 53 or 54... It will only update on the ESR branch, so until the next time a new ESR level is reached, you should be OK with your Plugin.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

cartoonic945
 
Posts: 6
Joined: March 14th, 2017, 8:40 am

Post Posted March 17th, 2017, 11:48 pm

Got the recent update, and the games from the site still work!

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], elist74 and 20 guests