MozillaZine

[SOLVED] How to get rid of about:config password?

User Help for Mozilla Firefox
gewe
 
Posts: 9
Joined: November 5th, 2004, 12:46 am
Location: EU

Post Posted April 17th, 2017, 6:58 am

Hello,

Somehow I managed to protect my Firefox configuration with a password. I know the password, that's not the problem.
Problem is, I am trying to create an extension. Every time I open the options page of the extension, I am asked for the password, just like when I open about:config.
I want to disable the password, but I don't remember how I set it, nor can I find that information anywhere.

Can anyone tell me how I can change or disable the password for about:config?
I am using Firefox 52.0.1 on Linux Mint 18.

Regards,
George
Last edited by gewe on April 18th, 2017, 10:19 am, edited 2 times in total.

Reflective

User avatar
 
Posts: 2201
Joined: February 15th, 2007, 11:13 am

Post Posted April 17th, 2017, 8:54 am

As with all passwords it's only the user who created them who knows what they are.

Your best option here would be to backup your bookmarks and then create a new profile: http://kb.mozillazine.org/Creating_a_ne ... on_Windows

gewe
 
Posts: 9
Joined: November 5th, 2004, 12:46 am
Location: EU

Post Posted April 17th, 2017, 9:12 am

I KNOW the password, I set it myself, and it is working. As I described that is NOT the problem.

Problem is I don't know where in Firefox I can change or remove the password. I am tired of having to enter it dozens of times per hour when developing and testing an extension's options page.

dfoulkes

User avatar
 
Posts: 22131
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted April 17th, 2017, 9:24 am

1st... in case Linux is part of the picture you should go and edit your Topic to include that...

2nd.. I know that the Master password affects various areas 'and' I think it also prompts at Firefox startup... don't remember... but could you have entered a Master PW in your Security section of Options?
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

Grumpus

User avatar
 
Posts: 11595
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted April 17th, 2017, 10:16 am

Look under /edit/preferences/security/logins and look at which blocks are checked.
about:config is technically a uri/url so the password setting under logins would probably apply.
If you uncheck "remember logins" and uncheck "use a master password" that may turn it off unless you are using something out side of Firefox.
If you are trying to perform this remotely on another intranet or computer it may be needed for security.

gewe
 
Posts: 9
Joined: November 5th, 2004, 12:46 am
Location: EU

Post Posted April 17th, 2017, 11:06 am

I do not have any passwords configured, or saved. Not for any website, no master password. Under /edit/preferences/security/logins everything is unchecked. There are no saved logins.

I remember there was an options to protect the configuration settings with a password. Problem is I can no longer find it, or any description of how to set it. But I know used it.

@dfoulkes: I don't think Linux is part of the picture. I just mentioned it for completeness.

kreemoweet
 
Posts: 713
Joined: December 30th, 2009, 11:25 pm

Post Posted April 17th, 2017, 4:03 pm

Firefox itself does not have any password protection for the about:config page. There may be some Firefox extension that does that, or it may be an external program, such as
some busy-body "security" suite. The solution is to uninstall the FF extension, or find the external program responsible and tell it to shut up.

dfoulkes

User avatar
 
Posts: 22131
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted April 17th, 2017, 7:04 pm

Found this info about some blocking with a password...
Solved: Is there a way to password protect the access opti... - Mozilla Support Community
Maybe it will take you down a fix-path?
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

Grumpus

User avatar
 
Posts: 11595
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted April 18th, 2017, 5:03 am

Mozilla.cfg from dfoulkes link does not appear to exist in Ubuntu and Mint Linux systems.
Link appears to be more MS related.
You may have changed something with regard to permissions in the Linux system itself.
You can open Nautilus and see the permission levels in a column which can be made visible using the /edit/Preferences /list columns.
You can change the permissions as the owner of a file or you may be able to access the file using admin privileges.

gewe
 
Posts: 9
Joined: November 5th, 2004, 12:46 am
Location: EU

Post Posted April 18th, 2017, 9:06 am

Found it!

I had the extension Procon Latte (a content filter) installed. The configuration was protected with a password, but that included the about:config and about:addons screens as well.
I removed the password from Procon Latte, and I can now open about:addons without being nagged for a password. Since my son is now at an age that he has his own computer, I think I will uninstall Procon Latte...

Thanks everyone!

dfoulkes

User avatar
 
Posts: 22131
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted April 18th, 2017, 9:16 am

I don't have that file either... so, maybe the user has to create it? ... some of cor-el's dialog almost sounds like that????
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 26 guests