MozillaZine

HELP: all plugins disabled due to error in system clock

User Help for Mozilla Firefox
ginahoy
 
Posts: 186
Joined: October 18th, 2007, 8:32 pm

Post Posted April 18th, 2017, 4:02 pm

I just updated my system clock and didn't realize I accidentally scrolled the year to 2011 with my mouse-wheel. Unfortunately, this disabled all my FF plugins, as I opened the browser before I realized what had happened.

Several plugins had updates so I was able to get them working again, but another dozen or so are up-to-date, so I don't see a way to enable these. The only option presented is the 'Remove' button. I prefer not to have to remove and reinstall all these extensions, as I'm not sure which if any will protect any changes I may have made to the settings.

Surely there must be a way to force these plugins to re-enable. Any ideas?

therube

User avatar
 
Posts: 17767
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 18th, 2017, 5:09 pm

Are you sure your Profile did not Reset?

No, it did not.

Are your bookmarks & history there as expected?

Yes.

When you say "plugins", are you meaning "extensions" or "Plugins" or both?

Extensions.

(You do realize that you are running FF 51. FF 52 ESR [is what you should be using with XP]. FF 53 will be out tomorrow or so, but no longer supports XP.)


I'm running FF 52 as "04/18/2011" (using RunAsDate) seemingly without issue (other then https: sites are [expectantly] complaining, https://www.youtube.com/) without [NoScript] being disabled.


(Interestingly, by setting an old date, FF reverts to using /Cache/ rather then /cache2/ - even on a current FF. ;-).)

Actually that's not quite right.
What happens is that is sets up the /Cache/ directory structure, populating it with the expected directories & ~12 MB of _CACHE_00#_ files, but actually uses the /cache2/ for its cache.

[SeaMonkey still uses /Cache/, but creates an empty /cache2/ directory ;-).]
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 17767
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 18th, 2017, 5:54 pm

Now that I've straightened out all of the above ...

I sitting here, FF still open, & out of the blue...

Image

And then I look in about:plugins...

Image


So it seems in fact that FF will disable extensions if your date is incorrect.

How mighty nice of them.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 17767
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 18th, 2017, 5:58 pm

The only option presented is the 'Remove' button.

True.


After correcting the date & restarting FF, I (about:plugins, Check for Updates), which downloaded & installed my existing (disabled) extensions, awaiting a restart to set them as enabled.

So do a 'Check for Updates', looks like it should right things.


(I wonder if the disabling doesn't have to do with the [now obligatory] signing?)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

therube

User avatar
 
Posts: 17767
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 18th, 2017, 6:39 pm

Several plugins had updates so I was able to get them working again, but another dozen or so are up-to-date, so I don't see a way to enable these.

Hmm...

Only thing I can think to do is to grab (drag) the (respective) .xpi from Profile folder/extensions/ into FF, installing it again.

I wouldn't think that should affect any settings?
(Can't hurt to backup first.)


(From about:support -> Extensions, you can match the "GUI-ID" name with the "simple" name.
Or you could just download the needed extensions again...)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

ginahoy
 
Posts: 186
Joined: October 18th, 2007, 8:32 pm

Post Posted April 18th, 2017, 6:45 pm

(scratching my head as to who you were quoting in your first post...???)

Nevertheless, to respond to your questions, yes, I was referring to extensions not plugins. My bad. Plugins were not affected. I'm sure this was related to obligatory signing.

Before posting my question, I corrected the system clock then my extensions went away. So I closed FF and restarted. No cigar. However, when opened FF just now to view your posts, I see that all my extensions are enabled! I have no idea why that didn't happen the first time I restarted, but its all good now.

As for my FF version, I've had too many problems over the years with automatic updates so my strategy has been to hold off as long as possible. I will be building a new machine later this year (Linux Mint). I really look forward to finally moving away from Windows :D

therube

User avatar
 
Posts: 17767
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 18th, 2017, 6:51 pm

(I was quoting myself, as I figured out the answers to my own questions [to you] ;-).)

I see that all my extensions are now enabled! I have no idea why that didn't happen the first time

I've got a thought on that, & that is FF downloaded a new blocklist.xml, triggering a check of "systems", at which time it found things "OK", so reset your extensions to "enabled".
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

ginahoy
 
Posts: 186
Joined: October 18th, 2007, 8:32 pm

Post Posted April 18th, 2017, 6:57 pm

I really appreciate the assist!

dickvl

User avatar
 
Posts: 52279
Joined: July 18th, 2005, 3:25 am

Post Posted April 18th, 2017, 7:55 pm

Try to delete the extensions.json file in the profile folder.
You may also have to reset some extensions preferences on the about:config page that store the extension's state.

Return to Firefox Support


Who is online

Users browsing this forum: Gubbio and 25 guests