MozillaZine

Firefox 53.0: "magnetic link" no longer works, why?

User Help for Mozilla Firefox
FoxAdriano
 
Posts: 10
Joined: January 12th, 2013, 4:12 am

Post Posted April 24th, 2017, 2:15 am

Hi, I'm using qTorrent for several years and I've never had this problem. When I found a torrent with Firefox and clicked on it with "magnetic lin" option, it downloaded the file and then it automatically opened qTorrent and the file was loaded.
For a while, when I click on the torrent with the "magnetic link" option nothing happens. But nothing.
Maybe do I have to configure my qTorrent software or is Firefox the problem?
I use the latest version of Firefox and in Tools/Options it is well configured. However with Internet Explorer "Magnetic link" works fine.
Only with Firefox I have this problem. What can I do?
Thank you

LIMPET235
Moderator

User avatar
 
Posts: 37155
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted April 24th, 2017, 3:20 am

Moving to Firefox Support...
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-50.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.9.0.
RadioYachting. Conficker Test. (Always choose the "Custom" Install.)

therube

User avatar
 
Posts: 17059
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 24th, 2017, 5:18 am

There must have been a related FF extension, or similar, involved, I would think.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

WaltS48

User avatar
 
Posts: 3165
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted April 24th, 2017, 5:42 am

@FoxAdriano

Check your Options > Applications for magnet in the Content Type column and qTorrent under Action.

I use qBittorrent and have no trouble activating magnet links.
Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

FoxAdriano
 
Posts: 10
Joined: January 12th, 2013, 4:12 am

Post Posted April 24th, 2017, 6:43 am

WaltS48 wrote:@FoxAdriano

Check your Options > Applications for magnet in the Content Type column and qTorrent under Action.

I use qBittorrent and have no trouble activating magnet links.


Firefox is configured well.

dickvl

User avatar
 
Posts: 51977
Joined: July 18th, 2005, 3:25 am

Post Posted April 24th, 2017, 9:28 pm

Try to rename/remove the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.
http://kb.mozillazine.org/mimeTypes.rdf
http://kb.mozillazine.org/File_types_an ... ad_actions

You can use the "Help -> Troubleshooting Information" (about:support) page or the about:profiles page to go to the current Firefox profile folder.
Help -> Troubleshooting Information -> Profile Directory: Windows: Show Folder

FoxAdriano
 
Posts: 10
Joined: January 12th, 2013, 4:12 am

Post Posted April 26th, 2017, 5:23 am

Ok, thanks for your news.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 8 guests