Firefox version 52 is intrusive

User Help for Mozilla Firefox
cynthia ramon
Posts: 2
Joined: April 25th, 2017, 1:46 pm

Post Posted April 25th, 2017, 2:35 pm

How can I stop Fire Fox from blocking websites on the ground of insecure or ownership not known. Why is facebook secure and daily kos not? I have used Fire Fox as a browser for 12 years because it was an open, people's, user friendly site. I tried using the permissions page but find it does not work. Ironically even logging in here was a pain as the insecure password window was in my way. If there is no way to stop this overt censorship and intrusiveness in version52 how can I as a non- geek go back to a version that does not police my browsing. I do not want to use Google Chrome, I don't like google, and this is the reason I use Firefox.. I want to be able to read and sign into websites that I decide are secure without jumping through Fire Fox's insane hoops. Anyone have a suggestion on how to handle this. What's with this obsessive concern and intrusive policing of my online browsing? Blocking images because they are insecure and using defaults that I have not selected is another problem. Do I have to be a programmer to make it possible to browse on my own computer?


User avatar
Posts: 120462
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted April 25th, 2017, 3:18 pm

Moving to Firefox Support as no bug has been identified here.

cynthia ramon
Posts: 2
Joined: April 25th, 2017, 1:46 pm

Post Posted April 25th, 2017, 6:09 pm

How about a link to wherever you moved this? No bug but a major problem and no solution that Fire Fox support seems willing to address. Too bad I really loved this browser but Chrome here I come. I have tried for the last month to find a solution on Firefox support and all I get is a runaround and bs about how all this ridiculous security this is for my own good or some such nonsense. I'm a graphic artist and the loading of images censorship is just not tolerable. Adios it was nice being here for the 12 years that allowed me to browse freely.


User avatar
Posts: 27435
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted April 25th, 2017, 6:50 pm

There is no link as you are posting in the very thread you posted as it was moved from the Firefox Bugs to Firefox support section of

If you look at the bottom of the right sidebar and at you will see that this is a independent forum. Mozilla has had their own support site at since 2007/2008. Also there are no links on top/bottom like a typical * page as another hint.

btw other web browsers are or will be doing a similar thing with insecure websites.


User avatar
Posts: 1259
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted April 25th, 2017, 9:38 pm

Go to about:config and set "security.insecure_field_warning.contextual.enabled" to "false" to turn that off. That will get rid of the insecure login warning.

Posts: 3850
Joined: March 19th, 2005, 10:51 am

Post Posted April 26th, 2017, 8:28 am

why do people always start ranting instead asking for a solution? in special users which uses firefox for so long time - those should know all about changes for this product. and dont using the current release - crying at high level with an insecure product.


User avatar
Posts: 52429
Joined: July 18th, 2005, 3:25 am

Post Posted April 27th, 2017, 2:23 am

Note that the dailykos website has a certificate installed, but loads a lot of content via an open HTTP connection which will make Firefox show the connection as insecure anyway.
You can see this in the Network Monitor

See also: ... ng-firefox ... tp-please/ ... cure-http/

Return to Firefox Support

Who is online

Users browsing this forum: xtreambee and 9 guests