MozillaZine

Sudden black screen on Firefox

User Help for Mozilla Firefox
larc

User avatar
 
Posts: 22
Joined: December 26th, 2006, 5:37 pm

Post Posted May 4th, 2017, 7:22 am

Occasionally getting a sudden black screen on Firefox after a site is opened. All of Firefox except the screen is still visible. This has been going on for at least a couple of months and happens only with Firefox. Refreshing or changing web sites makes no difference. The only fix I've found is to shut Firefox down and restart it. Running Windows 10 Pro x64 with Firefox x64. Video is Nvidia GTX 1050 with the latest driver. Anybody found a permanent fix or is it just a Firefox bug?
Larc

Frank Lion

User avatar
 
Posts: 19243
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted May 4th, 2017, 9:03 am

Disable Hardware Acceleration in Options>Advanced.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

larc

User avatar
 
Posts: 22
Joined: December 26th, 2006, 5:37 pm

Post Posted May 4th, 2017, 9:20 pm

Thanks, but I need that for 4k videos. If Firefox can't accommodate hardware acceleration properly, then Firefox has a problem that needs to be dealt with.
Larc

JayhawksRock

User avatar
 
Posts: 10403
Joined: October 24th, 2010, 8:51 am

Post Posted May 4th, 2017, 9:34 pm

larc wrote:Thanks, but I need that for 4k videos. If Firefox can't accommodate hardware acceleration properly, then Firefox has a problem that needs to be dealt with.

Well, get on over to Mozilla and demand a fix and / or get your money back
https://qsurvey.mozilla.com/s3/FirefoxInput/
"The trouble with quotes on the internet is you never know if they are genuine" ...Abraham Lincoln

Frank Lion

User avatar
 
Posts: 19243
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted May 5th, 2017, 3:02 am

larc wrote:Thanks, but I need that for 4k videos. If Firefox can't accommodate hardware acceleration properly, then Firefox has a problem that needs to be dealt with.

If you can't be bothered to try out a simple troubleshooting suggestion properly, then it is you who has a problem.

If I had suggested that you tried the diagnostic step of trying SafeMode, would than mean that I was suggesting that you permanently remained in SafeMode? No.

Why did you bother coming here? Troubleshooting problems is what we do and it's done through a series of elimination steps. If you want to get on your high horse and not even try them, then you are on your own, chum.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Reflective

User avatar
 
Posts: 1929
Joined: February 15th, 2007, 11:13 am

Post Posted May 5th, 2017, 4:46 am

I've had the same problem and don't use h/w acceleration. The way I fixed it was to install an extension called No Squint Plus and then checkmark the option called "Background" to turn a black background white. Settings in No Squint Plus are per site so that checkmarking "Background" on the site you're having a problem with won't other sites that use them.

You can also grab the menu panel with the mouse to move it out of the way if it's blocking the view of a change you want to make so that you can see what the result will be. I use it primarily to turn pale grey fonts to black which makes them easier to read.

larc

User avatar
 
Posts: 22
Joined: December 26th, 2006, 5:37 pm

Post Posted May 5th, 2017, 3:06 pm

Frank Lion wrote:
larc wrote:Thanks, but I need that for 4k videos. If Firefox can't accommodate hardware acceleration properly, then Firefox has a problem that needs to be dealt with.

If you can't be bothered to try out a simple troubleshooting suggestion properly, then it is you who has a problem.
You are making an invalid assumption. I have tried it. It's not a new a fix, but one that's been suggested for a few years. I came here as a last resort, not a first one. Turning off hardware acceleration makes 4k videos unacceptably jumpy.
Last edited by larc on May 5th, 2017, 3:13 pm, edited 1 time in total.
Larc

larc

User avatar
 
Posts: 22
Joined: December 26th, 2006, 5:37 pm

Post Posted May 5th, 2017, 3:10 pm

Reflective wrote:I've had the same problem and don't use h/w acceleration. The way I fixed it was to install an extension called No Squint Plus and then checkmark the option called "Background" to turn a black background white. Settings in No Squint Plus are per site so that checkmarking "Background" on the site you're having a problem with won't other sites that use them.
Thanks. I'll try that.
Larc

cr0m
 
Posts: 3
Joined: May 10th, 2017, 5:31 am

Post Posted May 10th, 2017, 5:45 am

I've been experiencing the same issue. I'm not certain, but I believe it has to do with recent nVidia drivers. I was not experiencing this under driver version 378.49, but upon upgrading to 381.65, I started experiencing the issue. I've since tried going to 381.89, but haven't yet tried reverting to confirm my suspicions.

One of the main reasons I think the nVidia drivers are at least partly to blame, is I've experienced other issues in Firefox previously back in the 31x.xx to 33x.xx era of drivers. Back then, only when browsing in Firefox, the nVidia driver would randomly crash (and then Windows would recover). It never happened while doing anything else on the PC, including playing games or using other browsers. Only when using Firefox. Normally that would make me blame Firefox, but nVidia has been releasing exceptionally buggy drivers the past few years, and it's a crapshoot trying to find a recent set of drivers without any major problems with my use case.

Reflective

User avatar
 
Posts: 1929
Joined: February 15th, 2007, 11:13 am

Post Posted May 10th, 2017, 7:01 am

cr0m wrote:I've been experiencing the same issue. I'm not certain, but I believe it has to do with recent nVidia drivers. I was not experiencing this under driver version 378.49, but upon upgrading to 381.65, I started experiencing the issue. I've since tried going to 381.89, but haven't yet tried reverting to confirm my suspicions.

One of the main reasons I think the nVidia drivers are at least partly to blame, is I've experienced other issues in Firefox previously back in the 31x.xx to 33x.xx era of drivers. Back then, only when browsing in Firefox, the nVidia driver would randomly crash (and then Windows would recover). It never happened while doing anything else on the PC, including playing games or using other browsers. Only when using Firefox. Normally that would make me blame Firefox, but nVidia has been releasing exceptionally buggy drivers the past few years, and it's a crapshoot trying to find a recent set of drivers without any major problems with my use case.

I use Display Driver Uninstaller (DDU) which completely removes the current drivers prior to installing the next version. Maybe give that a try to determine whether it fixes the problem for you.

My own system is an Acer Aspire V3-772G laptop running Windows 8.1

cr0m
 
Posts: 3
Joined: May 10th, 2017, 5:31 am

Post Posted May 10th, 2017, 7:53 am

Reflective wrote:I use Display Driver Uninstaller (DDU) which completely removes the current drivers prior to installing the next version. Maybe give that a try to determine whether it fixes the problem for you.

My own system is an Acer Aspire V3-772G laptop running Windows 8.1


I've been using DDU before every new video driver installation for a couple of years now, it's a great program. Unfortunately, that has not remedied the situation.

deustroop
 
Posts: 16
Joined: June 27th, 2017, 10:05 am

Post Posted June 30th, 2017, 2:03 pm

I have the same problem, the black screen only solved by not using HA. That is unsatisfactory since HA is very useful. FF should look at this .Here is my thread in Support Forum
viewtopic.php?f=38&t=3031380&e=0

EasterEEL
 
Posts: 9
Joined: February 23rd, 2013, 2:23 pm

Post Posted July 11th, 2017, 3:19 am

I have been getting this problem exactly as described since updating to the Creators Edition of Windows 10. I held off updating for while due to incompatibilities with Checkpoint VPN software.

The issue manifests as a black screen affecting all open tabs in Firefox. Minimising / maximising has no effect.
Completely random, it can happen when I am browsing, scrolling, switching tabs or just moving the mouse across a web page.
Opening another instance of Firefox has the same issue.
The only resolution is to completely close Firefox and start again.

I never saw this problem prior to updating to Creators Edition.
I have rolled back to pre Creators Edition and cannot recreate the problem.
Roll forward to Creators Edition and the problem returns.
Firefox is same version with same add-ons.
Same graphics drivers used (March-17) - NVidia 378.78-desktop-win10-64bit-international-whql.
I tried most recent graphics drivers (June-17) with Creators Edition and no improvement - Nvidia 384.76-desktop-win10-64bit-international-whql.

The issue is accompanied with the event error message 4101: Display driver nvlddmkm stopped responding and has successfully recovered. Therefore I am certain the Firefox black screen is as a result of the display error. However the display error message is only occurring when using Firefox and is not repeatable playing games or running benchmarks. I am very confident this display issue has been introduced with Creators Edition and only occurs with Firefox but have not been able to track down exactly what is going on and continuing to investigate.

cr0m
 
Posts: 3
Joined: May 10th, 2017, 5:31 am

Post Posted July 11th, 2017, 12:00 pm

EasterEEL, can you try using DDU to do a full uninstall of the nvidia drivers, and then install nvidia driver version 378.49? I reverted to 378.49 and no longer get the black screen. Every version after 378.49, including the latest, 384.76, gives me that issue. I am also on Windows 10 x64 Home Creators Update.

EasterEEL
 
Posts: 9
Joined: February 23rd, 2013, 2:23 pm

Post Posted July 14th, 2017, 2:03 pm

I have had the black screen issue a couple of times since last post and confirmed both times it was accompanied by event error message 4101: Display driver nvlddmkm stopped responding and has successfully recovered.

cr0m, I have used DDU to fully uninstall the Nvidia drivers and installed 378.49 and will post back how it goes over the next week.

Incidentally I had to use gpedit to enable "Do not include drivers with Windows Updates" to stop Windows Update from updating hardware drivers as it was immediately updating the Nvidia drivers to 382.05.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 10 guests