MozillaZine

can't view images directly over HTTPS

User Help for Mozilla Firefox
Jatopian
 
Posts: 10
Joined: February 18th, 2005, 6:06 pm

Post Posted May 13th, 2017, 10:15 pm

Hello. A few days ago, despite me not changing any setting I can think of, and not related to anything updating that I am aware of, I started to have an issue. I cannot directly view an image in the browser, if it is loaded over HTTPS. That is, if the URL is of an image file, like I'm trying to visit https://domain.name/image.png

However, I can do Ctrl+S and save the image to disk, where it is perfectly viewable in the image program of my choice.
Another clue - the issue does not arise in "safe mode". I have tried disabling some likely-looking addons to narrow the problem, but no dice.

Here is some info, including my addons, dumped as text from about:support
https://pastebin.com/DiVWTRXj

Any advice appreciated.

Brummelchen
 
Posts: 1466
Joined: March 19th, 2005, 10:51 am

Post Posted May 14th, 2017, 3:19 am

It is one of your still enabled extension - uB/uM cant cause this, i think more Ghostery (still buggy), https everywhere (buggy), ref control (pointless with uB)...

and you should look for alternatives to extension with "-signed.1-signed" - those are rather old and got no update since 2015, they must been buggy because firefox changed a lot in the last 2 years. i suggest a full refresh of your profile and start from scratch with settings. and stick with uBlock, not badger, noscript and this other "security" crap which is like an aluhelmet.

Reflective

User avatar
 
Posts: 1836
Joined: February 15th, 2007, 11:13 am

Post Posted May 14th, 2017, 7:18 am

You need to re-enable your extensions one by one testing a given link to an image each time until you find the one which is the culprit rather than trying to guess which one it might be.

Alternatively, you could enable half of them and then test it. If you're lucky and can view an image you know that the culprit lies in the other half of extensions which are still disabled.

Jatopian
 
Posts: 10
Joined: February 18th, 2005, 6:06 pm

Post Posted May 15th, 2017, 10:25 pm

Turns out it was badger. Thanks for the responses!

Brummelchen, I don't actually use uB or uM - I tried it briefly but quickly found it was a huge hassle. I can't remember why it's still sitting in my addon list as disabled... maybe I intended to try it again someday. Maybe it has changed, since you seem to like it so much.

Reflective

User avatar
 
Posts: 1836
Joined: February 15th, 2007, 11:13 am

Post Posted May 16th, 2017, 3:17 am

Jatopian wrote:Turns out it was badger. Thanks for the responses!

Purely out of curiousity could you provide a link to an image which you say badger was blocking? I use it myself but have never experienced any issues with it.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 12 guests