MozillaZine

media.autoplay.enabled set to false

User Help for Mozilla Firefox
heptapod
 
Posts: 1
Joined: May 18th, 2017, 6:53 am

Post Posted May 18th, 2017, 6:55 am

Yesterday I discovered media.autoplay.enabled in about:config, set it to false and enjoyed browsing the web without obnoxious autoplay video.

One thing I discovered is YouTube started loadind slowly, if at all, in addition to sites like imgur using .gifv formats giving me the experience of using the internet at 9600 baud.

Today I reset media.autoplay.enabled to true and YouTube is snappy as ever.

Is this a Firefox-only bug?

Grumpus

User avatar
 
Posts: 11150
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted May 18th, 2017, 11:26 am

Maybe these two links will help: Problems playing gifv files
Stops playing givfs

dickvl

User avatar
 
Posts: 51987
Joined: July 18th, 2005, 3:25 am

Post Posted May 18th, 2017, 9:07 pm

Setting media.autoplay.enabled to false isn't recommended since it can cause issues like you noticed.
A website can use JavaScript and try to start the player, but fails to do this properly and thus hangs.
On some websites you may have to click play twice in case autostart is active.

Reflective

User avatar
 
Posts: 1845
Joined: February 15th, 2007, 11:13 am

Post Posted May 19th, 2017, 12:05 am

I have media.autoplay.enabled set to false as well, but I don't find it troublesome. Just click the video which causes the play arrow to appear and then click that.

As regards gifv files not playing initially all you need to do is to right click them and then click "Play".

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 34 guests