MozillaZine

Where's the setting that displays tab close buttons?[Solved]

User Help for Mozilla Firefox
voipfc
 
Posts: 57
Joined: November 16th, 2006, 11:16 am
Location: Accra

Post Posted June 18th, 2017, 12:09 pm

I use a number of different profiles and in one profile the tab closing buttons are displayed, but don't display in another. Is there some setting in about:config that sets it. I use a number of tab related addons and don't know if the fault could be one of them but I really don't think so.

This is how the wrong one looks
Image

This is how it should look
Image

I use a tab unloading utility and without the button trying to close the tab involves activating and reloading the content before closing it, which involves wasting time for the tab to load before being able to close
Last edited by LIMPET235 on June 19th, 2017, 7:41 am, edited 1 time in total.
Reason: Added [Solved] to the Title.

Happy112

User avatar
 
Posts: 207
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted June 18th, 2017, 1:48 pm

Hi !
There used to be a preference in about:config to set the value to display the closing button on each tab, but that's been removed (you can only set it to close the last tab).
But you really should disable those tab related add-ons you have, one by one, cause one of them just might be the culprit.
(I'm thinking about Tab Mix Plus, for instance)

Grumpus

User avatar
 
Posts: 11228
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted June 18th, 2017, 1:48 pm

Easiest thing to do is compare the theme used in the profiles as the "x" may be affected by the theme used.
In some cases the OS theme can conflict with the default theme or make it somewhat less decipherable.
You could also try any of the profiles in Safe Mode and see if the profile with the issue displays the "x" or some other character.
If in Safe Mode and the "x" displays there's a good possibility one or more of your extensions are affecting the display.
Once in Safe Mode you can enable your extensions one at a time allowing you to see what is causing the issue.

Happy112

User avatar
 
Posts: 207
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted June 18th, 2017, 2:01 pm

Grumpus wrote:If in Safe Mode and the "x" displays there's a good possibility one or more of your extensions are affecting the display.
Once in Safe Mode you can enable your extensions one at a time allowing you to see what is causing the issue.


You're right, of course, but :
Safe Mode disables all extensions; if the OP has a lot of other extensions than the tab related add-ons, it would be a lot of hassle having to enable them again.
To just disable the tab related add-ons (Tab Mix Plus for starters, if the OP has that one installed) would save a lot of time and hassle.

Grumpus

User avatar
 
Posts: 11228
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted June 19th, 2017, 4:24 am

As it appears to be a possible display issue any extension could be the culprit.
Usually it's good for the OP to list the current extensions in use for more clarity hence the suggestion to look at theme use to begin with.

Happy112

User avatar
 
Posts: 207
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted June 19th, 2017, 4:52 am

Grumpus wrote:As it appears to be a possible display issue any extension could be the culprit.
Usually it's good for the OP to list the current extensions in use for more clarity hence the suggestion to look at theme use to begin with.


Okay, Grumpy - you're right.

(Shaking my head and thinking : "Sure hope the OP will start with the tab related add-ons ..... ") :wink:

voipfc
 
Posts: 57
Joined: November 16th, 2006, 11:16 am
Location: Accra

Post Posted June 19th, 2017, 7:16 am

I found a fix which was posted here earlier. viewtopic.php?p=12835187#p12835187

The following CSS must be added to the file chrome/userChrome.css in your Profile directory

Code: Select all
.tab-close-button,.tab-close-button > .toolbarbutton-icon {
   display: -moz-box !important;
   opacity: 1.0 !important;
}


Its a pity the restrictions on the length of the topic title do not enable marking it as solved without changing the original title

Happy112

User avatar
 
Posts: 207
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted June 19th, 2017, 7:28 am

voipfc wrote:I found a fix which was posted here earlier. viewtopic.php?p=12835187#p12835187

The following CSS must be added to the file chrome/userChrome.css in your Profile directory

Code: Select all
.tab-close-button,.tab-close-button > .toolbarbutton-icon {
   display: -moz-box !important;
   opacity: 1.0 !important;
}


Its a pity the restrictions on the length of the topic title do not enable marking it as solved without changing the original title


Wow ! I'm truly impressed - well done !!!
And you're right : it is a pity that there is no 'Chosen Solution' or 'Solved' button here.
One should be able to mark the post that solved the problem as such - in this case : your last post.

Once again : well done - thumbs up and a bunch of kudos !

Return to Firefox Support


Who is online

Users browsing this forum: GarethB and 10 guests