MozillaZine

FF Not Responding - Web Page Slowing Down

User Help for Mozilla Firefox
BuzWeaver

User avatar
 
Posts: 101
Joined: November 14th, 2007, 9:11 am
Location: Atlanta GA USA

Post Posted July 15th, 2017, 2:17 pm

Recently I've been having some annoying issues with Win10. Thankfully its intermittent and relegated to a few programs. I was first getting Firfox Not Responding so I did a Refresh and now I'm getting Web Page is Slowing down your browser. As far as FF is concerned it typically ONLY does this on Facebook (using Emjoi's or moving from one comment back to the home page) and on rare occasions Twitter. All other sites (Forms and such), as far as I can tell have no issues. YouTube can get a little sluggish with loading pages, but no problems on VidMe when loading video pages there. Any suggestions and recommendations are appreciated.

Image


Image

DanRaisch
Moderator

User avatar
 
Posts: 116408
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted July 15th, 2017, 2:21 pm

After the refresh, did you install extensions in the new profile?
Do you see the same issue if you run Firefox in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode

BuzWeaver

User avatar
 
Posts: 101
Joined: November 14th, 2007, 9:11 am
Location: Atlanta GA USA

Post Posted July 15th, 2017, 3:29 pm

No extensions or addons added. Yes, it does it in FF Safe Mode as well. Mainly when trying to use Emoji's. I don't have to use emjoi's, but its sad that the emoji's are bogging down the browser.

Happy112

User avatar
 
Posts: 276
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted July 15th, 2017, 10:22 pm

Since last year the 'a web page is slowing down your browser' is a new way of saying that a script is unresponsive.
Would you follow the steps in this article, please, and see if that will make a difference ?

https://support.mozilla.org/en-US/kb/warning-unresponsive-script

BuzWeaver

User avatar
 
Posts: 101
Joined: November 14th, 2007, 9:11 am
Location: Atlanta GA USA

Post Posted July 16th, 2017, 4:32 am

Thanks Happy. The settings in about:config were already set up or was by default the same as the suggestions in the article. The Script Addon blocks FB all together from working so that wasn't a viable option. I uninstalled and reinstalled the latest update from Java. I'll see if that helps.

Reflective

User avatar
 
Posts: 1868
Joined: February 15th, 2007, 11:13 am

Post Posted July 16th, 2017, 4:47 am

You can try reloading a site by hitting CTRL+F5. This bypasses the cache and re-downloads the site directly from the server instead of using the cache.

If that appears to be faster, clear the cache via Tools ---> Options ---> Advanced and then click the Network tab. You'll find the option to clear it in there.

You can also configure Firefox to delete the cache every time you close it via Options ---> Privacy. Checkmark the box where it reads "Clear history when Firefox closes" and then click the Settings button. Checkmark the "Cache" option and remove the checkmark from the other options you want to retain. This is how I have FF configured myself.

If you can't see the menu where the above options can be found, click the dropdown menu under "History" and select "Use custom settings for history".

BuzWeaver

User avatar
 
Posts: 101
Joined: November 14th, 2007, 9:11 am
Location: Atlanta GA USA

Post Posted July 17th, 2017, 4:56 pm

I've done a clean removal and reinstall with suggested settings changes and its still happening. I've even fun Malware/Spyware and Virus scans. Very odd.

Happy112

User avatar
 
Posts: 276
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted July 21st, 2017, 10:37 am

Would you give this a try :

Type in the address bar about:config (and press Enter)
(promise to be careful, if asked)
Type 'processHang' in the search bar and look for the preferences :

dom.ipc.processHangMonitor
and :
dom.ipc.reportProcessHangs

Change their values from 'true' to 'false '

Does that work ?

BuzWeaver

User avatar
 
Posts: 101
Joined: November 14th, 2007, 9:11 am
Location: Atlanta GA USA

Post Posted July 21st, 2017, 11:01 am

Happy112 wrote:Would you give this a try :

Type in the address bar about:config (and press Enter)
(promise to be careful, if asked)
Type 'processHang' in the search bar and look for the preferences :

dom.ipc.processHangMonitor
and :
dom.ipc.reportProcessHangs

Change their values from 'true' to 'false '

Does that work ?


I've tried it, but I'll try it again with this new load.

BuzWeaver

User avatar
 
Posts: 101
Joined: November 14th, 2007, 9:11 am
Location: Atlanta GA USA

Post Posted July 22nd, 2017, 5:25 pm

I'm starting to think this may be a Java issue. I've removed Java entirely off my computer and when I've tried two different Script Stoppers and Debuggers I get this message from Facebook:

Image

Happy112

User avatar
 
Posts: 276
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted July 22nd, 2017, 10:51 pm

Okay - I know that you know the difference between Java and JavaScript, so I won't have to explain that.
I'm also pretty sure that you've checked in about:config to see if the pref 'javascript.enabled' has it's value set to 'true'.
Now, you say that you've tried two different Script stoppers (YesScript and NoScript, maybe ?) - did you make sure that they do NOT stop JavaScript on Facebook ?
Do that and the problem should be solved ......

See this thread on Mozilla support forum :

https://support.mozilla.org/en-US/questions/1168695

BuzWeaver

User avatar
 
Posts: 101
Joined: November 14th, 2007, 9:11 am
Location: Atlanta GA USA

Post Posted July 23rd, 2017, 5:20 am

Thanks Happy. I'm not entirely sure what's going on and more specifically why its Facebook in and of itself, but even with NoScript properly setup for Facebook it may have corrected an aspect of the Script problem, but now its causing hang. It's so bizarre how its just Facebook and not other website.

Happy112

User avatar
 
Posts: 276
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted July 23rd, 2017, 5:45 am

BuzWeaver wrote:It's so bizarre how its just Facebook and not other website.

Makes me feel like I've landed in some SciFi movie .......
Must admit that I haven't a clue as to what's going on here.
I can only hope that somebody else, with better working braincells, will come to your rescue (so sorry).

BuzWeaver

User avatar
 
Posts: 101
Joined: November 14th, 2007, 9:11 am
Location: Atlanta GA USA

Post Posted July 23rd, 2017, 8:06 am

It is remarkable considering that I visit quite a few other social media sites that are similar to FB like Minds, Twitter, VidMe, YouTube Creator Forums, just to name a few. It's like FB code is trolling me.

Happy112

User avatar
 
Posts: 276
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted July 23rd, 2017, 8:10 am

Giving it one more shot :

Have you tried this again (like you said you would) :

Type in the address bar about:config (and press Enter)
(promise to be careful, if asked)
Type 'processHang' in the search bar and look for the preferences :

dom.ipc.processHangMonitor
and :
dom.ipc.reportProcessHangs

Change their values from 'true' to 'false '

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 14 guests