MozillaZine

Firefox jumps to dialog box

User Help for Mozilla Firefox
Rei_Rihani
 
Posts: 3
Joined: August 10th, 2017, 10:32 am

Post Posted August 10th, 2017, 10:38 am

On a certain forum Firefox keeps jumping to the bottom of the page to place the cursor in the reply box. It does it on both my laptop and desktop - 54.0.1 on the former, 55.0 on the latter (both 64-bit). I've tried looking this problem up on the web but I can only find things about caret browsing and potentially an add-on is causing it. I've tried both, tried starting up in safe mode and it still happens (and I only have two add-ons anyway, UBlock Origin and LastPass).

This is driving me nuts so if anyone can point me the way to disabling this annoying feature, I'd be very grateful. The forum I'm talking about is here, and if say I go to any page with plenty of comments on it, such as this one, maybe you can try to reproduce the problem on your own version of Firefox.

BruceAWittmeier

User avatar
 
Posts: 2625
Joined: June 9th, 2008, 10:53 am
Location: Near 37.501685 -80.147967

Post Posted August 10th, 2017, 1:21 pm

Don't know if someone wants to create an account to test your post.

Are you possibly seeing the search for text box appear at the bottom of the page from the option "Search for text when you start typing".
~ I'm only here to Pay it Forward. ~

"I often take a very long windy road to my destination. When I arrive I often wonder how I missed the shortcut".

GHM113

User avatar
 
Posts: 678
Joined: December 16th, 2015, 3:59 am
Location: Moscow, Russia

Post Posted August 10th, 2017, 1:28 pm

Looks like this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=1377752
Should be fixed in 55.
Sorry for my poor English.

Rei_Rihani
 
Posts: 3
Joined: August 10th, 2017, 10:32 am

Post Posted August 10th, 2017, 2:59 pm

Bruce - Not sure what you're asking, sorry...

GHM113 - I'm running 55 on my desktop :/

EDIT - here is a gif to show what is happening, you can see the page automatically jumps down and the cursor appears in the reply box (which you can not see very well, apologies - but you can see the top of it).

Image

therube

User avatar
 
Posts: 18002
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted August 11th, 2017, 10:28 am

I would think it is specific to that forum.
IOW it is the forum that set it up to do that, not your browser.

Disable JavaScript,
(about:config
toggle the value of, javascript.enabled, to 'false')
then click your link to open that page.

What happens?


(Reset that Pref after testing.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Rei_Rihani
 
Posts: 3
Joined: August 10th, 2017, 10:32 am

Post Posted August 11th, 2017, 3:03 pm

That did stop it, but if it's specific to the forum I wonder why it doesn't do it on Edge, Chrome or Opera? I've gone through all the settings I could find and confirmed it with several friends (that don't use Firefox) who use the board - it doesn't happen to them.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 18 guests