MozillaZine

Bold font after updating to v56 (win 32)

User Help for Mozilla Firefox
rain-13
 
Posts: 30
Joined: February 8th, 2010, 9:28 am

Post Posted October 1st, 2017, 3:11 am

Hi!

I upgraded my 32bit ff to latest version (56) on 64 bit win 7. On some sites such as facebook and google search font is now bold everywhere. Fonts that were normal before are bold now. However, on some sites, such as this forum for example, normal font is normal. I tried to disable hardware acceleration to see if it makes the difference but it didnt. Can anyone suggest anything?

DanRaisch
Moderator

User avatar
 
Posts: 119760
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted October 1st, 2017, 3:27 am

Have you tried starting Firefox in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode
If no improvement using Safe Mode, do you have the same problem if you create a new profile and test it with no extensions or non-default themes installed?
http://kb.mozillazine.org/Profile_Manager
and
http://kb.mozillazine.org/Creating_a_ne ... on_Windows

rain-13
 
Posts: 30
Joined: February 8th, 2010, 9:28 am

Post Posted October 1st, 2017, 4:08 am

Have you tried starting Firefox in Mozilla Safe Mode?

Tried now. Did not help.

If no improvement using Safe Mode, do you have the same problem if you create a new profile and test it with no extensions or non-default themes installed?

Yes, the problem is still there.

Reflective

User avatar
 
Posts: 2283
Joined: February 15th, 2007, 11:13 am

Post Posted October 1st, 2017, 6:38 am

Copy/paste about:preferences#content in the location bar and hit Enter. In the "Fonts and Colors" menu click the Advanced button and remove the checkmark from the box where it reads, "Allow pages to choose their own fonts, instead of my selections above".

If it doesn't help try using an alternative font to Times New Roman such as Verdana for example.

therube

User avatar
 
Posts: 18799
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted October 1st, 2017, 8:53 am

Screenshot.

Anything particular with your Windows (OS) theme?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

zzz00m
 
Posts: 3
Joined: October 6th, 2017, 4:39 pm

Post Posted October 6th, 2017, 4:56 pm

I have experienced the same thing as the OP since upgrading to FF 56. One forum that I visit daily now has all of the text within individual posts all in bold text. I have gone to "Options > Language and appearance > Advanced" and unchecked the option "Allow pages to choose their own fonts".

This has corrected the bold text within the individual posts, but now when I view the post listings by topic, the new posts that used to be in bold are all normal now. This makes it difficult to tell the new (unviewed) posts apart from those that have been previously viewed.

If I open the same forum in Google Chrome, everything still works normally. I am using the default theme in Windows 10 Pro x64, v1607. FF 56 x64.

zzz00m
 
Posts: 3
Joined: October 6th, 2017, 4:39 pm

Post Posted October 7th, 2017, 11:49 am

zzz00m wrote:I have experienced the same thing as the OP since upgrading to FF 56. One forum that I visit daily now has all of the text within individual posts all in bold text. I have gone to "Options > Language and appearance > Advanced" and unchecked the option "Allow pages to choose their own fonts".

This has corrected the bold text within the individual posts, but now when I view the post listings by topic, the new posts that used to be in bold are all normal now. This makes it difficult to tell the new (unviewed) posts apart from those that have been previously viewed.

If I open the same forum in Google Chrome, everything still works normally. I am using the default theme in Windows 10 Pro x64, v1607. FF 56 x64.


Update: I have since noticed after the update to FF 56, I had both 32-bit and 64-bit versions of FF installed. I had been using FF 55 x64 as my default up until this update. I think I still had FF 55 x86 installed, but unused.

So I went into Windows Control Panel and uninstalled Firefox x86. This appears to have resolved my problem with seeing all bold fonts on certain web forums, when allowed to choose their own fonts. Firefox 56 x64 running good here now!

rain-13
 
Posts: 30
Joined: February 8th, 2010, 9:28 am

Post Posted October 13th, 2017, 2:46 pm

Sorry for not answering back sooner. I was away form home.

Copy/paste about:preferences#content in the location bar and hit Enter. In the "Fonts and Colors" menu click the Advanced button and remove the checkmark from the box where it reads, "Allow pages to choose their own fonts, instead of my selections above".

If it doesn't help try using an alternative font to Times New Roman such as Verdana for example.


It made things worse. Now this site is also in bold.

Screenshot.

Anything particular with your Windows (OS) theme?

Image

Nope. Normal windows 7 with stock theme. it was ok before FF update. So it cant be windows update. Because I have never updated windows. Just FF.

Update: I have since noticed after the update to FF 56, I had both 32-bit and 64-bit versions of FF installed. I had been using FF 55 x64 as my default up until this update. I think I still had FF 55 x86 installed, but unused.

So I went into Windows Control Panel and uninstalled Firefox x86. This appears to have resolved my problem with seeing all bold fonts on certain web forums, when allowed to choose their own fonts. Firefox 56 x64 running good here now!


I still have only x86 FF. I'll see what happens if I install x64...

Edit. This didnt help. Still same with x64.
Last edited by rain-13 on October 13th, 2017, 2:58 pm, edited 1 time in total.

zzz00m
 
Posts: 3
Joined: October 6th, 2017, 4:39 pm

Post Posted October 13th, 2017, 2:49 pm

maybe it's an x86 thingy.

rain-13
 
Posts: 30
Joined: February 8th, 2010, 9:28 am

Post Posted October 13th, 2017, 2:59 pm

maybe it's an x86 thingy.

nope

mightyglydd

User avatar
 
Posts: 9187
Joined: November 4th, 2006, 7:07 pm
Location: Hollywood Ca.

Post Posted October 13th, 2017, 5:22 pm

When you disabled 'Use Recommended Performance settings'/ 'Hardware Acceleration', did you restart Firefox ?

@Somewhat related ?
viewtopic.php?f=7&t=3028150
#KeepFightingMichael

rain-13
 
Posts: 30
Joined: February 8th, 2010, 9:28 am

Post Posted October 14th, 2017, 3:09 am

When you disabled 'Use Recommended Performance settings'/ 'Hardware Acceleration', did you restart Firefox ?

yes.

@Somewhat related ?
viewtopic.php?f=7&t=3028150

That finally helped. Here is just quote of post that solved my issue for faster access:

Font rendering changed between Firefox 51 and 52:

about:config --> gfx.canvas.azure.backends -->
about:config --> gfx.content.azure.backends -->

--> direct2d1.1,cairo,skia (Fx 51) <--> direct2d1.1,skia,cairo (Fx 52)


Does anyone know why it works?

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 8 guests