MozillaZine

How to remove “Send Page to Device” from right-click menu?

User Help for Mozilla Firefox
ALAKTORN
 
Posts: 7
Joined: July 5th, 2015, 8:52 am

Post Posted October 3rd, 2017, 5:29 pm

Title. I updated from ≈ 52 to 56 today and it’s showing this Send Page to Device option which I don’t want. How do I remove it?

dickvl

User avatar
 
Posts: 52279
Joined: July 18th, 2005, 3:25 am

Post Posted October 4th, 2017, 1:33 am

You can add code to the userChrome.css file below the default @namespace line.
http://kb.mozillazine.org/userChrome.css
http://kb.mozillazine.org/Editing_configuration

Code: Select all
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */
#context-sep-sendpagetodevice,
#context-sendpagetodevice { display:none!important; }

ALAKTORN
 
Posts: 7
Joined: July 5th, 2015, 8:52 am

Post Posted October 4th, 2017, 7:09 am

Thank you! That worked, but I still feel like the right-click menu doesn’t look like it did before… too bad I don’t remember how exactly it looked… there’s something that doesn’t look right around “Save Page As…” though… https://i.imgur.com/y0CRCuI.png

This is my current Chrome.css:
Code: Select all
#context-back image,
#context-forward image,
#context-reload image,
#context-stop image,
#context-bookmarkpage image{
  display:none !important;
}

#context-back:before,
#context-forward:before,
#context-reload:before,
#context-stop:before,
#context-bookmarkpage:before{
   content: attr(aria-label) !important;
  -moz-margin-start:31px !important;
}
#context-navigation{
  -moz-box-orient: vertical !important;
}
#context-navigation > .menuitem-iconic {
  -moz-box-pack: start !important;
}

#PopupAutoCompleteRichResult .autocomplete-richlistbox {max-height:300px!important;height:auto!important}
#PopupAutoCompleteRichResult .autocomplete-richlistitem[actiontype="visiturl"]{display:none!important}
#PopupAutoCompleteRichResult .autocomplete-richlistitem[actiontype="searchengine"]{display:none!important}
#context-sep-sendpagetodevice,
#context-sendpagetodevice { display:none!important; }


Edit: Now that I look at my bookmarks, there are 2 options I don’t want in there too… “Other Bookmarks” and “Mobile Bookmarks”, it doesn’t even let me click Delete on them. How do I remove them?

Edit: Googled the solution:
Code: Select all
#menu_unsortedBookmarks { display: none !important; }
#BMB_unsortedBookmarks { display: none !important; }
#menu_mobileBookmarks { display: none !important; }
#BMB_mobileBookmarks { display: none !important; }

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], samsam1147 and 19 guests