MozillaZine

"We have detected you are using the 64-bit version of Firefo

User Help for Mozilla Firefox
SeahawksXLVIII
 
Posts: 73
Joined: August 22nd, 2015, 6:33 pm

Post Posted October 21st, 2017, 5:57 am

After I installed Java, Firefox automatically opened up to verify that Java is working and the Java website gave the following error message:

"We have detected you are using the 64-bit version of Firefox which will not run the Java plugin."

First off, I did not even know that I had the 64-bit version. When first I installed Firefox, there was no 64-bit version, unless it updated to the 64-bit version by itself somewhere along the line.

So I Google the message to see if there was any suggestions on what to do about this but all I got was spamlike results. There was no information about this error message at all—not even when searching the message using quotes.

I am wondering if anybody else has came up with this error message because you would think that Firefox or Mozilla was smart enough to let Java run on the 64-bit version of Firefox.

Anybody got any suggestions?

DanRaisch
Moderator

User avatar
 
Posts: 119442
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted October 21st, 2017, 6:06 am

Nope, there are only a couple of plug-ins compatible with the 64bit version of Firefox. See this support article -- https://support.mozilla.org/en-US/questions/1105633

WaltS48

User avatar
 
Posts: 3633
Joined: May 7th, 2010, 9:38 am
Location: Pennsylvania, USA

Post Posted October 21st, 2017, 6:09 am

Linux Desktop - AMD Athlon(tm) II X3 455 3.3GHz | 8.0GB RAM | GeForce GT 630
Windows Notebook - AMD A8 7410 2.2GHz | 6.0GB RAM | AMD Radeon R5

James
Moderator

User avatar
 
Posts: 27287
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted October 21st, 2017, 2:10 pm

SeahawksXLVIII wrote:First off, I did not even know that I had the 64-bit version. When first I installed Firefox, there was no 64-bit version, unless it updated to the 64-bit version by itself somewhere along the line.

I am wondering if anybody else has came up with this error message because you would think that Firefox or Mozilla was smart enough to let Java run on the 64-bit version of Firefox.

64-bit (Win64) Firefox for 64-bit Windows has existed since Firefox 42.0 and listed on https://www.mozilla.org/firefox/all/ since Firefox 43.0. The main purpose for Firefox 56.0.1 was
for to migrate 32-bit Firefox users to 64-bit (on Windows only). https://www.mozilla.org/firefox/56.0.1/releasenotes/

Win64 Firefox up til 51.0 Release only allowed the 64-bit Flash Player and Silverlight NPAPI Plugins to run so Windows users had to use the 32-bit Firefox and 32-bit NPAPI Plugins. Firefox 52.0 and later Releases only allows the Flash Player to run whether on Windows, Mac OSX or Linux.

If you really must use the vulnerable Java Plugin in Firefox on Windows then you can use the 32-bit Firefox 52 ESR as mentioned on bottom of https://support.mozilla.org/en-US/kb/npapi-plugins

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 9 guests