MozillaZine

[Closed] Updating Flash on Ubuntu with FF57

User Help for Mozilla Firefox
cscj01
 
Posts: 34
Joined: April 19th, 2006, 9:27 am

Post Posted November 30th, 2017, 2:46 pm

Flash has been disabled for version 25.0.0.171 for security reasons. Got it. So in Add-ons Manager, I click Update Now for Shockwave Flash which takes me to a Firefox Blocked Add-ons page which says to "check for updates on Adobe's Flash Page. That, in turn provides a link to https://get.adobe.com/flashplayer/, where I have a pull down to select my option for installing version 27.0.0.187. The page recognizes my OS, and in the pull down, I select Apt for Debian/Ubuntu. I then click Download now and get a message saying "This link needs to be opened with an application. Send to:". The default is AptURL which makes no sense to me. So I choose another application, namely apt, which is what I use to install applications. Though the title bar of the window says "Launch application" it doesn't do that. It really wants a link to some location. I know I could use a .tar.gz file and manually install Adobe Flash, but has anyone successfully used apt to upgrade Adobe Flash and its plug-ins? I know this is probably a question for the Ubuntu forums, but I thought I'd give the Mozillazine forums a shot as well.
Last edited by cscj01 on November 30th, 2017, 3:33 pm, edited 1 time in total.

Grumpus

User avatar
 
Posts: 11660
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted November 30th, 2017, 3:01 pm

Looks like you have three steps to make it happen.
First pick the download form
Second open and sign the PDF agreement
And there's a third page but I did not try it because I do not use Flash.
. . . also Are you running GTK or KDE - there's a control panel in the Ubuntu repositories which might be helpful?

cscj01
 
Posts: 34
Joined: April 19th, 2006, 9:27 am

Post Posted November 30th, 2017, 3:32 pm

I found the control panel (for GTK) and installed it. That gives me the ability to upgrade Flash. Thanks for the tip.

James
Moderator

User avatar
 
Posts: 27114
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted November 30th, 2017, 4:52 pm

https://addons.mozilla.org/blocked/
Flash Player 27.0.0.159 and older has been soft blocked since Oct 19 due to critical vulnerabilities.

Unfortunately critical vulnerabilities have been found in most previous versions of Flash Plugin (since Dec 2015 if I recall). Though Mozilla for some reason removed many of the old Flash Player versions from being mentioned in the blocklist for last couple years.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 17 guests