MozillaZine

Firefox Sound in RDP connections

User Help for Mozilla Firefox
diligence
 
Posts: 66
Joined: April 30th, 2014, 3:42 pm

Post Posted November 30th, 2017, 3:15 pm

Apparently, there is a huge issue related to the absence of sound in FF when using a Remote Desktop Connection (RDP), as explained here:

https://support.mozilla.org/en-US/kb/i-cant-play-audio-remote-desktop-connection1

I too have this problem. It arose initially when I upgraded 64-bit FF version 54, and it has remained ever since. I am now using FF Quantum’s latest version on 64-bit Windows 10, and the problem persists. There is absolutely no sound coming from a web page in FF.

I have tried it with “all add-ons disabled” in Safe Mode, although I use one a few addons, but there were no change regardless. I am not inclined to “reduce the sandbox security level” as a remedy because it would defeat the purpose of using Firefox as a defensive tool.

One more point I should mention, which seems relevant to this issue. I am running the Windows 10 system as a virtual machine in Hyper-V on Windows Server. It is my understanding that such VMs connect to Hyper-V as if through a Remote Desktop Connection. When I mouse over Windows “Volume Mixer” application in the task bar, I see a popup showing it to be a “Remote Audio -100%”. Even so, I do not have any sound related problems with other browsers in this same VM.

Clearly, this is a Firefox issue. When I need sound, I have to open another browser in this same VM. Consequently, I am hoping that this functionality will return to normal in FF when Mozilla fixes the issue with remote connections. Thanks.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 3 guests