MozillaZine

Can't stop automatic updates.

User Help for Mozilla Firefox
StanH
 
Posts: 96
Joined: March 5th, 2005, 2:29 pm
Location: North St Paul MN

Post Posted December 7th, 2017, 12:03 pm

I recently downgraded Firefox to v56.0.2 and added "Add-on Update Checker". But when I shutdown and restarted Firefox,it updated automatically from 56.0.2 back to to 57 even though I selected option:
"Never check for updates(not recommended)"

What could have happened and how can I fix it?

Happy112

User avatar
 
Posts: 485
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted December 7th, 2017, 12:30 pm

Hi StanH !

Have you also unchecked : ' Use a background service to install updates ' ?

You could have the Mozilla Maintenance Service - would you please take a look at this article :

https://support.mozilla.org/en-US/kb/wh ... ce-service

StanH
 
Posts: 96
Joined: March 5th, 2005, 2:29 pm
Location: North St Paul MN

Post Posted December 7th, 2017, 1:05 pm

Thanks Happy112.
There was no option that says: ' Use a background service to install updates ' ?

There is a line that says: "Keep Firefox up to date for the best performance, stability, and security." But this line has no checkbox or option button on it.

In [control panel] [programs and features] I found Mozilla Maintenance Service and removed it.

Happy112

User avatar
 
Posts: 485
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted December 7th, 2017, 1:29 pm

StanH wrote:There was no option that says: ' Use a background service to install updates ' ?


Of course : you're still on FF 56 - totally forgot (sorry !)

In [control panel] [programs and features] I found Mozilla Maintenance Service and removed it.


Well done ! That should do it (fingers crossed ..... )

StanH
 
Posts: 96
Joined: March 5th, 2005, 2:29 pm
Location: North St Paul MN

Post Posted December 9th, 2017, 12:24 am

Upon startup of Firefox today it updated from 56.0.2 and replaced itself with 57.0.1.

This, even though while in 56.0.2 yesterday I had checked "Never check for updates(not recommended)" and had uninstalled Mozilla Maintenance Service.

You said to uncheck 'Use a background service to install updates', but as I said in reply, I could not find such option in 56.0.2.

Now I know why. When I uninstalled Mozilla Maintenance Service from 56.0.2 the uninstall process removed the option: 'Use a background service to install updates' and instead configured Firefox so as to automatically update -- even if the user sets automatic to off.

The solution was to:
1 reinstall 56.0.2(32) over 57.0.1(64), (I didn't uninstall 57.0.1)
2 leave Mozilla Maintenance Service in place,
3 turn off the option 'Use a background service to install updates'
4 select "Never check for updates (not recommended)"

I am now running Firefox 56.0.2(32 bit) with all my legacy add-ons all working. Changes are: NoScript is v5.1.8.1 and Xmarks is v4.5.0.8. This arrangement seems to be working.
Last edited by StanH on December 9th, 2017, 10:52 am, edited 1 time in total.

Happy112

User avatar
 
Posts: 485
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted December 9th, 2017, 1:04 am

StanH : hats off and a huge round of applause for you !!!

=D>

StanH
 
Posts: 96
Joined: March 5th, 2005, 2:29 pm
Location: North St Paul MN

Post Posted December 9th, 2017, 8:13 pm

OOPs, Firefox updated again! My Kaspersky Internet Security 2017 has an application updater component that updates Firefox 56.0.2 to 57 - regardless of the above.

Here is how I turned Kaspersky off for Firefox:
Opened Kaspersky Internet Security 2017: [More Tools] [Software Updater] [Start search] Then clicked the arrow to expand the drop-down list next to Firefox 56.0.2 and select [Skip this update] https://support.kaspersky.com/us/12668#block2

Verified that FF 56.0.2 is excluded from updating: [Settings] [Protection] [Software Updater] [Exclusions]

Happy112

User avatar
 
Posts: 485
Joined: April 15th, 2017, 10:25 am
Location: Never-Never-Land

Post Posted December 10th, 2017, 3:07 am

You're getting to be quite an expert, StanH !

I used to have Kaspersky - my life is sooo much better since I ditched it and rely on Windows built-in security and the safest browser on the planet (Firefox, of course, what else ?) ........

But again : well done, Stan ! =D>

therube

User avatar
 
Posts: 18901
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted December 12th, 2017, 8:56 pm

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 6 guests