MozillaZine

Adblocker slows browser down

User Help for Mozilla Firefox
Hardcore1
 
Posts: 2
Joined: December 12th, 2017, 1:32 pm

Post Posted December 12th, 2017, 2:10 pm

Hello everybody, I've got an "older" computer with a hard disk, 4 GB RAM, CPU E8400. About 1 year ago my browser experience was really nice, I could play browsergames, surf quickly and was happy. But now... The adblocking addon for firefox makes everything in Firefox laggy. It doesn't care if i take FF 57, FF56, FF50, or any other FF-versions. The reason for lag is the large list of blocked websites from the addon. I tested "Adblock Plus" and "Ublock Origins" but both programmes have large lists. Is there any list which blocks annoying ad with a smoother browsing experience? I also tested creating a new profile because of the old computer. When I shut down the adblocking program Firefox runs fine.

On my gaming computer with 16 GB Ram, SSD and newer CPU I don't have any performance problems with the same addons.

I hope u can help me.

elist74
 
Posts: 62
Joined: June 27th, 2013, 11:27 am

Post Posted December 12th, 2017, 3:18 pm

My old computer 4 gb ram 320HD amd athlon x2 7550 motherboard m2n68 (i think) work fine with "Ublock Origins" I do not have noscript.
Can be a conflict with another add-on?

disable all other exept the adblocking.

CaJazzman

User avatar
 
Posts: 302
Joined: March 5th, 2009, 2:21 pm
Location: Vacaville,California

Post Posted December 12th, 2017, 4:08 pm

Hardcore1 wrote:Hello everybody, I've got an "older" computer with a hard disk, 4 GB RAM, CPU E8400. About 1 year ago my browser experience was really nice, I could play browsergames, surf quickly and was happy. But now... The adblocking addon for firefox makes everything in Firefox laggy. It doesn't care if i take FF 57, FF56, FF50, or any other FF-versions. The reason for lag is the large list of blocked websites from the addon. I tested "Adblock Plus" and "Ublock Origins" but both programmes have large lists. Is there any list which blocks annoying ad with a smoother browsing experience? I also tested creating a new profile because of the old computer. When I shut down the adblocking program Firefox runs fine.

On my gaming computer with 16 GB Ram, SSD and newer CPU I don't have any performance problems with the same addons.

I hope u can help me.

Ty Ultimate Adblocker, and if it also causes issues, you just may need another pc. I had issues about 5 yrs agao, with some addons, with my old pc, and realized, it was time to upgrade to a newer pc, which I built myself. Now adays, with all the games and streaming, you need a more powerful pc. 8-)

Gingerbread Man

User avatar
 
Posts: 7734
Joined: January 30th, 2007, 10:55 am

Post Posted December 12th, 2017, 4:23 pm

Hello,

  1. Don't use Firefox 50. It's insecure. If you insist on using an old version, update to 52 ESR.
  2. Starting with Firefox 55, downgrading is guaranteed to wreck your profile. So start with a fresh profile.
  3. In uBlock Origin, leave "uBlock filters…" enabled, but uncheck everything else.
  4. Add EasyList without element hiding in the custom box at the bottom. The difference versus regular EasyList is that occasionally you'll come across some blank spaces that haven't been cleaned up. You can create your own filters for those.
    Code: Select all
    https://easylist-downloads.adblockplus.org/easylist_noelemhide.txt
  5. Enable EasyPrivacy as well if you like. Both Adguard and Fanboy's lists are much smaller, so if you still have performance problems, switch to one of those.

therube

User avatar
 
Posts: 18572
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted December 12th, 2017, 5:53 pm

I run an e4300 with, maybe its 2 GB RAM (if that), & [SeaMonkey] & uBlock [& NoScript & any other extensions I use] don't present me with any issues.
I use uBlock's default set of filters, not cut down as @G mentioned.

(Funnily, I put Adblock Plus in my brothers computer - in IE just today. At some point shortly thereafter, there is this relatively nondescript message at the bottom of the browser window saying that an [addon, whatever lingo IE uses] is slowing down the browser. And it says "21ms", where IE has a cutoff of 20ms after which you're warned. Win10 on a low powered laptop. IE really runs like crap, compared to FF [which I tested against]. On another brothers computer, more powerful, he points out that with IE, he has to wait & wait before he's finally able to scroll down a web page. I tell him to try a different browser. I see that he has a Chrome icon on his desktop, fires that up & he says, wow. It was that much of a difference. IE must really suck, I gather.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Hardcore1
 
Posts: 2
Joined: December 12th, 2017, 1:32 pm

Post Posted December 13th, 2017, 8:41 am

So yesterday I also had it in my head to try a new profile and it worked. Now everything runs fine again. Firefox 57.0.2 installed now. Thank you.

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 10 guests