MozillaZine

I Changed Background Color to Black - How Can I Revert?

User Help for Mozilla Firefox
skeezix

User avatar
 
Posts: 22
Joined: April 19th, 2012, 1:33 pm

Post Posted December 14th, 2017, 10:41 pm

While mucking around in FF's Options page I clicked in the Colors part and then accidentally clicked Black in the Background part. Then I clicked Okay and bingo! My background for all pages turned black. Now I cannot see the text in the Options page to change the background color back to white.

I think there is an entry in the About: part that I can edit to change the background color but I don't know what the entry is called. Can somebody please give me a hand here, or tell me what I can do to restore the background to white? Hopefully I can do it without resetting Firefox.

I'm using version 57.0.2.

skeezix

User avatar
 
Posts: 22
Joined: April 19th, 2012, 1:33 pm

Post Posted December 14th, 2017, 11:08 pm

I forgot to mention that I cannot use anything in Firefox because the FF window is black. Only a checkmark here and there appear, and I cannot move the mouse so that Colors is highlighted.

Gingerbread Man

User avatar
 
Posts: 7736
Joined: January 30th, 2007, 10:55 am

Post Posted December 15th, 2017, 1:15 am

  1. Exit Firefox.
  2. Launch Notepad.
  3. Click the File menu, then choose Open. In the filename box, type %AppData%\Mozilla\Firefox\Profiles\ As you do, the path should pop up autocomplete options, showing you a folder named <random string>.default If not, just press Enter and then you should have a list of folders including the aforementioned. Either way, open that <random string>.default folder, then the prefs.js file inside it.
  4. Press the F3 key and look for browser.display.document_color_use. Change its value to the default 0 if you're not using a High Contrast theme in Windows, or set it to 1 if you are. Save and close the file when done.
  5. Start Firefox. If you want, you can now change the background color in about:preferences.

skeezix

User avatar
 
Posts: 22
Joined: April 19th, 2012, 1:33 pm

Post Posted December 15th, 2017, 7:12 am

I followed your instructions but I have no prefs.js in my <random string>.default folder.

<random string> = C:\Users\ME\AppData\Roaming\Mozilla\Firefox\Profiles

I restored an older profile by using MozBackup 1.5.2 so I'm okay now. But where is prefs.js file that you mentioned? I will add it to your instructions in case I need it in the future.

Gingerbread Man

User avatar
 
Posts: 7736
Joined: January 30th, 2007, 10:55 am

Post Posted December 15th, 2017, 7:23 am

skeezix wrote:<random string> = C:\Users\ME\AppData\Roaming\Mozilla\Firefox\Profiles

That's the parent folder of <random string>.default
skeezix wrote:But where is prefs.js file that you mentioned?

Enter about:support into the location bar. Click the "Open Folder" button.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 5 guests