MozillaZine

[Solved] Weird characters in address bar bing suggestions

User Help for Mozilla Firefox
eddman
 
Posts: 5
Joined: December 16th, 2017, 10:53 am

Post Posted December 16th, 2017, 11:01 am

This started happening a few days ago and I haven't changed any settings in firefox. It does not happen with the other search providers, google, yahoo, wiki, etc.

Image

Anyone else having this issue?

EDIT: Just to add, it carries over into the search results.

Image
Last edited by eddman on December 17th, 2017, 8:24 am, edited 2 times in total.

smsmith
Moderator

User avatar
 
Posts: 19757
Joined: December 7th, 2004, 8:51 pm
Location: Indiana

Post Posted December 16th, 2017, 12:47 pm

What "settings" did you change? Just change the default search to Bing?
Give a man a fish, and he eats for a day. Teach a man to fish, and he eats for a lifetime.
I like poetry, long walks on the beach and poking dead things with a stick.
Please do not PM me for personal support. Keep posts here in the Forums instead and we all learn.

eddman
 
Posts: 5
Joined: December 16th, 2017, 10:53 am

Post Posted December 16th, 2017, 1:00 pm

smsmith wrote:What "settings" did you change? Just change the default search to Bing?

This started by itself a few days ago. I didn't change anything.

If you mean in the past, I did change it to bing but that was a long time ago and it was working fine all this time until this started.

Gingerbread Man

User avatar
 
Posts: 7742
Joined: January 30th, 2007, 10:55 am

Post Posted December 16th, 2017, 1:37 pm

I'm not seeing that in the location bar suggestions when testing your search query with Bing.
Does this happen when you start Firefox in Safe Mode?
If yes, does it also happen when you start Firefox in a brand new profile?

U+E000 and U+E001 are Private Use Area characters, meaning what character they actually correspond to depends on the font used. "Bing uses E000 and E001 to mark the beginning and end of query terms for hit highlighting." — Search API reference from Microsoft.

eddman
 
Posts: 5
Joined: December 16th, 2017, 10:53 am

Post Posted December 16th, 2017, 2:03 pm

Gingerbread Man wrote:I'm not seeing that in the location bar suggestions when testing your search query with Bing.
Does this happen when you start Firefox in Safe Mode?
If yes, does it also happen when you start Firefox in a brand new profile?


It does not happen in a second profile. It was probably a cookie issue though. I cleared them and it seems to have fixed it. I apologize for taking your time. I should've thought of it sooner.

dickvl

User avatar
 
Posts: 52425
Joined: July 18th, 2005, 3:25 am

Post Posted December 16th, 2017, 9:45 pm

That is one of the PUA areas for Unicode characters (E000–F8FF).
https://en.wikipedia.org/wiki/Private_Use_Areas

This area is usually used by downloadable fonts and in your case this font is either not downloaded (blocked) or otherwise not working or you copied this text from a source that uses these Unicode code points.
gfx.downloadable_fonts.enabled = true

See also the Web Console and Network Monitor for messages related to fonts.
https://developer.mozilla.org/en/Tools/Web_Console
https://developer.mozilla.org/en/Tools/Network_Monitor

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 12 guests