MozillaZine

FF 57: Can't reply in Microsoft Forums

User Help for Mozilla Firefox
johnpd
 
Posts: 34
Joined: November 1st, 2004, 8:06 pm

Post Posted January 9th, 2018, 3:49 am

I just upgraded my laptop to FF v57.0.4 from v54. When i go to the Microsoft Support Forums and try to reply to a post (click on the "Reply" button), nothing happens. The only extensions I have are NoScript and uBlock Origin. I disabled both and still was not able to post to the forum. If I use MS Edge or an earlier version of FF, i have no issues. How can this be fixed?

JohnD

MarkRH

User avatar
 
Posts: 1259
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted January 9th, 2018, 4:52 am

I was able to hit the Reply button in a thread here: https://answers.microsoft.com/en-us/win ... _7-update/

I have uBlock Origin with the default lists. Don't use NoScript.

I notice in your post that the useragent says Firefox 56 and not 57.

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 9th, 2018, 12:50 pm

Restart in Safe Mode & see if there is any difference.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

johnpd
 
Posts: 34
Joined: November 1st, 2004, 8:06 pm

Post Posted January 10th, 2018, 12:11 am

I restarted in Firefox Safe Mode. No difference.

JohnD

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 10th, 2018, 9:17 am

As a test, create a new, clean Profile & see if that works on the MS forums.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

LIMPET235
Moderator

User avatar
 
Posts: 38477
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted January 10th, 2018, 9:24 am

Please ref: the KB article for a tad more info...
> http://kb.mozillazine.org/Creating_a_ne ... on_Windows
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0-61.0-62.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
(Always choose the "Custom" Install.)

johnpd
 
Posts: 34
Joined: November 1st, 2004, 8:06 pm

Post Posted January 13th, 2018, 4:25 am

OK, I tried a new profile and that worked. Is it possible to find the issue with the old profile or should I just scrap it and import all my bookmarks etc. into the new one?

Johnd

LIMPET235
Moderator

User avatar
 
Posts: 38477
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted January 13th, 2018, 4:33 am

That's good news.
Please ref; this article for assistance on what to transfer over.
> http://kb.mozillazine.org/Transferring_ ... _-_Firefox

Leave the old Profile in place for a while.
Re-name it to ".old" if you want.
& do not use the Profile Manager to delete it unless you know exactly what to delete.
> http://kb.mozillazine.org/Profile_Manag ... _a_profile
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-57.0-61.0-62.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.11.0.
(Always choose the "Custom" Install.)

johnpd
 
Posts: 34
Joined: November 1st, 2004, 8:06 pm

Post Posted January 13th, 2018, 5:02 am

OK I found the problem. It is NoScript. I added uBlock Origin and that caused no problem. When I added NoScript, the issue returned. I initially uninstalled it and things worked again. So I reinstalled it and then disabled it, and everything works. So NoScript is the culprit. I tried disabling and even uninstalling it in the the old profile, but it still would not work there. This is unfortunate as I count on it to help protect me. I will see if I can leave a post for the developer.

JohnD

EDIT: I tried it again in the old profile after uninstalling NoScript and restarting FF, and now it works. I thought I had restarted before, but maybe not.

therube

User avatar
 
Posts: 19187
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 15th, 2018, 7:30 am

Working here, FF 57, NoScript 10.

URL: https://answers.microsoft.com/en-us/win ... 8e059ad0c5

Click Reply.
Nothing.
Allow microsoft.com, nothing.
[aspnetcdn.com & gfx.ms are at their defaults (allowed)]
Allow msecdn.net.

Reply works.
I'm asked to log in, & once I do, I'm presented with a Reply box, as expected.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

johnpd
 
Posts: 34
Joined: November 1st, 2004, 8:06 pm

Post Posted January 16th, 2018, 2:23 am

OK I got it working. I reinstalled NoScript but it did not appear on the toolbar, so I installed it again and then it showed up. My previous settings for the site were still there. The only thing that was disabled were two "clicktale" sites which I assume are not wanted. Tried the "Reply" again and this time it worked. Not sure what happened, but it seems to be ok now.

Thanks,
JohnD

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 6 guests