MozillaZine

Can'te disable "Always check if Firefox ..."

User Help for Mozilla Firefox
pokeefe0001
 
Posts: 72
Joined: January 18th, 2010, 4:25 pm
Location: Pacific Northwest, USA

Post Posted January 9th, 2018, 10:51 am

Sometime in the past - maybe just today - the Firefox option "Always check if Firefox is your default browser" is permanently checked. I cannot uncheck it. Now, Firefox is my default browser and I'm not likely to change that, but I want that to be my choice, not Mozilla's. How do I disable this option?
Patrick O'Keefe
Win10 x64 Pro, FF 57.0.4 TB 52.1.1

Brummelchen
 
Posts: 2885
Joined: March 19th, 2005, 10:51 am

Post Posted January 9th, 2018, 12:44 pm

you have to change that in windows default programs settings

therube

User avatar
 
Posts: 18202
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 9th, 2018, 1:21 pm

Permissions issue?
Or maybe Preferences not saved?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

pokeefe0001
 
Posts: 72
Joined: January 18th, 2010, 4:25 pm
Location: Pacific Northwest, USA

Post Posted January 9th, 2018, 4:24 pm

Brummelchen wrote:you have to change that in windows default programs settings

On my wife's laptop (which does not have Firefox as the default browser) the option is checkable.

therube wrote:Permissions issue?
Or maybe Preferences not saved?

I can change other options. I don't think it's a permissions problem unless that one option takes a higher level of authority.
Patrick O'Keefe
Win10 x64 Pro, FF 57.0.4 TB 52.1.1

psaulm119

User avatar
 
Posts: 632
Joined: November 4th, 2007, 2:23 pm

Post Posted January 9th, 2018, 5:17 pm

Go to about:config
browser.shell.checkDefaultBrowser and set it as false
Paul

pokeefe0001
 
Posts: 72
Joined: January 18th, 2010, 4:25 pm
Location: Pacific Northwest, USA

Post Posted January 11th, 2018, 8:16 pm

psaulm119 wrote:Go to about:config
browser.shell.checkDefaultBrowser and set it as false

Thank you. That worked. After changing the config value the option is now unchecked but checkable.

I'll look at the option on my other two computers. They allow the option to be changed on the Options page.
Patrick O'Keefe
Win10 x64 Pro, FF 57.0.4 TB 52.1.1

psaulm119

User avatar
 
Posts: 632
Joined: November 4th, 2007, 2:23 pm

Post Posted January 11th, 2018, 8:27 pm

No problem.
Paul

wingspar

User avatar
 
Posts: 123
Joined: April 23rd, 2004, 10:16 am

Post Posted January 11th, 2018, 11:35 pm

psaulm119 wrote:Go to about:config
browser.shell.checkDefaultBrowser and set it as false


Good info. Thanks for that. :D
Gary
Will Fly for Food

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 11 guests