MozillaZine

3rd Party comments section on websites disappeared

User Help for Mozilla Firefox
TrueAwesome
 
Posts: 3
Joined: January 25th, 2018, 2:57 pm

Post Posted January 25th, 2018, 3:16 pm

On my firefox for a long while now, I have been unable to see the comments sections of websites that use a few select 3rd party comments sections. Facebook comment section no longer appears on any website I visit. A few disqus comments systems have disappeared from sites(not all). For example, I can't see the comments section of any bleacher Report article due to the fact it uses facebook as a 3rd party comment system. The website Newsarama also doesn't work for me.

In safe mode the comments section does indeed work. The issue is that I only have a total of 4 extensions/add-ons. And I have already tested.
I have 3 plugs-ins(all of which were auto installed by firefox):
Shockwave Flash 28
OpenH264 video codec provided by Cisco Systems, inc
Widevine Content Decryption Module by Google Inc.

I have 1 Extension(already removed and tested for source of problem)
AdBlock Plus

Additional Info:
Firefox on my mobile device does show 3rd party comments section
Safe Mode does show 3rd party comments sections
Deleting adblock did not fix issue

DanRaisch
Moderator

User avatar
 
Posts: 118688
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 25th, 2018, 4:24 pm

What are the other 3 extensions you have in that profile?
Have you tried disabling them, one at a time, to see if one of them is the source of the problem?

TrueAwesome
 
Posts: 3
Joined: January 25th, 2018, 2:57 pm

Post Posted January 25th, 2018, 6:56 pm

DanRaisch wrote:What are the other 3 extensions you have in that profile?
Have you tried disabling them, one at a time, to see if one of them is the source of the problem?

I'm sorry I miss wrote. I have only one extension. and that is Adblock plus.

MarkRH

User avatar
 
Posts: 1211
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted January 25th, 2018, 9:35 pm

One thing, make sure that in about:preferences#privacy you do not have Tracking Protection set to Always. That will cause Twitter, Facebook, and other related widgets not to work.

therube

User avatar
 
Posts: 18321
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 25th, 2018, 9:35 pm

unable to see the comments sections of websites that use a few select 3rd party comments sections

URLs?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Ed1
 
Posts: 872
Joined: January 30th, 2005, 2:33 pm

Post Posted January 26th, 2018, 9:46 am

I too am unable to see the Comments sections on some websites - one is Politico.com. I have Tracking Protection - Always ticked.

MarkRH, does your comment mean that in order to see Comments on those websites, a user's unrelated web activity needs to be tracked?

EDIT: Just disabled Tracking Protection. Did not resolve this issue. I have a number of privacy related addons, so I'll have to check whether those are the problem -- UBlock Origin, Disconnect, Privacy Badger, Decentraleyes, ClearURLs, Cookie AutoDelete.
Last edited by Ed1 on January 26th, 2018, 10:12 am, edited 2 times in total.

Brummelchen
 
Posts: 3053
Joined: March 19th, 2005, 10:51 am

Post Posted January 26th, 2018, 9:52 am

you were asked about urls... there is nothing we can do unless.

Ed1
 
Posts: 872
Joined: January 30th, 2005, 2:33 pm

Post Posted January 26th, 2018, 9:53 am

Brummelchen wrote:you were asked about urls... there is nothing we can do unless.


I just added one to my post.

Brummelchen
 
Posts: 3053
Joined: March 19th, 2005, 10:51 am

Post Posted January 26th, 2018, 10:05 am

any specific there? i dont find some with comments - or it wont work, but then it would concern chromium too.

Ed1
 
Posts: 872
Joined: January 30th, 2005, 2:33 pm

Post Posted January 26th, 2018, 10:11 am

Brummelchen wrote:any specific there? i dont find some with comments - or it wont work, but then it would concern chromium too.


Brummelchen, every article on Politico.com has a Show Comments black button at the end of the article. Clicking on it in Firefox does nothing. When using Microsoft Edge browser, the Comments are loaded onto the same page when that button is clicked.

therube

User avatar
 
Posts: 18321
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 26th, 2018, 10:52 am

every article on Politico.com has a Show Comments black button at the end of the article

Every article may have a "button", but not every article has comments.

This one does, https://www.politico.com/magazine/story ... rea-216486

Don't know why it is not working in FF?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Ed1
 
Posts: 872
Joined: January 30th, 2005, 2:33 pm

Post Posted January 26th, 2018, 11:23 am

Same problem on this story, which displays Comments when the Comments button is clicked on MS Edge, but not Firefox for me.

http://bleacherreport.com/articles/2755 ... =editorial

EDIT: In Firefox safe mode, the Comments display correctly when the Comments link is clicked at the end of the above story. So it appears to be an issue with one of my addons blocking the Comments. I'll be doing some further testing.

Brummelchen
 
Posts: 3053
Joined: March 19th, 2005, 10:51 am

Post Posted January 26th, 2018, 11:40 am

but not every article has comments.

thats what i asked again.

if a fresh profile wont help then its a blocker outside, probably on your system, any antivirus present? look there into logs.

on my system its blocked by HOSTS file, investigating...

-> its a combination of facebook and some other servers.

DanRaisch
Moderator

User avatar
 
Posts: 118688
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 26th, 2018, 12:25 pm

The comments display properly and I can enter a new comment using Firefox 58 under Win 10.

TrueAwesome
 
Posts: 3
Joined: January 25th, 2018, 2:57 pm

Post Posted January 26th, 2018, 12:42 pm

I caved and refreshed my firefox and everything works now. I even installed the same Add-on i had last time. AdBlock Plus

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 12 guests