MozillaZine

FF 58- Slower

User Help for Mozilla Firefox
Frank Lion

User avatar
 
Posts: 20063
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted January 29th, 2018, 2:12 am

As a test, people with this problem should try Menu > Options/Preferences > Privacy & Security and uncheck the 'Block dangerous and Deceptive Content' box. Then restart Firefox.

If no improvement is seen then, with Firefox closed, go to the safebrowsing folder and rename it to safebrowsing1. Then start Firefox and retest.

Your safebrowsing folder is located -

~/.cache/mozilla/firefox/XXXX/safebrowsing/ on Linux
~/Library/Caches/Firefox/Profiles/XXXX/safebrowsing/ on Mac
C:\Users\XXXX\AppData\Local\mozilla\firefox\profiles\XXXX\safebrowsing\ on Windows

After testing, all the changes can be reverted back, if you wish to.
Last edited by Frank Lion on January 29th, 2018, 10:01 am, edited 1 time in total.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

therube

User avatar
 
Posts: 19109
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 29th, 2018, 9:54 am

Also, if you could note (here) the date of /safe/browsing/goog-phish*.*.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Hönö
 
Posts: 43
Joined: June 24th, 2005, 3:56 am

Post Posted January 29th, 2018, 1:29 pm

Since I don't have the problem on Ubuntu, I decided to try and disable the browsing protection features of my Internet Security software, but it didn't help any.

Also, updating FF to 58.0.1 has not helped. It's getting rather tiresome.

Hönö
 
Posts: 43
Joined: June 24th, 2005, 3:56 am

Post Posted January 29th, 2018, 1:35 pm

Frank Lion wrote:As a test, people with this problem should try Menu > Options/Preferences > Privacy & Security and uncheck the 'Block dangerous and Deceptive Content' box. Then restart Firefox.

Nope, does not help.

Frank Lion

User avatar
 
Posts: 20063
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted January 29th, 2018, 1:38 pm

Hönö wrote:
Frank Lion wrote:As a test, people with this problem should try Menu > Options/Preferences > Privacy & Security and uncheck the 'Block dangerous and Deceptive Content' box. Then restart Firefox.

Nope, does not help.

Did you then go on to the second part of the test? -

If no improvement is seen then, with Firefox closed, go to the safebrowsing folder and rename it to safebrowsing1. Then start Firefox and retest.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Peter 123
 
Posts: 4
Joined: January 29th, 2018, 6:51 pm

Post Posted January 29th, 2018, 7:10 pm

Hello,

I just registered in this forum because it is good to see that I am not alone with my problem. I can confirm the issue reported by viper69 and Hönö:

With Firefox 58 (58.0.1) the loading of the starting page became quite (until very) slowly.

Here (approximately) the loading times (starting page page is google.at):

With Firefox 57.0.4 (the version I had installed before):
When starting Firefox outside of Sandboxie: 2-3 seconds
When starting inside Sandboxie: 3-4 seconds

With Firefox 57.0.4:
When starting Firefox outside of Sandboxie: 4-5 seconds
When starting inside Sandboxie: about 15 seconds (!)

So, especially when using Sandboxie (and I do this always) the delay is enormous.

Deactivating of my extensions did not help (anyway it is only NoScript and WX Download Status Bar). Frank Lion's above suggestions did not help too.

When downgrading to the previous Firefox version (57.0.4) all works fine again. So the delay must have to do with version 58.

My system: Windows 7, Home Premium, 32 bit.

Any further ideas, suggestions but also similar reports of other users would be welcome. Thanks in advance.

DanRaisch
Moderator

User avatar
 
Posts: 120281
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted January 29th, 2018, 9:11 pm

When downgrading to the previous Firefox version (57.0.4) all works fine again. So the delay must have to do with version 58.

Maybe but what security software, if any other than Sandboxie, are you running? Some security software can cause issues after an update to Firefox because it is not fully clearing the browser as the same program as the previous, authorized application.

Hönö
 
Posts: 43
Joined: June 24th, 2005, 3:56 am

Post Posted January 29th, 2018, 10:49 pm

Frank Lion wrote:Did you then go on to the second part of the test? -

Nope, that didn't do it either.

And a hint to others who want to try it: the quickest way to find the profile cache folder is to open up about:profiles (the instructions at https://support.mozilla.org/en-US/kb/pr ... -user-data direct you to the main folder).

Frank Lion

User avatar
 
Posts: 20063
Joined: April 23rd, 2004, 6:59 pm
Location: ... The Exorcist....United Kingdom

Post Posted January 30th, 2018, 5:38 am

Hönö wrote:
Frank Lion wrote:Did you then go on to the second part of the test? -

Nope, that didn't do it either.

Thanks, I'm working on something else and wanted to know if this was a related problem.
Metal Lion latest SeaMonkey & Thunderbird Themes - Sea Monkey and Silver Sea Monkey
"The only thing necessary for the triumph of evil, is for good men to do nothing." - Edmund Burke (attrib.)

Peter 123
 
Posts: 4
Joined: January 29th, 2018, 6:51 pm

Post Posted January 30th, 2018, 6:10 am

DanRaisch wrote:what security software, if any other than Sandboxie, are you running?

Only Microsoft Security Essentials and the Windows Firewall.

Peter 123
 
Posts: 4
Joined: January 29th, 2018, 6:51 pm

Post Posted January 30th, 2018, 3:44 pm

Hello,

I have good news for myself and I hope for all of you too who have the same problem with the delay in loading the starting page. :-)

Please try the following:

- Open Firefox and go to about:config
- Change the value for browser.tabs.remote.autostart from "true" to "false"
(There is also an entry "browser.tabs.remote.autostart.2". For this entry the value should already be "false" by default.)

The advice comes from some helpful guys in the Sandboxie Forum and originally refers to another problem: Some users (like me too) had no sound (e.g. at Youtube) when using Firefox 58.0.1 within Sandboxie.
The above measure solves both problems (the missing of sound and the delay in loading the starting page).

Here the link to the thread where the solution was posted orginally:
https://forums.sandboxie.com/phpBB3/vie ... 11&t=25364

And here my own thread where I mention it as solution for the problem with the delay:
https://forums.sandboxie.com/phpBB3/vie ... 11&t=25384

As in my case the extremely heavy delay within Sandboxie has vanished completely, it should work in other cases (= using Firefox without Sandboxie) too (I assume).

----------------

PS:
I have to add something:
With the above method unfortunately the problem is not resolved completely. Indeed the starting page loads without problem now but when changing from there to another website there is now (often? / always?) a remarkable delay - not when loading it (as far as I can say) but afterwards when you try to scroll on the website or to open a link etc. In these situations the browser freezes now for some seconds and only after this delay the action is performed. (I refer to the situation when using Firefox within Sandboxie. I did not test how the impacts are outside of the sandbox.)

Nevertheless, to my mind the situation is better than it was before and it seems that the new delay (short freezing) happens only one time and not later again while browsing.

Everyone should try out by himself if modifying the mentioned entry in about:config is helpful for him or not.

(Firefox is so annoying with its permanent technical changes. :x )

Hönö
 
Posts: 43
Joined: June 24th, 2005, 3:56 am

Post Posted January 31st, 2018, 12:39 am

Peter 123 wrote:Please try the following:

- Open Firefox and go to about:config
- Change the value for browser.tabs.remote.autostart from "true" to "false"
(There is also an entry "browser.tabs.remote.autostart.2". For this entry the value should already be "false" by default.)

I can see an improvement, not a full fix. I haven't clocked the load times, but my hunch is that this fix has at best only halved the extra delay.

In my case, the autostart.2 was also true, but I don't have a clue of why; I have not changed it via about:config, so I must have changed it either via the Settings or via some add-on, but cannot figure out which particular setting it is.

Hönö
 
Posts: 43
Joined: June 24th, 2005, 3:56 am

Post Posted January 31st, 2018, 1:01 am

Btw. the problem also concerns the live bookmarks (RSS feeds), but does not concern page loads if the page is on local hard drive.

So, it seems that it's all about network traffic. It also seems sometimes that this behaviour also disturbs other programs that try to access web content at the same time, but since I spend most of my time with FF, that happens so sporadically that I can't be 100% sure. In any case, the problem is clearly in FF58, as nothing else changed on the same day. Right now, the only thing I can think of trying next is switching between IPv4 and IPv6 in my router-modem.

Hönö
 
Posts: 43
Joined: June 24th, 2005, 3:56 am

Post Posted January 31st, 2018, 1:50 am

Instead of changing my router-modem settings, I decided to run IPV6 tests on the both machines: on Ubuntu, which does not have the FF slowness problem, and Win7, which does have it. The difference is huge.

In https://test-ipv6.com/ test, Ubuntu gives me figures that begin with "0.", except for IPv4 provider, for which the result begins with "1.". Windows gives results that begin with 2 or 3 or 4, except for IPV4 provider, which begins with "9.".

In http://ipv6-test.com/speedtest/, Ubuntu and Windows agree on IPv4 results, but disagree on IPv6 results; Win7 result is about half of the Ubuntu result (the main page http://ipv6-test.com does not reveal any difference).

Edit: I restored the two browser.tabs.remote.autostart values to the true value they had before, and ran the test on the Win7 machine again. This time, the IPv4 and IPv6 provider tests (at https://test-ipv6.com/) resulted in figures that begin with "0.", but the speed test (at http://ipv6-test.com/speedtest/) showed even bigger drop in speed. Then I ran the test again, and saw no drop in speed at all. Dumbfounded, I repeated the test for all different locations in the menu and got varying results, but most of the time, both IPv4 and IPv6 speeds seemed OK. Go figure. The https://test-ipv6.com/ page, though, still runs much faster on Ubuntu and shows significantly smaller numbers that on Win7.

oriongeradores
 
Posts: 2
Joined: January 31st, 2018, 3:08 am

Post Posted January 31st, 2018, 3:21 am

Last few years, Firefox has been regularly getting worse. Ever since the decision to remove "tab groups" Firefox has been on the drop. I'm reading promises of speed, but slowness is always I'm getting. :cry: Things have gotten so bad with the latest release that I just had to log in and ask what is going on? I read titles like "Firefox is faster than ever", but it has never been this slow. [-X It can barely keep 10 sites open at a time, while I used to have hundreds open. I've been very quiet as I really love Firefox addons. =D>

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 11 guests