[SOLVED] Firefox Quantum and ASUS website problem

User Help for Mozilla Firefox
Posts: 95
Joined: June 5th, 2007, 3:35 am

Post Posted January 29th, 2018, 8:09 am

When I went to ASUS webpage for my motherboard, clicked support, driver and utility and selected OS from dropdown menu, it doesn't open list of drivers below it. on IE it works. So there is something wrong with FF not displaying page properly.

When FF is in safe mode it works. When in normal mode, with all addons disabled, and prior to starting, userchrome and usercontent moved to another location, it still doesn't work.

Edit: Found what is the problem. When Tracking protection is set to always, problem occurs.
i7 2600K@4.2, NH-U12S, ASUS P8P67 Pro V.3.1, 16GB HyperX Gray@1600, MSI GTX1080 6GB GamingX, Samsung SSD Pro 256GB, WD 1TB;3TB, CM 690 II Advanced/Seasonic 850W KM3, SounBlaster ZX/Altec Lansing 121i/AKG K92, ASUS 24B3ST, Logitech M705 / K270, X360 wireless gamepad, LG 42LF652V, Win 7 x64 Pro


User avatar
Posts: 19298
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted January 29th, 2018, 10:20 am

(Just to note, same/similar conclusion here, Can't see or downlaod motherboard drivers from ASUS website.)
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support

Who is online

Users browsing this forum: No registered users and 12 guests