MozillaZine

Firefox 58 - Drop-downs are double spaced

User Help for Mozilla Firefox
leamphil
 
Posts: 64
Joined: February 18th, 2008, 12:03 pm

Post Posted February 9th, 2018, 1:39 pm

I just took the plunge and updated to Firefox Quantum - so went straight to Firefox 58 from a pre-Quantum FF (54?).

When I access a site with drop-downs I see them double spaced, ie. with blank lines between the values:
a

b

c

d

etc. rather than single spaced as below (which is what I see on other browsers, eg. Chrome, IE)
a
b
c
d

This happens if I use safe mode, happens if I use a new blank profile, and happens on multiple machines.

Is there a setting I am missing ? Or is it a feature of FF 58 ? Or is it a bug ?

TheVisitor
 
Posts: 4649
Joined: May 13th, 2012, 10:43 am

Post Posted February 9th, 2018, 2:38 pm

Link to site you have issues with.

leamphil
 
Posts: 64
Joined: February 18th, 2008, 12:03 pm

Post Posted February 9th, 2018, 2:44 pm

Site is my bank (https://www.halifax-online.co.uk/person ... /login.jsp), prompt for second-level password via dropdown, so unfortunately I cannot provide a link :-(

Other browsers, and FF pre-quantum, have single spaced drop-down.

Tony-E

User avatar
 
Posts: 8778
Joined: November 5th, 2004, 11:28 am

Post Posted February 9th, 2018, 4:37 pm

It's not just Firefox. I see it on that site on Firefox 59 beta and Chrome, but don't see it on MS Edge

leamphil
 
Posts: 64
Joined: February 18th, 2008, 12:03 pm

Post Posted February 10th, 2018, 12:50 am

I just used Chrome (Version 64.0.3282.140 (Official Build) (64-bit)) and it was OK for me.
Not OK on FF 58.0.2.

It also happens on Smile bank second stage of logon (https://bank.smile.co.uk).

leamphil
 
Posts: 64
Joined: February 18th, 2008, 12:03 pm

Post Posted February 10th, 2018, 3:34 am

Other web pages (eg. http://www.echoecho.com/htmlforms11.htm) also illustrate the problem.

In the "Butter / Cheese / Milk" example (under header Settings on the page above), on FF 58 the "Milk" option spans the bottom of the frame, on Chrome all the options are just about within the outer frame.

Drop-down items are wider spaced (in my bank examples it looks like there is a blank space between the alternatives) but there is no actual blank line between the options, it just looks that way.

TheVisitor
 
Posts: 4649
Joined: May 13th, 2012, 10:43 am

Post Posted February 10th, 2018, 6:02 am

Are your system Display settings set to 100% or have you changed it to get larger size ? Sometimes Firefox does not like system settings over 100%

leamphil
 
Posts: 64
Joined: February 18th, 2008, 12:03 pm

Post Posted February 10th, 2018, 7:21 am

Display settings are set to 100%.

Brummelchen
 
Posts: 3576
Joined: March 19th, 2005, 10:51 am

Post Posted February 10th, 2018, 7:46 am

58.0.2 - no space between butter and co. i need to check a clean profile. nope, same -> no issues.
must be your profile, maybe userchrome.

leamphil
 
Posts: 64
Joined: February 18th, 2008, 12:03 pm

Post Posted February 10th, 2018, 8:08 am

I've renamed userchrome and restarted FF - still have the problem.

I've created a new profile and restarted FF - still have the problem.

When you say that you don't see a problem with butter etc., where does the bottom of the drop-down come to ?
Where I am seeing a difference between FF and Chrome is that in FF the top of the last element (Milk) is level with the frame, in Chrome the bottom of the last element (Milk) is level with the frame.
This makes a huge difference when the drop-down is the letters A-Z & 0-9.

Brummelchen
 
Posts: 3576
Joined: March 19th, 2005, 10:51 am

Post Posted February 10th, 2018, 8:26 am

no space either, no issue with the upper drop down nor with the lower (at bottom) drop down.
do you have also here space?
https://silviomoreto.github.io/bootstra ... /examples/
(several examples, the first is unstyled/plain)

what about disabling hardware acceleration?

leamphil
 
Posts: 64
Joined: February 18th, 2008, 12:03 pm

Post Posted February 10th, 2018, 8:53 am

Yes I see spaces in your example - bottom of drop-down goes down to the faint box around the example.

No change when I disabled h/w acceleration in FF options.

ReggieNJ
 
Posts: 27
Joined: March 21st, 2016, 5:45 am

Post Posted February 10th, 2018, 9:49 am

I noticed this after the upgrade to 57, happens everywhere and makes the dropdown boxes gigantic. I figured it was just some new behavior related to Quantum.

https://i.imgur.com/kG8LZ5q.png

Brummelchen
 
Posts: 3576
Joined: March 19th, 2005, 10:51 am

Post Posted February 10th, 2018, 12:46 pm

thats no double space - thats margin (or padding) - depending on website style.

leamphil
 
Posts: 64
Joined: February 18th, 2008, 12:03 pm

Post Posted February 10th, 2018, 1:07 pm

Maybe it is "padding" -
- BUT:
(1) it changed when I upgraded to Firefox Quantum (58)
(2) web pages are is widely different when viewed with other browsers (eg. Chrome, IE)

The "padding" has not been changed by the webpage - what is seen has changed as a result of the Browser update.

See https://imgur.com/pSpzxiU for what it now looks like on FF 58,
and https://imgur.com/mwYNMJJ is what it looks like on Chrome.

It looks like a problem to me !

Is there a CSS option (like seems to be the solution for many other Quantum aspects) that will reduce/remove the padding ?
And will this work on secure (bank) sites ?

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 3 guests