MozillaZine

Odd problem with US Court site

User Help for Mozilla Firefox
Haircut
 
Posts: 37
Joined: April 12th, 2017, 2:57 pm

Post Posted March 31st, 2018, 11:11 am

For one reason or another, when I try to listen to any oral arguments on any US Appeals court site the mp3 will play for less then a minute before I get a "The connection was reset" page. This is consistent across three OSs-- Linux (home), Windows 7 and Windows 10 (both at work). It also happens on all three platforms when in safe mode. Chromium and Edge play the MP3s without an issue.

Any ideas?


http media.ca7.uscourts.gov/sound/external/dl.17-1582.17-1582_03_29_2018.mp3
Last edited by LIMPET235 on March 31st, 2018, 11:18 am, edited 1 time in total.
Reason: Killed the live link/s.

MarkRH

User avatar
 
Posts: 1282
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted March 31st, 2018, 12:39 pm

That's an odd site. I get the same connection reset message but in the console I see no errors or any type of server response codes. Hmmm

TheVisitor
 
Posts: 4990
Joined: May 13th, 2012, 10:43 am

Post Posted March 31st, 2018, 2:28 pm

I get the same on win10 latest Nightly build.

Haircut
 
Posts: 37
Joined: April 12th, 2017, 2:57 pm

Post Posted March 31st, 2018, 9:58 pm

Time to see if I can connect someone at support at uscourts.gov.

Limpet, it is a .gov site. Take deep breath.

atlanto
 
Posts: 93
Joined: March 7th, 2015, 4:19 pm
Location: Japan

Post Posted April 1st, 2018, 6:53 pm

This is a regression bug. Former versions don't have this problem.

Haircut
 
Posts: 37
Joined: April 12th, 2017, 2:57 pm

Post Posted April 1st, 2018, 7:11 pm

Can someone write a bug for it? Bugzilla does not like comcast IPNs from Seattle for one reason or another.

Actually, does not like my IPN. My computer has been shut off for a couple of week so I was likely assign a new number.

MarkRH

User avatar
 
Posts: 1282
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted April 1st, 2018, 8:50 pm

Still something's funky on the server's end. It plays MP3 files directly from my website just fine. I also got a connection was reset error in Google Chrome but it kept playing the file. Hmm..

Haircut
 
Posts: 37
Joined: April 12th, 2017, 2:57 pm

Post Posted April 1st, 2018, 10:16 pm

I am assuming that your web site simply provided a link? Did you get an connection reset error page in Chrome or was it something you saw in the logs?

morat
 
Posts: 3438
Joined: February 3rd, 2009, 6:29 pm

Post Posted April 1st, 2018, 11:47 pm

Haircut wrote:Can someone write a bug for it?

The connection was reset for partial content (hat tip atlanto)
http://bugzilla.mozilla.org/show_bug.cgi?id=1450607

I get the following error page in Firefox 59. The file stops playing.

about:neterror?e=netReset&d=The connection to the server was reset while the page was loading.

I get the following error in the console in Chrome 65. The file continues playing after the error.

Failed to load resource: net::ERR_CONNECTION_RESET

Brummelchen
 
Posts: 4599
Joined: March 19th, 2005, 10:51 am

Post Posted April 2nd, 2018, 4:13 am

no stop here on windows 8, 19 minutes with no break.

Grumpus

User avatar
 
Posts: 12228
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted April 2nd, 2018, 6:05 am

Connection reset just before midway point on scale.
Moving slider to end of what has been loaded causes rest of what has loaded to appear but break still occurs.
Total time shows as more than 32 minutes in length.
Cashless society sacrifices independence, privacy and lastly liberty, encouraged by ignorance and villainy.

MarkRH

User avatar
 
Posts: 1282
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted April 2nd, 2018, 1:49 pm

Haircut wrote:I am assuming that your web site simply provided a link? Did you get an connection reset error page in Chrome or was it something you saw in the logs?


The links are down at the bottom here: https://www.companyofvalor.org/library.shtml#downloads

Granted, they aren't 30 minutes long. In Chrome, I saw the error in the Developer Tools Console. I did not get an actual page with the error. I'll probably upload a really long MP3 somewhere to test with.

Well, a 30 minute MP3 seems fine on my site. I can see it requesting more and more bits of the file. I stuck it here: https://www.markheadrick.com/entertainment.shtml#radio It's the "Rava - A Mentally Remixed Thank You" link.

Haircut
 
Posts: 37
Joined: April 12th, 2017, 2:57 pm

Post Posted April 2nd, 2018, 10:22 pm

Thanks folks.

Haircut
 
Posts: 37
Joined: April 12th, 2017, 2:57 pm

Post Posted April 22nd, 2018, 3:37 pm

One more item. There is one US Court site that still works http://www.ca11.uscourts.gov/oral-argument-recordings . All the rest still are broken.

therube

User avatar
 
Posts: 20046
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted April 23rd, 2018, 10:08 am

No reason for anything to have changed - on the FF end (as the Bug report shows no progress).
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 9 guests