MozillaZine

"Your connection is not secure" again & again

User Help for Mozilla Firefox
Al_H
 
Posts: 329
Joined: November 6th, 2006, 5:39 am

Post Posted April 15th, 2018, 1:33 pm

Hi,
I have a W10 fully updated, AVG antivirus, fully updated
For the last two weeks I have been getting this old error again & again:"Your connection is not secure"

As I did in the past, I have been solving it temporarily (going to my profile and deleting cert8.db and cert9.db, restarting the PC)

Still it is a nuisance since I need to restart my PC every time this happens and it is a waste of time
Any idea of what to do?

makaiguy

User avatar
 
Posts: 16648
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted April 15th, 2018, 1:56 pm

If this only happens when going to http (as opposed to https) sites, see if this helps:

Starting with Ver 52, FFox pops up a warning when attempting to log into sites not accessed via a secure connection (i.e. those using non-secured http protocol instead of secured https protocol). The warning correctly points out that your login name and password are being transmitted in the clear where they can be captured by any server along the way.

This does not mean that the site you are trying to log in to has suddenly become insecure. This situation has always been there, but the folks at Mozilla just decided they'd warn you about it.

To avoid the warning:
  1. If the site supports a secure https connection, use that instead of http. Your transmission will be encrypted and only readable by your destination site.

  2. If you just don't want FFox to warn you of these insecure connections, do this:
    • Enter about:config in the Address/URL bar.
    • Press the button to agree to be careful (if you haven't done this previously).
    • Enter insecure in the Filter bar to limit display to just options containing 'insecure'.
    • Double-click on each of the following two options to toggle them between true and false. Set them to false:
        security.insecure_field_warning.contextual.enabled
        security.insecure_password.ui.enabled
    • Enter autofill in the Search bar.
    • Double-click on signon.autofillForms.http and toggle it to true.
    NOTE: if any of the above options are not found, you can create them manually. Right-click (control-click on Apple) an empty space in the option list. Click New | Boolean. Enter the option name and appropriate true/false value.
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.9.0 ESR (64bit), TB 52.9.1(32bit) ║ Android 8.0/7.1.1: FF 62.0.1 No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

Brummelchen
 
Posts: 3801
Joined: March 19th, 2005, 10:51 am

Post Posted April 15th, 2018, 2:04 pm

Disable ssl (httpS) scanning in AVG

Al_H
 
Posts: 329
Joined: November 6th, 2006, 5:39 am

Post Posted April 16th, 2018, 1:11 pm

Thanks to both.
I will start disabling https scanning in AVG and proceed from there.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 14 guests