MozillaZine

Please confirm your identity? WHY? (Linux)

User Help for Mozilla Firefox
GudgeonPin

User avatar
 
Posts: 409
Joined: March 8th, 2008, 4:10 pm

Post Posted August 15th, 2018, 11:27 am

Hi,

When I hover the mouse or right-click the FFx icon in the Launcher (Ubuntu 16.04, FFx 61.0.2) I get "Please confirm your identity."

What's that all about? It overrides the Ubuntu Launcher options for "Open new window" etc.

This seems to be something from only a few days back after an upgrade.

Hovering over the icon
Image

Right-click the icon
https://i.imgur.com/iDSVNqf.jpg
Last edited by Daifne on August 16th, 2018, 7:07 am, edited 3 times in total.
Reason: removed img tags. Size of image breaking forum format.
Cary G.

Grumpus

User avatar
 
Posts: 12015
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 15th, 2018, 12:51 pm

Open about:config and type in captive.
There is a grab for the portal which may be the issue causing the "Please confirm your identity"
There are a number of item which can be blanked or toggled to false.
It should say Firefox Web Browser; Browse the Worldwide Web

GudgeonPin

User avatar
 
Posts: 409
Joined: March 8th, 2008, 4:10 pm

Post Posted August 15th, 2018, 3:39 pm

Grumpus wrote:Open about:config and type in captive.


Here's what I have as the only toggle-option, it was True and I set it to False
network.captive-portal-service.enabled

I then zeroed out everything else there. Shut down FFx and rebooted. The attached images are what I got **after** that.
Cary G.

Grumpus

User avatar
 
Posts: 12015
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 16th, 2018, 5:21 am

I haven't got a clue why this is different and can only guess it's some form of security interference from an add-on or maybe a VPN or proxy setup.
Look at /edit/preferences/general and see if the network proxy settings call for a password?
Are you sure you updated Firefox from the main Ubuntu repository and not some other repo which was added to the list of sources?
I have two other OSs running 16.04 derivatives, 18.2 mint and 18.3 Mint and do not see this.

GudgeonPin

User avatar
 
Posts: 409
Joined: March 8th, 2008, 4:10 pm

Post Posted August 16th, 2018, 8:28 am

Thanks, but no proxy etc. Just the stock Ubuntu and FFx. It is the FFx version that was installed with 16.04 and updated and upgraded regularly by the Ubuntu Update Manager.

As mentioned above I tried disabling all add-ons but same. The thing that tends to key it to FFx is the "Mozilla Firefox" at the end of both the hover and right click menus.

I rolled back to an image backup with FFx v58 and it is good. Seems like some "feature" with 61.

Maybe someone should look into FFx calling home in secret.
Cary G.

Grumpus

User avatar
 
Posts: 12015
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 16th, 2018, 9:47 am

This is not normal for the stock Ubuntu and Firefox. There has to be something else affecting this.
Just because it says Mozilla Firefox doesn't mean it's something from the stock package.
If you start in Safe Mode does it still appear? hit in the menu /Help/Restart with add-ons disabled or type in about:profiles for the same restart.
As far as calling home, aside fro the features in Preferences you can open about:config and type "http" to see what is calling home.
You also may try the word "search" for the various Mozilla and Google protections.

elist74
 
Posts: 94
Joined: June 27th, 2013, 11:27 am

Post Posted August 17th, 2018, 3:09 pm

Hi!, Check in the edits options "properties" (right click) on the firefox logo if there having "please confirm your identity" in "name" or "comment".

Grumpus

User avatar
 
Posts: 12015
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 20th, 2018, 7:46 am

@elist74 - it's always the simple things, prank or misguided systems manager?
Wonder if it's that simple or maybe an extension changes it?

elist74
 
Posts: 94
Joined: June 27th, 2013, 11:27 am

Post Posted August 20th, 2018, 7:58 am

Just a question GudgeonPin , when you upgrade did firefox was recently on a login or confirmation page?
Maybe the shortcut launcher was mess up.
Also maybe your firefox start page (or home page) is on a login page.

BTW "Please confirm your identity" seems to be a facebook thing.

elist74
 
Posts: 94
Joined: June 27th, 2013, 11:27 am

Post Posted August 20th, 2018, 7:42 pm

Grumpus wrote:@elist74 - it's always the simple things, prank or misguided systems manager?
Wonder if it's that simple or maybe an extension changes it?


(For me) I prefer simples solutions (especially with linux i'm not so familiar with it) ;-)

Grumpus

User avatar
 
Posts: 12015
Joined: October 19th, 2007, 4:23 am
Location: ... Da' Swamp

Post Posted August 21st, 2018, 4:53 am

@elist74 - It's like the more you know the less you help sometimes, like a tilting dummy, simple becomes overlooked and difficult becomes simple.
Imagine having access to computers in an office and setting up a startup program or macro that changes the Firefox icons text to comments?
Someone needs to work on this it could be great for moral, productivity, screwing with someone's head. ;)

elist74
 
Posts: 94
Joined: June 27th, 2013, 11:27 am

Post Posted August 21st, 2018, 5:36 am

Grumpus wrote:@elist74 - It's like the more you know the less you help sometimes, like a tilting dummy, simple becomes overlooked and difficult becomes simple.
Imagine having access to computers in an office and setting up a startup program or macro that changes the Firefox icons text to comments?
Someone needs to work on this it could be great for moral, productivity, screwing with someone's head. ;)


Very true :-)

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 16 guests