MozillaZine

Opening Links on web pages sometimes a problem not opening

User Help for Mozilla Firefox
Energise

User avatar
 
Posts: 285
Joined: January 4th, 2008, 3:11 pm
Location: Suffolk, UK

Post Posted August 23rd, 2018, 4:35 pm

Windows 10 Firefox 61.0.2

For some reason, I've recently started to have problems opening links to both pdf and to web sites when using Firefox, which is my favoured browser. Each time the page isn't going to open, I get a blank page with the tab indicating the page is loading and the 'thingy' going round and round on the page.

I tend to right click on a link and select to open in a new tab but the same will happen if I just left click the link.

In order to open the link, I have found that if I copy the web address (ie from the address bar), open IE or Edge, paste into the address bar and the page will open.

This seems to be happening more frequently. Has anyone any idea as to why this is happening and what I can do to 'fix' it, please?

Many thanks for all help and advice

DanRaisch
Moderator

User avatar
 
Posts: 120268
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 23rd, 2018, 6:09 pm

Try menu path Tools->Options->Privacy and Security->Click on the "Clear Data" button->select "Cached data" and click on the "Clear" button.

Energise

User avatar
 
Posts: 285
Joined: January 4th, 2008, 3:11 pm
Location: Suffolk, UK

Post Posted August 24th, 2018, 4:00 am

DanRaisch wrote:Try menu path Tools->Options->Privacy and Security->Click on the "Clear Data" button->select "Cached data" and click on the "Clear" button.

Many thanks
Fortunately I realised I'd need to know the 'log in's after doing this - use KeePass ;)
Only time will tell if this has made a difference. I'll need to check back to find where it was I couldn't open the link etc before I'll know
Again, many thanks

DanRaisch
Moderator

User avatar
 
Posts: 120268
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 24th, 2018, 4:05 am

You're welcome.

Energise

User avatar
 
Posts: 285
Joined: January 4th, 2008, 3:11 pm
Location: Suffolk, UK

Post Posted August 24th, 2018, 4:09 am

Oops!!!

Just tried one of the links to a pdf page and it doesn't open, ie same as yesterday. It opened fine in Edge, though.
I've just got a white page, with the 'busy' sign, taking an age.
I've just tried it in IE this time and it opens immediately ...

What else could you suggest, please?

Thanks

DanRaisch
Moderator

User avatar
 
Posts: 120268
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 24th, 2018, 4:29 am

What is the URL?

Energise

User avatar
 
Posts: 285
Joined: January 4th, 2008, 3:11 pm
Location: Suffolk, UK

Post Posted August 24th, 2018, 8:09 am

DanRaisch wrote:What is the URL?

Thanks

This is one of the pages that won't open but will open immediately in Edge and IE -
https://www.england.nhs.uk/commissionin ... _FINAL.pdf

There were some more but I can't find them just now. I've just looked in 'History' but it's hard to identify them

DanRaisch
Moderator

User avatar
 
Posts: 120268
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted August 24th, 2018, 8:24 am

That site opens immediately here.

Try menu path Tools->Options->Privacy and Security->Click on the "Manage Data" button->select any and all entries in the list of cookies that refer to England.nhs.uk or nhs.uk and click on the "Remove selected" button.

If no improvement after that:
Have you tried starting Firefox in Mozilla Safe Mode? http://kb.mozillazine.org/Safe_mode
If no improvement using Safe Mode, do you have the same problem if you create a new profile and test it with no extensions or non-default themes installed?
http://kb.mozillazine.org/Profile_Manager
and
http://kb.mozillazine.org/Creating_a_ne ... on_Windows

Energise

User avatar
 
Posts: 285
Joined: January 4th, 2008, 3:11 pm
Location: Suffolk, UK

Post Posted September 3rd, 2018, 12:36 pm

Hi DanRaisch

Apologies for leaving you in the lurch. I had some other stuff needing my attention which 'took over' my life a bit, so this issue just had to be put to one side.

I've had further issues with opening pdf links so I'll be trying your suggestions but also will make a note of the url when it happens. I think it's web addresses other than nhs but I'll keep an eye on that.

I'll come back with an update once I've worked through your suggestions.

Many thanks

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 9 guests