MozillaZine

new tab switch immediately uncheck - still switches

User Help for Mozilla Firefox
need_sleep
 
Posts: 9
Joined: August 11th, 2014, 11:35 am

Post Posted August 31st, 2018, 10:30 am

tools/options/general/
checkbox : When you open a link in a new tab, switch to it immediately
Mine is unchecked.

I'm on current Firefox version: 61.0.2
Doesn't work :cry:

dfoulkes

User avatar
 
Posts: 22325
Joined: June 28th, 2008, 10:31 pm
Location: Mesquite, Nevada

Post Posted September 1st, 2018, 9:37 am

I just checked that out in my portable version of Firefox... using this Mozillazine support section I just right-clicked on a subject and opened it in a new tab... and it did not focus on that new tab... then I made the same change in Options that you pointed out and tried it again... it did switch to the new tab as it should... then I changed in back in Option and it did not switch... so, it seems that my portable version acts as advertised..

I suggest that you restart Firefox in safe-mode and give your option setting a test...

Try running Firefox in safe-mode... NOTE: This is a testing procedure only ... NOT for normal browsing.
-- On the menu bar, click the Help menu and select Restart with Add-ons Disabled....
Firefox will start up with the Firefox Safe Mode dialog. Click continue in Safe Mode and don't check any items.

Note: You can also start Firefox in Safe Mode by holding down the shift key while Single/Double clicking on the icon.
* (option key while starting Firefox on Mac).

-----------------------------------------------------------------------------------------
>What safe-mode does ..... Safe Mode temporarily affects the following:
* All extensions are disabled. --- * The userChrome.css and userContent.css files are ignored.
* The default theme is used, without a persona. --- * The default toolbar layout is used.
* The Just-in-time (JIT) JavaScript compiler is disabled. --- * Hardware acceleration is disabled.

-- Safe Mode has no effect on the following --
* The status of plugins is not affected.
* Custom preferences are not affected.

This is the link to the main KB article for Safe-Mode ... but, use the above info 1st...
Safe Mode - MozillaZine Knowledge Base
As you can see she's (The CAT) always alert and on the prowl for Meoware !!

therube

User avatar
 
Posts: 19161
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted September 1st, 2018, 9:40 am

Does this happen everywhere or only with some links?
Link where this happens?
How are you opening the link?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

jscher2000

User avatar
 
Posts: 10292
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted September 7th, 2018, 5:19 pm

need_sleep wrote:tools/options/general/
checkbox : When you open a link in a new tab, switch to it immediately
Mine is unchecked.


There are two preferences, but the checkbox only covers one:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste inback and pause while the list is filtered

(3) If the browser.tabs.loadInBackground preference is bolded and "modified" to false, double-click it to restore the default value of true -- this handles links you directed to a new tab that otherwise would have opened in the same tab; this is what the checkbox toggles

(4) Double-click the browser.tabs.loadDivertedInBackground preference to switch the value from false to true -- this handles links the site directed to a new window that Firefox diverted to a new tab instead

Does that cover it?

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 10 guests