MozillaZine

Can I update my 52.9.0 esr to version 60 esr on my Vista ?

User Help for Mozilla Firefox
skuddle
 
Posts: 61
Joined: September 8th, 2012, 9:46 am

Post Posted September 11th, 2018, 11:09 am

Brummelchen wrote:never would come back. if you need descriptions go using firefox 60 esr.


Can I update my version 52.9 to version 60 esr on my Windows Vista computer? I guess I'm not sure what "esr" means.

Thank you in advance.
Last edited by James on September 11th, 2018, 7:57 pm, edited 1 time in total.
Reason: splitted off from http://forums.mozillazine.org/viewtopic.php?f=38&t=3041537

skuddle
 
Posts: 61
Joined: September 8th, 2012, 9:46 am

Post Posted September 11th, 2018, 11:12 am

Brummelchen wrote:never would come back. if you need descriptions go using firefox 60 esr.


Can I update my version 52.9 to version 60 esr on my Windows Vista computer? I guess I'm not sure what "esr" means.

Thank you in advance.

jscher2000

User avatar
 
Posts: 10223
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted September 11th, 2018, 5:29 pm

skuddle wrote:
Brummelchen wrote:never would come back. if you need descriptions go using firefox 60 esr.


Can I update my version 52.9 to version 60 esr on my Windows Vista computer? I guess I'm not sure what "esr" means.

Thank you in advance.

No, 52.9.0 is the last version for Windows Vista.

ESR:

* https://www.mozilla.org/firefox/organizations/faq/
* https://support.mozilla.org/kb/end-support-windows-xp-and-vista
Last edited by jscher2000 on September 12th, 2018, 9:51 pm, edited 1 time in total.

James
Moderator

User avatar
 
Posts: 27407
Joined: June 18th, 2003, 3:07 pm
Location: Made in Canada

Post Posted September 11th, 2018, 8:01 pm

Firefox 53.0 and later requires Windows, 7, 8 (8.1), 10 to run.

Only other option to be able to use current Firefox versions is perhaps installing or dual booting with a Linux distro with a lighter desktop options like XFCE and not the heavier Gnome 3 or KDE.

If your Vista PC is using a old 32-bit CPU then your options are more limited, though there are still some Linux distros that still support 32-bit like Lubuntu and Xubuntu among other light options.

skuddle
 
Posts: 61
Joined: September 8th, 2012, 9:46 am

Post Posted September 13th, 2018, 8:58 am

Ok, then version 52.9 it is!!

Brummelchen
 
Posts: 3790
Joined: March 19th, 2005, 10:51 am

Post Posted September 13th, 2018, 9:38 am

thats double pity - outdated windows and outdated browser. there is nothing we can do except you upgrade to windows 7 or higher, if you can collect all drivers for your machine!

frg
 
Posts: 626
Joined: December 15th, 2015, 1:20 pm

Post Posted September 16th, 2018, 4:15 am

The funny thing is you can still update Vista manually with the latest Server 2008 fixes using them from a wsusoffline download. Works still fine and if MS does not close that hole supported till 2020.

Don't really use Vista any longer but needed to test the latest SeaMonkey security backports from ESR60. Don't want to break XP and Vista in 2.49 until 2.57 is released.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 12 guests