MozillaZine

Autoscroll trackball feature stopped working on some sites

User Help for Mozilla Firefox
FirreFoxx
 
Posts: 4
Joined: July 20th, 2016, 4:23 pm

Post Posted October 9th, 2018, 2:37 pm

FF Quantum 62.0.3 (64-bit) on Windows 10 Pro, all perpetually up-to-date.

I have been using a Logitech trackball mouse with up-to-date Logitech SetPoint drivers for years now without issue. By clicking a certain button, it will enable auto-scrolling and I can scroll the page at various adjustable speeds until I click it again to stop or it reaches the bottom of the page. A recent coding change on a stock information and message board website (http://www.stockhouse.com) has seemingly disabled the ability to auto-scroll with my trackball. It continues to work as normal on most all other websites I visit but infrequently I'll end up on another website where it also does not work.

Following a tip from this SeaMonkey board (viewtopic.php?f=3&t=70390) I disabled Javascript in FF configuration and what do you know, scrolling works again... However, this is not a viable solution because the site's ticker quotes and other analysis features use Javascript and now I can't see price quotes or stock charts, one of those, "the cure is worse than the disease" kind of things.

Does anyone know if there might be a particular Javascript setting that would alleviate the scrolling issue but also keep the site's other Javascript-based features operational?

therube

User avatar
 
Posts: 19242
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted October 10th, 2018, 12:41 pm

stockhouse.com itself is doing the blocking on you.

Perhaps uBlock, or similar, can block particular scripts on the page that are doing the actual blocking of auto-scroll?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

FirreFoxx
 
Posts: 4
Joined: July 20th, 2016, 4:23 pm

Post Posted October 10th, 2018, 2:46 pm

Thanks for the reply. If it is StockHouse doing the blocking how do you account for the fact that scrolling works when I completely disable Javascript?

-EDIT-

I think I figured out the answer to my own question... by completely disabling Javascript, I am also preventing the StockHouse scripts from running, so that makes sense now.

Following another tip, I just tried the "press Esc" trick while the page was loading to stop scripts from running and scrolling worked normally. But again, by preventing their scripts, I can't see price quotes and stock charts. ](*,)

Not sure if going the uBlock route would help since I already use AdBlock and have tried disabling the blocks I have in place on the site, but that doesn't alleviate the scrolling issue, which means AdBlock isn't blocking the offending script. I'd hate to switch ad-blockers just to find out uBlock also doesn't work.

I'll try to focus in on the culprit using NoScript or similar add-on.

Wiggam72
 
Posts: 293
Joined: July 30th, 2013, 9:05 am

Post Posted October 10th, 2018, 9:23 pm

Please post the link to the site that's giving you the problem. I used to own a Logitech trackball and I still have a Logitech keyboard. It has 3 magnify buttons and for several years now, the button that is supposed to make a page jump back to the default size doesn't work. I'm not sure if it's a hardware or software problem. It might not work, but try updating Setpoint to the latest version.

FirreFoxx
 
Posts: 4
Joined: July 20th, 2016, 4:23 pm

Post Posted October 10th, 2018, 10:57 pm

Try actually reading my original post. All your questions answered...

Wiggam72
 
Posts: 293
Joined: July 30th, 2013, 9:05 am

Post Posted October 11th, 2018, 9:43 am

When I read that you have an up to date version installed, it made me wonder if it included the very recent one. I had what I thought was an up to date version installed as you said for years on my Windows 7 PC. Then I got a new Windows 10 and a few weeks ago when I installed Setpoint, it installed a new version that was numerically much higher than the one that I had installed for years.

So I deduced that it's possible that Setpoint has a glitch in that was not detecting new updates and you could have the same problem. What version does your say?

therube

User avatar
 
Posts: 19242
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted October 11th, 2018, 12:38 pm

Regardless of the mouse, setpoint software or whatnot, it is the site.
Visit & try.

BTW, you might drop an email to the webmaster & see what they say.
Might not be aware of the issue.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

FirreFoxx
 
Posts: 4
Joined: July 20th, 2016, 4:23 pm

Post Posted October 12th, 2018, 6:01 pm

Yes, it definitely is the StockHouse.com scripts.

I installed NoScript and tried turning off and on all the different scripts they use on the site and found the culprit. Of course, it's the one I can't do without, the script which displays price quotes and stock charts originating at: http://quotespeed.morningstar.com

When that script is disabled, i.e., set to Untrusted, scrolling works as normal. When enabled, scrolling doesn't work.

:roll:

I will try writing their webmaster but I doubt they will care, to be candid. This site is constantly tweaking the website and they have been on a downward trend of cluttering it up and making it just worse and worse... everyone that frequents the message boards I am a part of hates the site, but it's really the only game in town when it comes to Canadian securities message boards, so we are stuck with it.

The only way I can even tolerate all the junk on the pages is to use AdBlock. And again, all my AdBlock filters have been on for over a year and scrolling was fine until they started using this new Morningstar quote system recently.

The scrolling issue with the Morningstar script happens irrespective of whether AdBlock is on or off.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot] and 12 guests