MozillaZine

Bookmark toolbar icons keep corrupting

User Help for Mozilla Firefox
Exiled_077
 
Posts: 7
Joined: November 13th, 2017, 4:34 pm

Post Posted October 25th, 2018, 8:42 pm

Okay, it seems as though it was a temporary fix as the problem is back.

lasardo
 
Posts: 106
Joined: September 9th, 2018, 1:41 pm

Post Posted October 25th, 2018, 9:12 pm

According to here https://www.reddit.com/r/firefox/commen ... nd_i_cant/ the reddit enhancement suite could cause them to be replaced with reddit icons.
I glanced at bugzilla and did not see losing favicons shown. What antivirus and extensions do you have?

Exiled_077
 
Posts: 7
Joined: November 13th, 2017, 4:34 pm

Post Posted October 26th, 2018, 10:29 pm

Creating a new profile seems to have fixed my problem for good this time, I'm guessing that what Firefox updated to v63 it somehow corrupted my profile or something I'm not really sure.....anyway a new profile sorted the issue right out.

tomatoshadow2

User avatar
 
Posts: 355
Joined: May 11th, 2017, 9:52 am

Post Posted October 31st, 2018, 2:21 am

@Exiled_077 Could also have been a possible bad extension.

Exiled_077
 
Posts: 7
Joined: November 13th, 2017, 4:34 pm

Post Posted November 3rd, 2018, 4:02 pm

It actually started happening again even after creating a new profile, but I've managed to fix it again for good (this time for real). I managed to pinpoint the problem to Firefox Account Sync, every time Firefox performed a sync (which I believe is periodically) it would remove the site icons on the bookmarks that the issue was happening with but other bookmark icons would remain untouched. What I did was change the URL of all the bookmarks that it was happening to then performed a manual sync, then changed them back again and did again manual sync, and now everything seems to be working properly.

bender01
 
Posts: 8
Joined: August 12th, 2015, 7:49 am

Post Posted November 7th, 2018, 2:16 am

Bookmarks favicons keep disappearing, they become the default globe and I need to load the site to make the favicon come back. It started since the last 10-15 days. It happens with the same few bookmarks.

Moving places.sqlite and favicons.sqlite only worked for 2-3 days then the issue came back.

Exiled_077 wrote:I managed to pinpoint the problem to Firefox Account Sync

What if I don't use a Firefox account? How do you do a manual sync?

DanRaisch
Moderator

User avatar
 
Posts: 120445
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 7th, 2018, 4:45 am

More info needed to answer that question. How many computers would you be synching? What would you intend to synch? Just bookmarks or also history, passwords, etc?

bender01
 
Posts: 8
Joined: August 12th, 2015, 7:49 am

Post Posted November 7th, 2018, 5:51 am

But I don't use the Synch. That's why I was asking: how can I do the solution indicated by Exiled_077 if I don't use the Synch or the Firefox account?

DanRaisch
Moderator

User avatar
 
Posts: 120445
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted November 7th, 2018, 7:06 am

The questions would remain the same.

bender01
 
Posts: 8
Joined: August 12th, 2015, 7:49 am

Post Posted November 7th, 2018, 7:31 am

I don't use the Sync so it's just one computer. And I don't know about the rest, I only know that Exiled_077 talked about doing a manual sync, but I assume it's just for the bookmarks.

Maybe his fix won't do for me since I never used the Sync.

jscher2000

User avatar
 
Posts: 10292
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted November 7th, 2018, 9:06 am

bender01 wrote:I don't use the Sync so it's just one computer. And I don't know about the rest, I only know that Exiled_077 talked about doing a manual sync, but I assume it's just for the bookmarks.

Maybe his fix won't do for me since I never used the Sync.

Sync caused the problem in that case, so a hacky workaround related to Sync was used in that case. Please check all the other suggestions in the thread.

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 8 guests