MozillaZine

Can't Stop Autoplay

User Help for Mozilla Firefox
swillson
 
Posts: 7
Joined: September 16th, 2004, 4:51 pm

Post Posted October 26th, 2018, 2:57 pm

Firefox recently upgraded itself to version 63.0. Now videos play automatically (e.g., cbsnews.com).

No matter what I do, I can't get it to stop. Under Add-ons, I have Shockwave disabled. I also have Widevine disabled. The only other Add-on I have is OpenH264 Video Codec.

I went to (but did not change) about:config, looked up media.autoplay. Under media.autoplay.enabled it says "false".

Any suggestions?

Brummelchen
 
Posts: 4345
Joined: March 19th, 2005, 10:51 am

Post Posted October 26th, 2018, 3:51 pm

media.autoplay.enabled

revert to default pls - this pref has a bad influence.

try
https://addons.mozilla.org/firefox/addo ... 2017.12.20

i suggest in special the previous build because comments said that current build is somehow broken.

MarkRH

User avatar
 
Posts: 1282
Joined: September 12th, 2007, 2:30 am
Location: Oklahoma City, OK

Post Posted October 26th, 2018, 4:02 pm

Might read: https://www.ghacks.net/2018/09/21/firef ... -blocking/

Going to about:config and setting media.autoplay.default to 1 and setting media.autoplay.allow-muted to false will block autoplay everywhere. Same as using the now removed media.autoplay.enabled option.

Looks like there's not quite a UI front-end for this in 63 yet.

Brummelchen
 
Posts: 4345
Joined: March 19th, 2005, 10:51 am

Post Posted October 27th, 2018, 1:58 am

thats what i read some days ago
media.autoplay.default -> 2 for each site
media.autoplay.default -> 1 any site

media.autoplay.enabled.user-gestures-needed -> true for an (experimental) settings dialog

according to Sören Hentzschel media.autoplay.enabled is deprecated and no longer available
users using outdated and vulnerable software probably never will get an answer from me - sticked with the past? stay alone.

jscher2000

User avatar
 
Posts: 10628
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted October 27th, 2018, 2:19 pm

The old media.autoplay.enabled preference has been replaced by several new ones as the feature is evolving from "all or nothing" to a site permission. Give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

* Double-click the media.autoplay.default preference and set it to 1

=> Does that work for you?

Allow autoplay by default (default for Release)

* Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

Ask on a site-by-site basis (default for "Nightly")

* Double-click the media.autoplay.default preference and set it to 2
* Double-click the media.autoplay.ask-permission preference to switch the value from false to true
* Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.

Brummelchen
 
Posts: 4345
Joined: March 19th, 2005, 10:51 am

Post Posted October 28th, 2018, 2:16 am

firefox 63 only has a simple checkbox, firefox 65 additonal offers a choice /seperate/all/never/ (and moved this dialog below, while 63 is upper)

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 17 guests