MozillaZine

FF 63.0.1 Automatically Playing Videos Contrary To Settings

User Help for Mozilla Firefox
thechamlin
 
Posts: 233
Joined: June 13th, 2005, 8:47 pm

Post Posted November 8th, 2018, 3:56 pm

Example: www.cbsnews.com Prior to v 63, I used to open it and the video would wait for me to select it to play. Now...it just runs.

How to I troubleshoot this?

Thanks,
Chamlin

jscher2000

User avatar
 
Posts: 10292
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted November 8th, 2018, 6:31 pm

Hi Chamlin, the autoplay-related preferences were revamped in Firefox 63. Did you already find a thread on that? If not:

The old media.autoplay.enabled preference has been replaced by several new ones as the feature is evolving from "all or nothing" to a site permission. Give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

To set your preferred behavior:

Block autoplay by default

* Double-click the media.autoplay.default preference and set it to 1
* Some people suggest you also: Double-click the media.autoplay.allow-muted preference to switch the value from true to false

=> Does that work for you?

Allow autoplay by default (default for Release)

* Double-click the media.autoplay.default preference and set it to 0 (or right-click > Reset)

Ask on a site-by-site basis (default for "Nightly")

* Double-click the media.autoplay.default preference and set it to 2
* Double-click the media.autoplay.ask-permission preference to switch the value from false to true
* Double-click the media.autoplay.enabled.user-gestures-needed preference to switch the value from false to true

I'm sure we'll learn more about the interaction of these various preference and what sites can bypass them as more users begin to run Firefox 63.

thechamlin
 
Posts: 233
Joined: June 13th, 2005, 8:47 pm

Post Posted November 8th, 2018, 9:02 pm

Ahhhh. Thank you sooooooooooo much. Perfect. Balance is restored to my universe!

Return to Firefox Support


Who is online

Users browsing this forum: Bing [Bot] and 11 guests