MozillaZine

Firefox and Hotmail login error

User Help for Mozilla Firefox
teh roxxors
 
Posts: 66
Joined: August 5th, 2004, 11:35 am

Post Posted December 1st, 2018, 7:17 pm

Something went wrong.

We can't get that information right now. Please try again later.


Once that message appears during login with Firefox, the browser can no longer be used to login to Hotmail (or whatever they're calling it this year).

This happened a month or two ago, and I think I fixed it by doing a refresh on the browser, which meant losing all my add-ons, NoScript settings, and so on. Really, a PITA of a fix. And, yes, I can access Hotmail via another browser, but I'd like to use Firefox. I don't want to refesh the browser every couple of weeks.

I can access Hotmail/Outlook with Firefox in safe mode, which I believe means that one of my add-ons is causing the issue. I only have three, so it's probably No-Script (the other two are video downloaders).

Any very smart person out there know why this happens and how to prevent it?

Thank you.

DanRaisch
Moderator

User avatar
 
Posts: 123693
Joined: September 23rd, 2004, 8:57 pm
Location: Somewhere on the right coast

Post Posted December 2nd, 2018, 5:12 am

Have you confirmed that you are using the latest version of NoScript?
Have you tried running Firefox in standard mode with just NoScript disabled?

LIMPET235
Moderator

User avatar
 
Posts: 39259
Joined: October 19th, 2007, 1:53 am
Location: The South Coast of N.S.W. Oz.

Post Posted December 2nd, 2018, 5:46 am

Hi teh roxxors,
If you find that it is No Script that is causing the error, (&....I suspect it is), then make sure that you use the latest version, as noted by Dan
& open No Script (Left click the icon/button) & set all your Hotmail page links to "Trusted"...

No Script is very "selective" with it's default settings.
You may have to set each site you visit this (^) way.

I had to do this with a few of my sites that were not loading correctly or at all.
Keep an eye out for any red indicator on the icon/button.
Ancient Amateur Astronomer
Win-7-HP/IntelĀ® DualCore-2.0GHz/500G HDD/4 Gig Ram/550Watt PSU/350WattUPS/Firefox-20.0-62.0-70.0/T-bird-2.0.0.24/SnagIt-v10.0.1/MWP-7.12.
W.M.Y.C.
(Always choose the "Custom" Install.)

Mo_D

User avatar
 
Posts: 765
Joined: January 4th, 2006, 6:34 pm

Post Posted December 10th, 2018, 2:10 pm

teh roxxors wrote:
Any very smart person out there know why this happens and how to prevent it?

I'm not a smart person, but I was having this same problem and found a solution.

Normally NoScript will detect all domain/scripts on a page, but for some reason, on Hotmail / Outlook, it doesn't detect ow2.res.office365.com. That domain must be allowed to run scripts manually by going into NoScripts' preferences and pasting that URL to the Whitelist.

I'm still using the pre-quantum NoScript. It may work different in the current version.

Also, I learned of this through the NoScript forum in a post in French language, and in that case, it was: "ow1.res.office365.com". If you right-click on the Hotmail page and choose "view source", you can find the URL for the script in your region.

therube

User avatar
 
Posts: 20559
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted December 12th, 2018, 7:05 pm

On, https://outlook.live.com/owa/, NoScript sees: live.com, msecdn.net, & office365.com.

NoScript defaults to only allowing live.com.
With that, the https://outlook.live.com/owa/ page appears "blank".

Not sure if msecdn.net is actually needed, but by allowing office365.com, the page the displays, allowing you to click, 'login', where you can enter your UN/PW... and login, successfully. (My second time, now - ever, at "outlook.com".)
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 7 guests