MozillaZine

[SOLVED] Kill Sticky removes scrollbar

User Help for Mozilla Firefox
scubscub
 
Posts: 30
Joined: December 5th, 2008, 10:30 am

Post Posted December 29th, 2018, 8:48 pm

Hello,

There is an annoying trend in web design to create "sticky" elements which stay on the screen and do not scroll, thus removing screen space from the control of the user; fortunately, I have found the Kill Sticky add-on which eradicates all this with one click (usually):

https://addons.mozilla.org/en-US/firefo ... ll-sticky/

Unfortunately, every now and then using Kill Sticky also removes the scrollbar from the side of the browser, making the page impossible to navigate.

How can I avoid this? I am thinking (without any real knowledge) that the pages in question are taking control of my scrollbar somehow, and when they are over-ridden, the scrollbar disappears. Is there any way to prevent this behavior?

Thanks for any help!
Last edited by scubscub on January 6th, 2019, 5:55 pm, edited 1 time in total.

makaiguy

User avatar
 
Posts: 16698
Joined: November 18th, 2002, 6:44 pm
Location: Somewhere in SE USA

Post Posted December 29th, 2018, 9:25 pm

When this happens will your up- and down-arrow and Page_Up and Page_Down keys allow you to scroll?
Doug Wilson, "The Makai Guy"
Win10 (64bit): FF 52.9.0 ESR (64bit), TB 60.6.0 (32-bit) ║ Android 8.0/7.1.1: FF Mobile 65.0.1 No TB for Android available, dammit!
What a fool believes he sees, no wise man has the power to reason away - Doobie Brothers

scubscub
 
Posts: 30
Joined: December 5th, 2008, 10:30 am

Post Posted December 30th, 2018, 10:59 am

They do not.

I found an example of such a page: https://www.sapiens.org/culture/table-m ... s-hadzabe/

On scrolling through the article, a pop-up appears over the text; I see now that the scrollbar has already disappeared when the pop-up appears, and when hitting kill-sticky the popup disappears but the scrollbar does not return.

jscher2000

User avatar
 
Posts: 10432
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted December 30th, 2018, 11:09 am

"Modal" overlays that take over the viewport hide the scrollbar to force you to give them your attention. I think LinkedIn also does that (so you log in). You should try dismissing that kind of overlay by hand using its close button, if you can, or use a tool that understands how they work.

scubscub
 
Posts: 30
Joined: December 5th, 2008, 10:30 am

Post Posted December 30th, 2018, 10:57 pm

Thank you. Is there a way to block this kind of overlay?

jscher2000

User avatar
 
Posts: 10432
Joined: December 19th, 2004, 12:26 am
Location: Silicon Valley, CA USA

Post Posted December 30th, 2018, 11:26 pm

scubscub wrote:Is there a way to block this kind of overlay?

Not that I'm aware of.

Benjamin Markson

User avatar
 
Posts: 377
Joined: November 19th, 2011, 3:57 am
Location: en-GB

Post Posted December 31st, 2018, 2:36 am

I don't have a magic bullet for the overlays (except to block them on a case by base basis) but I preserve my scrollbars using this:

Code: Select all
body {overflow: visible !important;}

I use Stylish (for earlier versions), Stylus (for later versions since later versions of Stylish went 'rogue')

Ben.
XUL is dead. Long live the Google Chrome Clones.

scubscub
 
Posts: 30
Joined: December 5th, 2008, 10:30 am

Post Posted January 2nd, 2019, 5:58 pm

Thank you! So I have this snippet of code... where do I paste it? (sorry for the dumb question)...

scubscub
 
Posts: 30
Joined: December 5th, 2008, 10:30 am

Post Posted January 6th, 2019, 5:53 pm

Well, I found the answer to how to use the script. I installed tha add-on Stylus, clicked on the S icon on Firefox, then clicked on "manage," then on "Write New Style." I copied and pasted the script into this and saved it. The default setting is that the script is applied to all pages, and so far this seems to be working.

Return to Firefox Support


Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 22 guests