MozillaZine


Firefox is saving ALL images as .webp

User Help for Mozilla Firefox
SeahawksXLVIII
 
Posts: 80
Joined: August 22nd, 2015, 6:33 pm

Post Posted February 26th, 2019, 5:52 pm

This includes PNG files that I uploaded myself to Mediafire! It does not matter of the original image is a jpg or a png, if I try to download it, Firefox "thinks" that it is some weird .webp file that I have no clue on how to open it!

If I copy and paste the direct link to these images in my browser, the URL will end in either .jpg or .png but Firefox still downloads them as this "unknown" format that is .webp! Firefox "thinks" that these images are some weird format that I have never heard of and I am very computer savvy

I already tried both solutions listed here but neither of them worked: https://support.mozilla.org/en-US/quest ... tion-reply

I need these images in PNG like they are supposed to be.

MarkRH

User avatar
 
Posts: 1307
Joined: September 12th, 2007, 2:30 am
Location: Edmond, OK

Post Posted February 27th, 2019, 12:03 am

Link to these images on Mediafire? If you right-click on the image and View Image Info, does is says Type WEBP? Anyway, it seems to completely get rid of WEBP support, need to do the following:

If you really want, can disable WEBP support by changing the following in about:config :
Set `image.webp.enabled` to `false`.
Set `image.http.accept` to `*/*`.
Set `network.http.accept.default` to `text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8`

dickvl

User avatar
 
Posts: 53667
Joined: July 18th, 2005, 3:25 am

Post Posted February 27th, 2019, 5:19 pm

Note that you can leave image.webp.enabled set to true.
That way you can still open (locally saved) WebP images in Firefox.
Only the two above mentioned accept prefs that set what request http headers are send to a website matter in what image type is send by this website.

syldub

User avatar
 
Posts: 7
Joined: January 24th, 2014, 8:44 am

Post Posted October 26th, 2019, 12:08 pm

MarkRH wrote:Set `image.http.accept` to `*/*`.
Set `network.http.accept.default` to `text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8`


This works in Firefow v70 no more.
I still haven't found any solution for this pain.
I don't want .webp images... because I need to export images from website and I want these images to be readable by the default Windows Photo Viewer.

dickvl

User avatar
 
Posts: 53667
Joined: July 18th, 2005, 3:25 am

Post Posted October 26th, 2019, 1:11 pm

If the pref no longer has effect then the website might be doing user interface sniffing and automatically send .webp files to a browser that is known to support this format.

You can test this by using a user agent switching extension to spoof an older Firefox version.

Brummelchen
 
Posts: 4480
Joined: March 19th, 2005, 10:51 am

Post Posted October 26th, 2019, 2:22 pm

get a graphics program which is capable to work with webp
https://insanelab.com/blog/web-developm ... g-gif-png/

therube

User avatar
 
Posts: 21024
Joined: March 10th, 2004, 9:59 pm
Location: Maryland USA

Post Posted October 27th, 2019, 11:32 am

http://www.mediafire.com/file/cneq45eot ... s.png/file

Source is a .png.
Download is still a .png.


Compares exactly.


image.webp.enabled is default, true.
Fire 750, bring back 250.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14 Pinball CopyURL+ FetchTextURL FlashGot NoScript

RobertJ
Moderator

User avatar
 
Posts: 10880
Joined: October 15th, 2003, 7:40 pm
Location: Chicago IL/Oconomowoc WI

Post Posted October 27th, 2019, 11:51 am

.
The original post is 7+ months old.

Locking

.
FF 92.0 - TB 78.13 - Mac OSX 10.13.6

Return to Firefox Support


Who is online

Users browsing this forum: No registered users and 7 guests